disabling "Show live previews of windows in switcher" leads to wrong mouse position while enabling it breaks "Show Desktop" hot corner

Bug #1311323 reported by Ningfei Li
280
This bug affects 96 people
Affects Status Importance Assigned to Milestone
Compiz
Confirmed
Undecided
Unassigned
compiz (Ubuntu)
Triaged
Critical
Unassigned
Nominated for Trusty by Alberto Salvia Novella

Bug Description

A related bug report is here:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1283267
Since that one was already closed and I can't change the status of it, I report this problem here.
Also here:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1306550

compiz: 0.9.11+14.04.20140409-0ubuntu1
unity: 7.2.0+14.04.20140416-0ubuntu1

If disabling "Show live previews of windows in switcher" in ccsm (Unity Plugin --> Swither), minimize a window (let's say firefox or gedit), remaximize it. Then if I want to click somewhere or select text in the window, I have to put the mouse pointer one line above and several charactors left (compared to the real position I want) to do it.

However, if enabling "Show live previews of windows in switcher" , then you cannot use the hot corner to "Show Desktop" (ccsm-->General Options-->Key bindings-->Show Desktop). Set it to BottomLeft (any corner that's not conflict with other key bindings), with "Show live previews of windows in switcher" enabled, you can just use the hot corner to show desktop for once. Then if you check the Show Desktop setting in ccsm, it will be blank (not None but blank, nothing there). You can't use the showdesktop hot corner any more.

This problem started from 13.10 and continues now in 14.04...

Ningfei Li (ningfei)
description: updated
summary: - disabling "Show live previews of windows in switcher" leading to wrong
- mouse position while enabling it breaking "Show Desktop" hot corner
+ disabling "Show live previews of windows in switcher" leads to wrong
+ mouse position while enabling it breaks "Show Desktop" hot corner
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Peter Roos (roospeteristvan) wrote :

Disabling live previews is essential for me, as with the nvidia drivers I get ugly black window contents while minimizing windows. However, this bug also affects me, causing a much greater functionality problem.

Revision history for this message
Ningfei Li (ningfei) wrote :

@Peter
For me, the nvidia driver works well. I have GT650M and I installed the proprietary driver in the source (nidia-331 331.38-0ubuntu7 from the restricted channel, nvidia-setting 331.20-0ubuntu8 and nvidia prime 0.6.2 from the main channel). Before this, I also tried to install the nvidia drive sometime when I was using 13.10. But it didn't work, causing an window corruption. I think I saw somewhere that since 319.XX and later verion, nvidia driver became better, especially for dual graphic card support. Now I can use either intel card or nvidia card and swith them using nvidia-setting (with nivida-prime installed as a request) or using prime-indicator from ppa source.
But here, this problem, wrong mouse position and broken showdesktop hot corner, do exist no mather you are using nvidia card or intel card, single card or dual card...

Revision history for this message
Peter Roos (roospeteristvan) wrote :

Well, I ended up enabling the live previews (as was by default), and disabled the minimizing and unminimizing animations. This way I have a faster workflow, and don't see ugly black squares moving through my screen.

Revision history for this message
Sebastian Ilea (s3b4) wrote :

I have this bug, too in Ubuntu 14.04 64 bit, wuth Unity.

tags: added: trusty
Changed in compiz (Ubuntu):
importance: Undecided → Critical
Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Ongun Arısev (ongunarisev) wrote :

I also have this problem on Ubuntu 14.04 64-bıt with Unity desktop as of 13.1.2015.

Revision history for this message
Sanjeet Arora (sanjeetarrora) wrote :

Even I'm facing the same issue. My laptop has "Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)" and I'm using :-
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
64 bit

Revision history for this message
Alvaro de Lucas (alvarolucas) wrote :

Still there on 16.04 (August 2016)

Revision history for this message
valk (vkhalil) wrote :

+1 still there on 16.04

Revision history for this message
Alvaro de Lucas (alvarolucas) wrote :

+1 same problem on 16.04

Revision history for this message
Picolli (olihui) wrote :

+1 on 16.04.1 64bit
Intel 3rd Gen Core processor Graphics Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x0166 "3rd Gen Core processor Graphics Controller"
Revision: 0x09
Driver: "i915"
Driver Modules: "drm"

Revision history for this message
Anthony Koenada (koenada) wrote :

I am also experiencing this issue. I can confirm the same issue with same results as originally described

Revision history for this message
djipey (jeanpatrick-francoia) wrote :

I'm also having this issue. Ubuntu 16.04, fresh install.

Revision history for this message
Ongun Arısev (ongunarisev) wrote :

Still present in Ubuntu 16.04 64-bit hot corners work with this setting disable, but mouse point is not correct. Is there a workaround for this?

Revision history for this message
dwilches (dwilches) wrote :

Version 17.10, bug still present. Happens randomly and only with maximized windows.
Workaround: drag your window so it is not maximized anymore, and then maximize it again.

Revision history for this message
dwilches (dwilches) wrote :

I mean Ubuntu 17.04 up here ^

Revision history for this message
nshiell (nshiell) wrote :

This bug seems similar to an issue I'm having with XUbuntu (Xfce) in VirtualBox
As I work around I can:
1. Press Crtl+Alt+F6 (to drop down to a TTY)
2. without logging in Press Ctrl+Alt+F7 (or whichever keys you need to get back into your GUI)

Issue seems to go away then

a59ff5 (a59ff5a59ff5)
Changed in compiz:
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson)
Changed in compiz:
status: Fix Released → Confirmed
Changed in compiz (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
James (jameswoodhouseuk) wrote : Re: [Bug 1311323] Ready: disabling ku "Show live previews of windows in switcher" leads to wrong mouse position while enabling it breaks "Show Desktop" hot corner
Download full text (4.8 KiB)

On Tue, 2 Nov 2021, 17:36 Ahmed, <email address hidden> wrote:

> $ cat test.c
> struct foo {
> int len; https://www.webb-dev.co.uk/category/computers/
> int items[];
> };
>
> struct foo *p;
> http://www.compilatori.com/category/technology/
> int main() {
> return 0;
> }
> $ gcc test.c -g -O0 -o test
> http://www.acpirateradio.co.uk/category/computers/
> $ ./gdb -q -nx --data-directory=data-directory ./test -ex 'python
> gdb.parse_and_eval("p").type.target()["items"].type.range()'
> Reading symbols from ./test...
> http://www-look-4.com/category/computers/
> /home/simark/src/binutils-gdb/gdb/gdbtypes.h:435: internal-error:
> LONGEST dynamic_prop::const_val() const: Assertion `m_kind == PROP_CONST'
> failed. http://www.mconstantine.co.uk/category/services/
> A problem internal to GDB has been detected,
> further debugging may prove unreliable.
> Quit this debugging session? (y or n)
> http://www.logoarts.co.uk/category/computers/
>
> This is because the Python code (typy_range) blindly reads the high
> bound of the type of `items` as a constant value. Since it is a
> http://www.iu-bloomington.com/category/computers/
> flexible array member, it has no high bound, the property is undefined.
> Since commit 8c2e4e0689 https://komiya-dental.com/category/computers/
> ("gdb: add accessors to struct dynamic_prop"),
> the getters check that you are not
> http://www.go-mk-websites.co.uk/category/services/ getting a property
> value of the wrong
> kind, so this causes a failed assertion.
> http://www.slipstone.co.uk/category/computers/
>
> Fix it by checking if the property is indeed a constant value before
> http://embermanchester.uk/category/computers/
> accessing it as such. Otherwise, use 0. This restores the previous
> GDB http://fishingnewsletters.co.uk/category/services/
> behavior: because the structure was zero-initialized,
> http://connstr.net/category/computers/ this is what was
> returned before. But now this behavior is explicit and not
> accidental. But now this behavior is explicit and not accidental. But now
> this behavior is explicit and not
> http://the-hunters.org/technology/new-robot/ accidental. But now this
> behavior is explicit and not accidental. But now this behavior is explicit
> and is explicit and not accidental.
> http://joerg.li/category/computers/
> Add a test, gdb.python/flexible-array-member.exp, that is derived from
> gdb.base/flexible-array-member.exp.
> http://www.jopspeech.com/category/computers/ It tests the same things,
> but
> through the Python API. It also specifically tests getting the range
> from the various kinds
> http://www.wearelondonmade.com/category/computers/ of flexible array
> member types (AFAIK it wasn't
> possible to do the equivalent through the CLI).
> https://waytowhatsnext.com/category/computers/
>
> gdb/ChangeLog:
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1311323
>
> Title:
> disabling "Show li...

Read more...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers