yad notification icon does not display in notification area, therefore losing functionality

Bug #1305835 reported by Paddy Landau on 2014-04-10
58
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu does not display the notification icon for yad, which means that its extremely useful functionality no longer works. It affects many scripts.

To duplicate the problem:

1. Install yad from pp:webupd8team/y-ppa-manager.

2. Open a terminal or Alt-F2 and enter the following two lines.

yad --notification --listen
menu:Proceed!gedit|Cancel!quit

3. No notification appears in the notification area. Ubuntu is supposed to display yad's icon, allowing the user-specified menu to show when the icon is clicked.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz-core 1:0.9.11+14.04.20140409-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 10 13:21:58 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0492]
InstallationDate: Installed on 2014-04-10 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
MachineType: Packard Bell oneTwo L5861
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic root=UUID=b1df1a4b-22ce-47ef-b4e2-ca44a15c2afa ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/08/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A4
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: oneTwo L5861
dmi.board.vendor: Packard Bell
dmi.chassis.type: 3
dmi.chassis.vendor: Packard Bell
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A4:bd03/08/2011:svnPackardBell:pnoneTwoL5861:pvr:rvnPackardBell:rnoneTwoL5861:rvr:cvnPackardBell:ct3:cvr:
dmi.product.name: oneTwo L5861
dmi.sys.vendor: Packard Bell
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Apr 10 12:26:44 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 257
 vendor ACR
xserver.version: 2:1.15.0-1ubuntu7

Paddy Landau (paddy-landau) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Andrea Azzarone (azzar1) wrote :

Tray icons are no longer supported by unity. Marking as won't fix.

Changed in unity:
status: New → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Won't Fix
Changed in unity:
status: Invalid → Won't Fix
Changed in compiz (Ubuntu):
status: Won't Fix → Invalid
Changed in unity (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.