hot corners stop working time to time

Bug #1305438 reported by Ruchir on 2014-04-10
258
This bug affects 55 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to ubuntu 14.04, time to time hot corners stop working. I have to disable and enable again from unity tweak tool to make it working again.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz-core 1:0.9.11+14.04.20140408-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 10 11:38:48 2014
DistUpgraded: 2014-04-07 11:18:00,385 DEBUG failed to SystemUnLock() (E:Not locked)
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 6.30.223.141+bdcom, 3.13.0-23-generic, x86_64: installed
 virtualbox, 4.3.10, 3.13.0-23-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0434]
Lsusb:
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0c45:6461 Microdia
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Inspiron 1464
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic root=UUID=63447271-280d-41b9-8d35-1670541ea71c ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to trusty on 2014-04-07 (3 days ago)
dmi.bios.date: 03/29/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A13
dmi.board.name: 0C6HFD
dmi.board.vendor: Dell Inc.
dmi.board.version: A13
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A13
dmi.modalias: dmi:bvnDellInc.:bvrA13:bd03/29/2011:svnDellInc.:pnInspiron1464:pvrA13:rvnDellInc.:rn0C6HFD:rvrA13:cvnDellInc.:ct8:cvrA13:
dmi.product.name: Inspiron 1464
dmi.product.version: A13
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.11+14.04.20140408-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Apr 10 11:32:23 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4156
 vendor AUO
xserver.version: 2:1.15.0-1ubuntu7

Ruchir (ruchir-brahmbhatt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

Same problem with a fresh install of 14.04. I installed unity tweak and enabled a hot corner, which worked fine. But after a log out or reboot it no longer works and I must disable it and then enable it in order for the feature to work again.

Cole (cole-h-cohen) wrote :

Same issue with 14.04 upgraded from 13.10. The hotcorners consistently reset on reboot, and it's fixed when turned off and on in Tweak Tool.

Dmitry Tuykov (d-touikov) wrote :

Hot corners are not working after some time.
After reboot or disable/enable hot corners via unity tweak tool - all OK.

Kristijan (lapor) wrote :

I hope this will get fixed, because I cannot move some computers from 12.04 to 14.04. People really got used to it...

Michał Sawicz (saviq) wrote :

As stated in the related question (https://answers.launchpad.net/ubuntu/+question/243724) this seems to be caused by "show live previews in spread" option for the unity plugin.

Dmitry Tuykov (d-touikov) wrote :

Disabling of "show live previews in spread" helps but not always. Active corners are not working after some time.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

This *might* be a duplicate of bug #1063617 or at least affected by the same issue. It's not clear from the details of this bug if that is the case though.

I have a test version of Compiz in https://launchpad.net/~townsend/+archive/compiz-settings-reset-fix that fixes the resetting of custom shortcuts. If anyone affected by this bug could try that test Compiz package and report back here if it fixes the issue for them or not, that would be greatly appreciated.

Thanks!

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
importance: Undecided → Medium
aloisam (a-musil) wrote :

→ Christopher Townsend (townsend)

I added your ppa, but bug persist. Ubuntu 14.04 32bit.
Unfortunately this is only solution so far, that is working for me:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/858845/comments/59

monkeybrain2012 (kammon101) wrote :

The corners are working in 13.10 after disabling auto plugin sorting and ordering the plugins in cetain ways. I use scale, expo and wall flippng. In 13.10 expo can be placed anywhere, wall has to be at the bottom for the edges to be renembered. scale has to be close to the bottom for the hot corner to be remmebered.

But then when 14.04 comes out this doesn't work anymore. Now expo has to be at the very bottom, and for some reasons scale has to be above unity-shell in the list or triggering scale would kill unity instantly. scale and wall still have to be close to the bottom. This doesn't leave much room. After some trial and error only ordering that works is scale > unity > scale addon > wall > expo in descending order and expo at the very bottom.

This has been working for some times and then after reccent unity updated from 7.2.0 to 7.2.1 scales stops remembering corner (it also break other things) so I downgraded it and it works again. Then since yesterday scale has suddenly stopped working and I have still no clue why.

It is really gettng very frustrating. These bugs have been around in one variation or other since 12.04 (or before), they never get fixed but everytime when a new Ubuntu release comes out they move things around in such a way that it breaks workarounds that previously works.

P.S. Christopher Townsend's PPA does not work, scale still doesn't remember corners.

monkeybrain2012 (kammon101) wrote :

Disabling "SHOW LIVE PREVIEWS OF WINDOWS IN THE SWITCHER" may work for show desktop, but I don't use it so I can't tell. However it doesn't work on scale's hot corner on reboot. You still have to log out and then log in again for the corner to activate, but then you may as well restart Unity, it is faster (without disabling "show live preview" logout and login doesn't work at all)

My previous workaround a few months ago doesn't seem to work anymore, mostly lilkely thanks to some updates along the way (tested with different hard drives). https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/858845/comments/59 Half of the times unity just doesn't start properly and have to manually shut down, on reboot it goes through disk checking and what not. It seems that somehow for whatever reason the file system get corrupted if restarting Unity doesn't complete successfully at start up (manually restarting after login is OK) Have reformatted and restore from last working image many times since last night. Well if they don't fix something at least don't screw it up with updates, now I have no idea which update is the culprit.

aloisam (a-musil) wrote :

@monkeybrain2012
Delay launching of your script. I've added this line:
X-GNOME-Autostart-Delay=6
in to the appropriate .desktop file in ~/.config/autostart folder.
And ist's working again.
But it is still very disappointing, it seems like this bug is getting worse, not better...

Gabriel Ionescu (justoneslave) wrote :

Bug got indeed worse after updating to 15.04.

Christian MATHIEU (kikito63) wrote :

this little script works fine for me:

Christian MATHIEU (kikito63) wrote :

oops, sorry, forgot script :

#!/bin/bash
# tentative de parade à ce p****n de scale de unity qui démarre pas toujours !
# noCopyRight Christian MATHIEU le 01/01/2015
# script en démarrage auto
sleep 1
scaleAll=$(dconf read /org/compiz/profiles/unity/plugins/scale/initiate-all-edge)
sleep 1
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-all-edge "'bug'"
sleep 1
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-all-edge $scaleAll
exit 0

I had the same problem with a clean 14.04 installation. However, I changed my drivers from the open source (xserver-xorg-video-ati) to the propietary driver (fglrx-updates), and the hot corners seem to work everytime I reboot. I have a HD Radeon 7670M graphics card.

Gabriel Ionescu (justoneslave) wrote :

For me it is fixed in 15.10. Anyone can confirm?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
Robert Smith (rsmith31415) wrote :

Would it be possible to reopen this issue? I have installed Ubuntu 16.04 and this feature doesn't work reliably. Sometimes you can make it work by clicking on the desktop immediately after booting.

Let me know what information you need to solve this issue.

Hot corner problem still persists on Ubuntu 16.04.

Dimas Ari (inchidi) wrote :

+1 on Ubuntu 16.04 hot corners not working
temporary fix with command `compiz --replace` on startup
but hot corners suddenly not working again after few minutes
(possibility after full screen any apps / after installing apps)

To post a comment you must log in.