[Regression] Window titlebars placed behind panel

Bug #1303462 reported by Alfred E. Neumayer on 2014-04-06
438
This bug affects 127 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
0.9.11
High
Christopher Townsend
Unity
Invalid
Medium
Unassigned
compiz (Ubuntu)
High
Christopher Townsend
Trusty
High
Unassigned

Bug Description

[Impact]

Some windows that open from within another window such as a Firefox popup window will be placed with the decorations under the Panel. Also, some windows will just open with the decoration under the Panel such as virt-manager. This can cause confusion for the user on how to move the window and how to close it. This can be very disruptive to a user's workflow.

[Test case]

1. Install virt-manager.
2. Make sure no other windows are open.
3. Start virt-manager.

virt-manager should start in the top left. With this fix, the decoration should be visible.

[Regression potential]

None identified.

* Debdiff is found at https://launchpadlibrarian.net/178439518/compiz-trusty-sru-2.debdiff *

Original description:

Windows with a height of (Display Height - Panel Height) get placed at y=0 (behind the top panel)
which means window titlebars are not reachable without alt-moving the window.
I assume this happens with windows that want to resize themselves if their height exceeds the display resolution.
Reproducable on my 1366x768 screen with LibreOffice and a Qt 5 desktop application I'm working on.

TEMPORARY WORKAROUND:
Use the Cntrl+SuperKey+Right or Left Arrow Key
This will resize your currently focused window to occupy the Right (Left) half of the screen. The Title Bar should now be visible, so you need to drag it and resize it at your prefered position. This will save the new position in place of the previously hidden state.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140403-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Sun Apr 6 21:45:41 2014
InstallationDate: Installed on 2014-04-04 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140404)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alfred E. Neumayer (beidl) wrote :
description: updated
Adolfo Jayme (fitojb) on 2014-04-06
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: new-decorations ubuntu-desktop-trusty
Pere Ubu (pereubu) wrote :

I have the same problem, when firefox opens pop-up windows.
They always opens with the titlebar hidden under the top-panel.

Pere Ubu (pereubu) wrote :

You can see a screendump of it here:
http://ubuntuone.com/2K26eo3Hu5RrmekiwMxlod

Adolfo Jayme (fitojb) on 2014-04-09
Changed in unity (Ubuntu):
milestone: none → ubuntu-14.04
tags: added: rls-t-incoming
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1303462

tags: added: iso-testing
Stephen M. Webb (bregma) on 2014-04-12
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in compiz:
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
status: Triaged → Invalid
Atul (atulkakrana) wrote :

I am still facing this problem on Final Trusty release. Damn this old bug made my life hell 2 years back and now again.

Atul

Adolfo Jayme (fitojb) wrote :

Indeed, this is a regression by the new decorations.

Changed in unity (Ubuntu):
milestone: ubuntu-14.04 → trusty-updates
Max (fmax1282) wrote :

I have the same problem when open all LibreOffice app.

I have this issue when Firefox launches a new window. :'(

Stephen M. Webb (bregma) on 2014-04-21
Changed in unity:
milestone: none → 7.2.1

I have this problem too, but this is not related to LibreOffice, this happens to me with other apps, like Firefox. This bug is so annoying. Hopefully, you can drag the window by holding Alt, I mean, you can move the window while pressing Alt from any position of the window that you want to drag.

John M.K. (jconni) on 2014-04-23
description: updated
description: updated
Wal (trees5353) wrote :

This bug also affects "Image Viewer". When pictures are opened and then the page maximised the "maximise, minimise, close" buttons slip up under the top panel and cannot be accessed.

Aaron Whiticar (awhiticar) wrote :

the best workaround I have come up with is:
- install compizconfig-settings-manager from the software center
- run compizconfig-settings-manager
- go to place windows
- go to fix windows placement tab
- create new (windows with fixed positions)
- window postion: class= "the program that is loading in the wrong position"
- X=65
- Y=55
then close
 repeat as needed for all program causing problems and adjust X & Y based on you launcher and panel scaling.
some time you have to restart for the setting to take effect.

hope this helps
cheers!
Whitaar

Wal (trees5353) wrote :

Thank You Whitaar that workaround worked like a charm and fixed all my misbehaving windows on all of my PC's. Your help is very much appreciated.

Cheers Wal

Paul White (paulw2u) on 2014-05-03
tags: added: utopic
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
importance: Medium → High
milestone: none → 0.9.11.0
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Stephen M. Webb (bregma) on 2014-05-08
Changed in unity:
milestone: 7.2.1 → none
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Trusty):
status: New → Confirmed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.10.20140606-0ubuntu1

---------------
compiz (1:0.9.11+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Only ungrab the Mod2Mask modifier on buttons 4-7 to allow scrolling
    in unfocused Gtk windows while still allowing keybinding modifiers
    to other scroll wheel actions. (LP: #1311788)
  * Fix issue where window decorations would be placed under the Panel
    when opening a new window from an already open window. This is due
    to the already open window being taller or just as tall without be
    maximized than the workspace. (LP: #1303462)
  * Only constrain the non-modifier scrolling to the vertical scrolling
    buttons - buttons 4 & 5. (LP: #1311303)
  * Fix issue where maximized windows would get moved to different
    workspaces when disconnecting/connecting an external monitor.
    Windows should stay in the same workspace they are in when the
    monitor event occurs. (LP: #1304531)
  * Fix issue where custom keyboard shortcuts would get reset to
    defaults when rebooting or restarting Compiz. (LP: #1063617)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Fix issue where horizontal and vertical keyboard resizing could not
    happen at the same time. (LP: #347390)

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
  * Event: set the screen grabbed also when we get a NotifyWhileGrabbed
    Focus{In,Out} event (LP: #1305586)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 09:43:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) on 2014-06-06
Changed in compiz (Ubuntu Trusty):
importance: Undecided → High
Changed in compiz:
milestone: 0.9.11.0 → 0.9.12.0
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
milestone: trusty-updates → none

Attaching the debdiff for the Compiz Trusty SRU.

description: updated

Hello Alfred, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140617-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

I've checked the described Test Case with virt-manager and the window appears in top left corner with window decoration fully visible.

I also didn't have any problems with gnome-disk-utility, Firefox, Chrome, Image Viewer and LibreOffice.

Download full text (3.2 KiB)

​Hi,

did several tests, everything seems to be fine now.

Best regards,
Jhonny Oliveira

On Fri, Jun 20, 2014 at 5:58 PM, Mateusz Stachowski <
<email address hidden>> wrote:

> I've checked the described Test Case with virt-manager and the window
> appears in top left corner with window decoration fully visible.
>
> I also didn't have any problems with gnome-disk-utility, Firefox,
> Chrome, Image Viewer and LibreOffice.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1303462
>
> Title:
> [Regression] Window titlebars placed behind panel
>
> Status in Compiz:
> Fix Committed
> Status in Compiz 0.9.11 series:
> In Progress
> Status in Unity:
> Invalid
> Status in “compiz” package in Ubuntu:
> Fix Released
> Status in “compiz” source package in Trusty:
> Fix Committed
>
> Bug description:
> [Impact]
>
> Some windows that open from within another window such as a Firefox
> popup window will be placed with the decorations under the Panel.
> Also, some windows will just open with the decoration under the Panel
> such as virt-manager. This can cause confusion for the user on how to
> move the window and how to close it. This can be very disruptive to a
> user's workflow.
>
> [Test case]
>
> 1. Install virt-manager.
> 2. Make sure no other windows are open.
> 3. Start virt-manager.
>
> virt-manager should start in the top left. With this fix, the
> decoration should be visible.
>
> [Regression potential]
>
> None identified.
>
> * Debdiff is found at
>
> https://bugs.launchpad.net/compiz/+bug/1303462/+attachment/4134214/+files
> /compiz-trusty-sru.debdiff *
>
> Original description:
>
> Windows with a height of (Display Height - Panel Height) get placed at
> y=0 (behind the top panel)
> which means window titlebars are not reachable without alt-moving the
> window.
> I assume this happens with windows that want to resize themselves if
> their height exceeds the display resolution.
> Reproducable on my 1366x768 screen with LibreOffice and a Qt 5 desktop
> application I'm working on.
>
> TEMPORARY WORKAROUND:
> Use the Cntrl+SuperKey+Right or Left Arrow Key
> This will resize your currently focused window to occupy the Right
> (Left) half of the screen. The Title Bar should now be visible, so you need
> to drag it and resize it at your prefered position. This will save the new
> position in place of the previously hidden state.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140403-0ubuntu1
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14.1-0ubuntu1
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CurrentDesktop: Unity
> Date: Sun Apr 6 21:45:41 2014
> InstallationDate: Installed on 2014-04-04 (2 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64
> (20140404)
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this...

Read more...

Attaching an updated debdiff for the Compiz Trusty SRU.

description: updated
description: updated

Hello Alfred, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140623-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Phill (phill.l) wrote :

That's fixed it, thanks.

I just upgraded with proposed updates enabled, and can confirm that the problem has gone away.

It required a restart (maybe log-out/in would have done it).

Wal (trees5353) wrote :

I can confirm that the packages for this bug in proposed updates have fixed the problem. Once installed just logout and back in and the problem will be gone.

Phonteus Nevolius (phontanka) wrote :

I've just enabled proposed and updated my system. I can also confirm the bug has been fixed.

Thanks!

Hello Alfred, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
removed: verification-done
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.1+14.04.20140701-0ubuntu1

---------------
compiz (1:0.9.11.1+14.04.20140701-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Bump version to 0.9.11.1.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 01 Jul 2014 11:51:26 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released
Jimkont (jimkont) wrote :

My compiz version is compiz:all/trusty-updates 1:0.9.11.1+14.04.20140701-0ubuntu1

but the problem still remains not only in chromium /firefox popup windows but to most common programs I use as well
such as:
* console
* nautilus
* evince

Some programs e.g. Thunderbird that are full screen when I close them, remain full screen on re-open, otherwise they open on the top-left corner
steps to reproduce for Thunderbird

Scenario #1 Thunderbird
- open Thunderbird
- Maximize window
- close
- Re-open Thunderbird
- Thunderbird opens maximized

Scenario #2 Thunderbird
- open Thunderbird
- un- maximize window
  - window goes to top-left
- move window to visible position & close Thunderbird
- open Thunderbird again and window goes to top-left again

Scenario #1 console
- open console
- opens on top-left by default
- Maximize window
- close
- Re-open console
- console *does not* open maximized

Scenario #2 console
- open console
- opens on top-left by default
- move window to visible position & close console
- open console again and window goes to top-left again

Adolfo Jayme (fitojb) wrote :

@Jimkont: the problem referred to in this bug was different to the one you’re posting. Please open a new bug report. Thanks.

Download full text (3.2 KiB)

I think it's the same bug
my windows too go behind the panel (top left)
Some applications (e.g.Thunderbird) do not do this when they are closed
maximized
while many others (e.g. console, evince, nautilus) do this every time I
open them

On Tue, Jul 22, 2014 at 12:11 AM, Adolfo Jayme <email address hidden> wrote:

> @Jimkont: the problem referred to in this bug was different to the one
> you’re posting. Please open a new bug report. Thanks.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1312196).
> https://bugs.launchpad.net/bugs/1303462
>
> Title:
> [Regression] Window titlebars placed behind panel
>
> Status in Compiz:
> Fix Committed
> Status in Compiz 0.9.11 series:
> Fix Committed
> Status in Unity:
> Invalid
> Status in “compiz” package in Ubuntu:
> Fix Released
> Status in “compiz” source package in Trusty:
> Fix Released
>
> Bug description:
> [Impact]
>
> Some windows that open from within another window such as a Firefox
> popup window will be placed with the decorations under the Panel.
> Also, some windows will just open with the decoration under the Panel
> such as virt-manager. This can cause confusion for the user on how to
> move the window and how to close it. This can be very disruptive to a
> user's workflow.
>
> [Test case]
>
> 1. Install virt-manager.
> 2. Make sure no other windows are open.
> 3. Start virt-manager.
>
> virt-manager should start in the top left. With this fix, the
> decoration should be visible.
>
> [Regression potential]
>
> None identified.
>
> * Debdiff is found at https://launchpadlibrarian.net/178439518/compiz-
> trusty-sru-2.debdiff *
>
> Original description:
>
> Windows with a height of (Display Height - Panel Height) get placed at
> y=0 (behind the top panel)
> which means window titlebars are not reachable without alt-moving the
> window.
> I assume this happens with windows that want to resize themselves if
> their height exceeds the display resolution.
> Reproducable on my 1366x768 screen with LibreOffice and a Qt 5 desktop
> application I'm working on.
>
> TEMPORARY WORKAROUND:
> Use the Cntrl+SuperKey+Right or Left Arrow Key
> This will resize your currently focused window to occupy the Right
> (Left) half of the screen. The Title Bar should now be visible, so you need
> to drag it and resize it at your prefered position. This will save the new
> position in place of the previously hidden state.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140403-0ubuntu1
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14.1-0ubuntu1
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CurrentDesktop: Unity
> Date: Sun Apr 6 21:45:41 2014
> InstallationDate: Installed on 2014-04-04 (2 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64
> (20140404)
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this ...

Read more...

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released

Easy Peasy Solution

You need to set the appropriate option in the Compiz Place Windows plugin.

    Open CCSM (make sure you have it installed first).
    Find the Place Windows plugin:
    CSSM
    Now, in the options, make sure that smart placement is selected.
    Smarty

This option is usually set by default, but sometimes for some reason it is not. I am not 100% certain as to the cause (still trying to find it). If you do not have the place windows plugin, make sure to check that you have any additional compiz plugins installed in the software centre.

maedox (paal-nilsen) wrote :

Old bug, but I thought I'd chime in with the reason I found it. I had some issues with screen flickering so I used the reset to default feature in CCCP to see if it would help. It was unrelated, but the "Place windows" plugin was disabled by this action and windows started opening in the top left corner underneath the top panel.

peddanet (peter-wein) wrote :

The bug is now active again for me in 16.04, but the workaround from post #11 works from Aaron, but this is not very satidsfying...The default position of a new window with fixed position is set to [-32768, -32768]...

To post a comment you must log in.