Blur effect on whole screen

Bug #1294762 reported by Marvin Janosch on 2014-03-19
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
NVIDIA Drivers Ubuntu
Undecided
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

Using Ubuntu 14.04, Compiz seems to apply a blur effect on the whole screen. Fresh updated display areas get transitional blurrier.

Behavior applies to the Unity Desktop and all desktop apps like Chrome, the Terminal, Steam Client but not on OpenGL games or Flash content and affects window borders, texts, images and all UI elements except the mouse cursor. -> see attachment

Nvidia proprietary drivers are in use.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11+14.04.20140310-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-16ubuntu6)
.tmp.unity.support.test.0:

ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Wed Mar 19 18:05:00 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-17-generic, x86_64: installed
 bbswitch, 0.7, 3.13.0-18-generic, x86_64: installed
 nvidia-331-updates, 331.38, 3.13.0-17-generic, x86_64: installed
 nvidia-331-updates, 331.38, 3.13.0-18-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GT215M [GeForce GTS 250M] [10de:0ca9] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff50]
InstallationDate: Installed on 2014-03-16 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140316)
MachineType: TOSHIBA QOSMIO X500
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-18-generic root=UUID=ba85cdbb-19f2-40d5-85d3-b6f5a031d224 ro nomodeset quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/10/2010
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V2.90
dmi.board.name: QOSMIO X500
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV2.90:bd12/10/2010:svnTOSHIBA:pnQOSMIOX500:pvrPQX33E-015009GR:rvnTOSHIBA:rnQOSMIOX500:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: QOSMIO X500
dmi.product.version: PQX33E-015009GR
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.11+14.04.20140310-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Mar 19 16:49:11 2014
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.0-1ubuntu7

Marvin Janosch (janosch.koeln) wrote :
Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
no longer affects: compiz

It affects an essential hardware component (disk controller, built-in networking, video card, keyboard, mouse).

Changed in compiz (Ubuntu):
importance: Undecided → High

What happens if you turn off NVIDIA proprietary drivers?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Marvin Janosch (janosch.koeln) wrote :

Nouveau still seems no to support the GTS 250M and only runs in a 640sh resolution and every thing seems to be software rendered. I can't clearly state if the blur effect still applies due to the over all low resolution, but I think the described problem isn't applying in this case.

Furthermore the problem comes in sporadically under the proprietary drivers. I couldn't find the trigger for the wrong display behavior.

Changed in compiz (Ubuntu):
status: Incomplete → Triaged
Tom Goeckel (norak2) wrote :

I had to switch to the 304.117 drivers to get rid of the problem. Seems to be related to the 331.38 drivers from NVIDIA.

With 304.117 drivers my gt650M does not work. Black screen. In safegraphics mode same.

Andrzej Golonka (wiecznywem) wrote :

I have exactly the same problem. GTX570, 331.38, Ubuntu 14.04

It may helps: before, when I used 12.10 lts I saw a few times this bug when I have done something to compiz(I don't remeber what exacly, maybe kill or run some effect)

Andrzej Golonka (wiecznywem) wrote :

It depends of configuration files because on guest session everything seems to be okay.

Marvin Janosch (janosch.koeln) wrote :

Can confirm, other sessions like the guest session aren't affected.

Andrzej Golonka (wiecznywem) wrote :

There is a problem. Before, to repair this, I've created new user. But this morning the problem affected me again. Now, only my desktop and my all windows are blurred. The unity dash seems to be okay. Yesterday everything was okay, so please tell me how I can get useful log information for you.

Andrzej Golonka (wiecznywem) wrote :

Okay, I figured out the reason.

When in the "nvidia-settings" in antialiasing settings, the field "Enable FXAA" is enabled, the problem affects. If I turned it off, everything will be okay.

To see every change I need to restart computer.

Marvin Janosch (janosch.koeln) wrote :

Thought on something like that but seem to missed that one.

Disabling FXAA in the Nvidia driver fixes the problem (thanks Andrzej) but still, we know now Nvidia's FXAA is buggy.

Ivo (van-hoi) wrote :

Can confirm that turning Anti-Aliasing off fixes the problem, thanks Andrzej!
If I can be of help by by giving some log information, please let me now!

To post a comment you must log in.