Some of the input fields are blank in CompizConfig Settings Manager

Bug #1294341 reported by Doctor Rover on 2014-03-18
58
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Users trying to use Compiz Config Settings Manager (CCSM) cannot see some of the fields' values. Also, due to this issue, some values will automatically reset to a value not set by the user.

This can cause much user frustration when trying to set values in CCSM and can cause behaviors not intended by the user.

[Test Case]

To reproduce:
* Open CCSM by either typing "ccsm" in the command line or finding it in the Dash.
* Browse different settings and notice some of the values are missing in the input boxes. For example, General Options->Edge Trigger Delay is blank.

[Regression Potential]

None identified.

Original Description:

Input fields of some of the parameters in CompizConfig Settings Manager are blank. It is possible to modify them by typing a value or by pressing up/down buttons next to the input field. But leaving the particular plugin and returning back leads to the input fields being blank again.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compizconfig-settings-manager 1:0.9.11+14.04.20140310-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Wed Mar 19 00:14:55 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff50]
   Subsystem: Toshiba America Info Systems Device [1179:ff50]
InstallationDate: Installed on 2014-01-27 (50 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140124)
MachineType: TOSHIBA Satellite U400
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-18-generic root=UUID=ade20c72-1376-4808-b6fb-4b0c1cdba8c8 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/12/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V3.00
dmi.board.name: Satellite U400
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV3.00:bd07/12/2008:svnTOSHIBA:pnSatelliteU400:pvrPSU40E-02000FRU:rvnTOSHIBA:rnSatelliteU400:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite U400
dmi.product.version: PSU40E-02000FRU
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.11+14.04.20140310-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Tue Mar 18 23:43:31 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 14145
 vendor SEC
xserver.version: 2:1.15.0-1ubuntu7

Related branches

Doctor Rover (doctor-rover) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 0.9.11.0
description: updated
Changed in compiz:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Trusty):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

It seems the automated message did not reach here.

The updated version is now in proposed: https://launchpad.net/ubuntu/trusty/+source/compiz/1:0.9.11+14.04.20140423-0ubuntu1

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Doctor Rover (doctor-rover) wrote :

I confirm that the bug has been fixed.
compiz version is 1:0.9.11+14.04.20140423-0ubuntu1

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140423-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Ryan Tandy ]
  * Fix gnome-flashback session starting Unity plugins. Change the
    profile back after processing settings upgrades. When changing
    profile, discard existing GSettings wrappers pointing to the old
    profile. (LP: #1232299)

  [ Chris Townsend ]
  * Remove the Number of Desktops option in CCSM as this option confuses
    Compiz and is really no longer needed since the Horizontal/Vertical
    Virtual Desktop Size is what is used for determining the size. (LP:
    #1289820)
  * Due to some change in Gtk SpinButton, setting the initial value in
    Adjustment does not work for integers, so now just explicitly set
    the value after the SpinButton is created. (LP: #1294341)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 14:56:06 +0000

Changed in compiz (Ubuntu Trusty):
status: Confirmed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140423-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Ryan Tandy ]
  * Fix gnome-flashback session starting Unity plugins. Change the
    profile back after processing settings upgrades. When changing
    profile, discard existing GSettings wrappers pointing to the old
    profile. (LP: #1232299)

  [ Chris Townsend ]
  * Remove the Number of Desktops option in CCSM as this option confuses
    Compiz and is really no longer needed since the Horizontal/Vertical
    Virtual Desktop Size is what is used for determining the size. (LP:
    #1289820)
  * Due to some change in Gtk SpinButton, setting the initial value in
    Adjustment does not work for integers, so now just explicitly set
    the value after the SpinButton is created. (LP: #1294341)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 14:56:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Alexis Wilke (alexis-m2osw) wrote :

I suppose this was not back ported to 13.10, correct?

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers