'Move to Another Workspace' causes window to disappear

Bug #1289820 reported by Jesse Johnson on 2014-03-08
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

If users set the wrong setting in Compiz Config Settings Manager (CCSM), it is possible for a users window to disappear when using "Move to Workspace X" when right clicking on a windows decoration.

This can make seem like the user has lost their window and force the user to potentially loose any unsaved works if they can't figure out how to recover the window.

[Test Case]

To reproduce:
* Open CCSM by either typing "ccsm" in the command line or finding it in the Dash.
* Go to General Options->Desktop Size.
* Enter some number > 1 for "Number of Desktops".
* Right click on the decoration of a window and select "Move to Workspace Right".
* Watch the window disappear with no trace.

After applying this fix:
* The "Number of Desktops" option should be gone.

[Regression Potential]

For Ubuntu running Unity, none identified.
Very small chance that some other desktop environment may use this setting, but none of the major desktop environments use it.

Original description:

When using the 'Move to Another Workspace' right-click option on a window, the window disappears from the current workspace, but is not present in any other workspace. It effectively is no longer accessible, though it can still be killed. Disabling workspaces does not cause the lost window to reappear, but setting the number of desktops to 1 in CCSM > General Options > Desktop Size > Number of Desktops does the trick and the window reappears.

I am using Ubuntu 14.04 (latest updates as of 2014-03-07) and NVIDIA proprietary drivers. I do not experience this problem on Ubuntu 13.04.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20140305-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Sat Mar 8 11:47:54 2014
InstallationDate: Installed on 2013-12-31 (66 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131228)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jesse Johnson (holocronweaver) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is that still an issue? Does it happen every time? What screens/workspaces configuration do you use?
I can't confirm the issue here

Jesse Johnson (holocronweaver) wrote :

Yes, it is still an issue and happens every time. I have been dealing with it since I first installed 14.04 back in early January 2014.

It happens whether I use System Settings > Appearance > Behavior > Enable workspaces, or manually configure workspaces using CCSM > General Options > Desktop Size (which I normally do since I prefer a flat horizontal workspace to avoid windows crossing workspaces).

I should mention that the window disappears even if I send it to the workspace it is already on.

I could not reproduce this issue in a fresh install of Ubuntu 14.04 in VirtualBox, so it may be specific to my GPU drivers or compiz config.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

It's estimated to have a moderate impact on a large portion of Ubuntu users.

Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Christopher Townsend (townsend) wrote :

I've been looking at this and it seems this occurs when setting ccsm->General Options->Desktop Size->Number of Desktops to some value other than 1. I'm thinking that setting may not be needed anymore, but I still need to investigate.

affects: unity → compiz
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: New → Triaged

Yup that's what I did. Changed that back to one and my test window popped up! i noticed something else while testing that, don't know if its related. I've noticed that if you have the same window open on different desktops the launcher spread can't see the ones on other desktops.

Christopher Townsend (townsend) wrote :

Hi Corey,

Regarding the Spread on windows on different workareas, it is by design to only show windows in Spread for the current desktop.

Jesse Johnson (holocronweaver) wrote :

I too can confirm that setting the number of desktops to 1 in CCSM fixes the issue.

ronin12 (ronin12) wrote :
  • fd Edit (123.9 KiB, application/octet-stream)

I may have simmilar issue here when I restore my firexox browser. (after suspend mode gone wrong. switch on firefox and restore all windows)

I use few different windows of firefox at the same time.

I try to organize/spread different firefox windows, for ex.: using ctr+alt+arrow down (move it down).

After that when I am going back to the previous workspace the moved window appear back on the origin workspace.

It looks like Ubuntu get confused about nummbering the workspaces.
The window is positioned out of the screen (see attached file)

ronin12 (ronin12) wrote :

I am using 4 workspaces. I have changed nummbergin (swap workspace 3 with 4) and also I have changed shortcuts for getting to workspaces: I use alt+1, alt+2 to get to desirable workspace.
Thanks

Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
milestone: none → 0.9.11.0
description: updated
Changed in compiz:
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

It seems the automated message did not reach here.

The updated version is now in proposed: https://launchpad.net/ubuntu/trusty/+source/compiz/1:0.9.11+14.04.20140423-0ubuntu1

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Trusty):
status: New → Confirmed
Ryan Tandy (rtandy) wrote :

Reproduced in trusty following the test case in the description. After installing compiz from precise-proposed, the option is gone and the Send to Workspace actions no longer appear, regardless of what it was set to before. Marking verified.

tags: added: verification-done
removed: verification-needed
Changed in compiz (Ubuntu Trusty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140423-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Ryan Tandy ]
  * Fix gnome-flashback session starting Unity plugins. Change the
    profile back after processing settings upgrades. When changing
    profile, discard existing GSettings wrappers pointing to the old
    profile. (LP: #1232299)

  [ Chris Townsend ]
  * Remove the Number of Desktops option in CCSM as this option confuses
    Compiz and is really no longer needed since the Horizontal/Vertical
    Virtual Desktop Size is what is used for determining the size. (LP:
    #1289820)
  * Due to some change in Gtk SpinButton, setting the initial value in
    Adjustment does not work for integers, so now just explicitly set
    the value after the SpinButton is created. (LP: #1294341)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 14:56:06 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140423-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Ryan Tandy ]
  * Fix gnome-flashback session starting Unity plugins. Change the
    profile back after processing settings upgrades. When changing
    profile, discard existing GSettings wrappers pointing to the old
    profile. (LP: #1232299)

  [ Chris Townsend ]
  * Remove the Number of Desktops option in CCSM as this option confuses
    Compiz and is really no longer needed since the Horizontal/Vertical
    Virtual Desktop Size is what is used for determining the size. (LP:
    #1289820)
  * Due to some change in Gtk SpinButton, setting the initial value in
    Adjustment does not work for integers, so now just explicitly set
    the value after the SpinButton is created. (LP: #1294341)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 14:56:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers