compiz unnecessarily shrinks new windows

Bug #1287472 reported by Paul on 2014-03-04
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Marco Trevisan (Treviño)
compiz (Ubuntu)
Marco Trevisan (Treviño)

Bug Description

Ubuntu 14.04 Trusty, compiz 1:0.9.11+14.04.20140303-0ubuntu1.

The fix for bug 1282304, just released, has introduced the following regression.

Problem: All new non-fullscreen windows are now shrunk by the decoration size. This produces gnome-terminals of 79 columns by 22 rows, and applications that remember their window size when closed shrink further each time.

Expected behaviour: Windows should not be resized unless they exceed the viewport size.

Related branches

PS Jenkins bot: Approve (continuous-integration) on 2014-03-10
Christopher Townsend: Approve on 2014-03-10
Doug McMahon (mc3man) on 2014-03-04
Changed in compiz (Ubuntu):
status: New → Confirmed
POJAR GEO (geoubuntu) wrote :

Indeed, this behavior affects video applications that need to keep aspect ratio in window mode.

Mh, I think I forgot to commit a change that was avoiding this :/

Changed in compiz (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none →
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
importance: Medium → High
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
User Unknown (user-unknown) wrote :

I believe this bug affects me as well, with XFCE4.10 as the DE on Ubuntu 13.10. Whenever I minimize to tray/iconify a window and then restore from tray, the size of the window will shrink by the size of its decoration and title bar. Somehow sounds to me like exactly what's happening in this bug report.

I frequently minimize-to-tray windows such as messengers or mail clients and calendars which makes this issue very annoying.

Likely related are the bugs #1204307 and #1217286 where windows grow by the size of their decoration upon compiz restart.

User Unknown (user-unknown) wrote :

Hrmpf, it didn't link to the other bugs...

Likely related bugs: bug #1204307, bug #1217286

Doug McMahon (mc3man) wrote :

commit fixes this & 2 other bugs here, so duped

Stephen M. Webb (bregma) on 2014-03-11
Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
Paul (i41bktob-launchpad-net) wrote :

Confirming fixed in compiz 1:0.9.11+14.04.20140310-0ubuntu1. Thanks, Treviño.

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers