Could not disable sync to vblank

Bug #1277541 reported by Holger Seelig on 2014-02-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I am developing an Gtk3/OpenGL application and I need for testing purposes to disable sync to vblank. Since Ubuntu 13.10 I cannot disable sync to vblank. I have tried disabling it in CSM OpenGL settings, what in Ubuntu 13.04 works perfect for me, but in 13.10 it has no effect. I tried nvidia-setting disabling sync to vblank, but it has not effect. I tried the OpenGL functions for disabling - no effect.

As I stated before just disabling sync to vblank in CSM worked perfect for me in 13.04.

Best regards,
Holger Seelig

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz 1:0.9.10+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-15.25-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 319.60 Wed Sep 25 14:28:26 PDT 2013
 GCC version: gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9)
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,gnomecompat,resize,place,compiztoolbox,mousepoll,move,regex,session,imgpng,animation,grid,snap,unitymtgrabhandles,wall,expo,workarounds,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Feb 7 15:36:46 2014
DistUpgraded: 2013-10-18 16:13:51,179 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 630] [10de:0f00] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ZOTAC International (MCO) Ltd. Device [19da:6199]
InstallationDate: Installed on 2012-11-04 (459 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: MEDIONPC MS-7501
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=5fbc5ba5-93fb-46d1-9446-d53030ce7dda ro quiet splash
SourcePackage: compiz
UpgradeStatus: Upgraded to saucy on 2013-10-18 (112 days ago)
dmi.bios.date: 04/10/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: A7501MLN.10E
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7501
dmi.board.vendor: MEDIONPC
dmi.board.version: 2.1
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MEDIONPC
dmi.chassis.version: 0.A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrA7501MLN.10E:bd04/10/2008:svnMEDIONPC:pnMS-7501:pvr2.1:rvnMEDIONPC:rnMS-7501:rvr2.1:cvnMEDIONPC:ct3:cvr0.A:
dmi.product.name: MS-7501
dmi.product.version: 2.1
dmi.sys.vendor: MEDIONPC
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Thu Feb 6 03:23:44 2014
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.5-1ubuntu2~saucy1

Holger Seelig (holger-seelig) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Eduard (beigemidnight) on 2015-04-18
no longer affects: compiz
To post a comment you must log in.