Black window borders, black terminal

Bug #1242115 reported by Alexis Laporte on 2013-10-19
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I have just upgraded to 13.10.

Some elements of the desktop are black:
* Notifications
* Window borders
* The terminal
* Tooltips in Chrome browser

 I can't tell much more at the moment, it might be related to my graphic card? I'm on a Dell XPS 13.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1242115/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → unity (Ubuntu)
affects: unity (Ubuntu) → compiz (Ubuntu)
Alexis Laporte (alexis-laporte) wrote :

XTerm works, so I can do a bit more to track the bug.
It seems to be related to compiz / window management. If I disable/enable window management in CCSM, I see some failure in syslog (document attached).

description: updated
description: updated
summary: - Some elements of the desktop are black
+ Black window borders, black terminal
Stephen M. Webb (bregma) wrote :

Thanks for trying to track this down.

The log file that would be of greatest interest would be ~/.cache/upstart/gnome-session.log which should capture any error from Compiz or unity. If you could attach that to this bug, that might help the developers track down this problem.

Changed in compiz (Ubuntu):
status: New → Incomplete
Alexis Laporte (alexis-laporte) wrote :

Hi, thanks for your reply.

The file is quite big, I thought it would empty itself after a restart but it did not. I have just rebooted so the latest entries must be of interest.
I needed, I can delete the file to get a clean one after a restart.

Note that I currently do not have any borders, I got many system crash errors on startup.

Alexis Laporte (alexis-laporte) wrote :

My last attachment is erroneous, I made a typo in gtk-windowS-decorator, which is why I did not have any decor at all.

This is now correct, and I am back with the black borders.

I now attach an excerpt of gnome-session.log, what happens when I disable then enable decor.

"compiz (decor) - Warn: No default decoration found, placement will not be correct"

Alexis Laporte (alexis-laporte) wrote :

I can reprodruce the bug and get a report when doing:
gtk-window-decorator --replace

The report is attached.

Maybe that is related:
 [ 534.000809] gtk-window-deco[2631]: segfault at 20 ip b7591698 sp bfd655f0 error 4 in libwnck-1.so.22.3.31[b7571000+3d000]

Alexis Laporte (alexis-laporte) wrote :

It now seems to me that this is the bug:
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'

I think I should get something when doing:
gconftool-2 --get /apps/compiz-1/general/screen0/options/active_plugins

But I don't know which plugins should I enable?
Note that I did not change anything in that list, I haven't played much with CCSM (I installed it to track the bug).

Alexis Laporte (alexis-laporte) wrote :

Well I did
gconftool-2 --set --type=list --list-type=string /apps/compiz-1/general/screen0/options/active_plugins "[core,composite,opengl,decor,snap,vpswitch,compiztoolbox,gnomecompat,imgpng,unitygrabhandles,grid,copytex,place,move,wall,resize,session,regex,widget,mousepoll,animation,fade,expo,scale,workarounds,unityshell]"

Now I don't get any bug report when doing
gtk-window-decorator --replace

The fact that it was empty seems odd to me, but I still don't have any decor :/.

I was able to fix this problem by re-installing Mir using the following instructions: https://wiki.ubuntu.com/Mir/Installing

Thanks, I just convinced myself to install a fresh Ubuntu, it works fine.
Were you having the exact same problem: black borders, no decor?

It was exactly the same issue as far as I was able to tell. I switched to Enlightenment until someone found the solution here: http://askubuntu.com/questions/360598/13-10-black-borders-black-terminal

Stephen M. Webb (bregma) wrote :

Does this problem only occur when running the Mir unity-system-compositor component?

Great! I could not tell if this would work for me, all I know is that a fresh install does not have the problem with my device. Do you have an intel graphic chip?

Myna Mefirst (myna6p) wrote :

I also have this problem. Very annoying. To answer some of the questions i see:
- the link at http://askubuntu.com/questions/360598/13-10-black-borders-black-terminal suggested to reinstall MIR, but no luck. i have the same problem WITH and WITHOUT the mir compositor
- I have tried clearing out unity and compiz to defaults, but no luck
- I also get exactly the same errors: segfault and no decoration found.
- I am SOOOO happy to see i am not the only one, because i have been searching for hours now. :)
- I do think it has to do with something that happens when upgrading. If i do a fresh install, it works fine. Unfortunately i really wanted to stick to the upgrade (for time purposes), so i still would like to figure this out.

Ken D'Ambrosio (ken-jots) wrote :

Sadly, please add my name to the list. Black borders, black terminal. I *LOOOVE* my Compiz, so I'm not planning on giving up, but I also need to stay employed, so I'll revert... for now. If someone figures this out, please post to this thread.

Thanks kindly!

-Ken

Øyvind Stegard (oyvinst) wrote :

I often get all black decorations and drop shadows after resume from suspend. Ubuntu 13.10 (clean install), nvidia binary graphics driver. Tested various nvidia driver versions, including the most recent 331.20, but that has made no difference. This did not happen with Ubuntu 13.04 on the same hardware. The drawing errors are not permanent and decorations redraw correctly after Alt-tabbing. Some window borders/drop shadows and other graphical elements remain black for a longer period of time (until proper redraw is triggered I guess).

Some (cumbersome) work-arounds:
1. unity --replace
2. Re-suspend and resume, and often it will come back OK.

I'm using 13.10 and a HP Pavilion dv6 with an Intel/NVIDIA GeForce GT630M hybrid, where bumblebee is needed to make the proprietary driver work. This isn't used for Unity/Compiz so the Xorg driver I'm using is intel.

Mir does not work on this hardware - Xorg won't start (but that's off-topic). To disable it, I commented out this line in /etc/lightdm/lightdm.conf.d/10-unity-system-compositor.conf

#type=unity

With this configuration I get the black window border / black terminal symptom in Compiz consistently. I am not sure what the trigger was, but it was when I re-installed stuff in an attempt to get bumblebee working. It wasn't triggered when I upgraded from 13.04 to 13.10, but it happened some time after.

I *have* had it working, and it may be that I previously got Mir to work (because I definitely tried to do this).

wmertens (wout-mertens) wrote :

Same issue here - Running trusty on a Dell with hybrid Intel i915 + AMD HD 8790M. X is using the i915 and everything seems to run fine, glbench2 works fine, except that everything that does overlays (shadows, window decoration, hover tips) appears as completely black.

It is related to compiz somehow, because when I kill compiz and run metacity instead, the hover tips appear normally (at least I think so, they are white text on a black borderless rectangle).

I tried resetting the compiz settings but that didn't make any difference.

X.Org X Server 1.14.5 - Release Date: 2013-12-12
Compiz 0.9.10.2

Troubleshooting tips welcome.

wmertens (wout-mertens) wrote :

Update: This only happens when using the i915. When I install the proprietary drivers the black areas aren't there, and when I run `aticonfig --px-igpu` to switch back to the i915 and logout/login they are black again.

Unfortunately the dgpu drivers cause massive screen corruption when using screen rotation and I love my rotated screen so I can't use those either :-(

wmertens (wout-mertens) wrote :

Actually when I say i915 I actually mean the "Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)" which comes with my Xeon E3-1200.

"sudo pmap `pidof X` | grep dri.so" refers to i965_dri.so.

wmertens (wout-mertens) wrote :

BTW, before I upgraded to trusty it was working fine (12.04). Here's the output of /usr/bin/intel_reg_checker :

MI_MODE (0x209c): 0x00000000
  (bit 14) OK: Async Flip Performance mode
  (bit 13) OK: Flush Performance Mode
  (bit 12) FAIL: MI_FLUSH enable must be set
  (bit 6) FAIL: Vertex Shader Timer Dispatch Enable must be set
GFX_MODE (0x229c): 0x00000000
  (bit 13) PERF: Flush TLB Invalidation Mode should be set
GT_MODE (0x7008): 0x00000000
CACHE_MODE_0 (0x7000): 0x00000000
  (bit 15) OK: Sampler L2 Disable
  (bit 9) PERF: Sampler L2 TLB Prefetch Enable should be set
  (bit 8) OK: Depth Related Cache Pipelined Flush Disable
  (bit 5) OK: STC LRA Eviction Policy
  (bit 4) OK: RCC LRA Eviction Policy
  (bit 3) OK: Hierarchical Z Disable
  (bit 0) OK: Render Cache Operational Flush
CACHE_MODE_1 (0x7004): 0x00000000
  (bit 13) OK: STC Address Lookup Optimization Disable
  (bit 12) OK: HIZ LRA Eviction Policy
  (bit 11) OK: DAP Instruction and State Cache Invalidate
  (bit 10) OK: Instruction L1 Cache and In-Flight Queue Disable
  (bit 9) OK: Instruction L2 Cache Fill Buffers Disable
  (bit 6) OK: Pixel Backend sub-span collection Optimization Disable
  (bit 5) OK: MCS Cache Disable
  (bit 4) OK: Data Disable
  (bit 1) OK: Instruction and State L2 Cache Disable
  (bit 0) OK: Instruction and State L1 Cache Disable
FF_SLICE_CHICKEN (0x2088): 0x00000000
           OK: chicken bits unset
3D_CHICKEN3 (0x2090): 0x00000000
           OK: chicken bits unset
FF_SLICE_CS_CHICKEN1 (0x20e0): 0x00000000
           OK: chicken bits unset
FF_SLICE_CS_CHICKEN2 (0x20e4): 0x00000000
           OK: chicken bits unset
FF_SLICE_CS_CHICKEN3 (0x20e8): 0x00000000
           OK: chicken bits unset
COMMON_SLICE_CHICKEN1 (0x7010): 0x00000000
           OK: chicken bits unset
COMMON_SLICE_CHICKEN2 (0x7014): 0x00000000
           OK: chicken bits unset
WM_CHICKEN (0x5580): 0x00000000
           OK: chicken bits unset
HALF_SLICE_CHICKEN (0xe100): 0x00000000
           OK: chicken bits unset
HALF_SLICE_CHICKEN2 (0xe180): 0x00000000
           OK: chicken bits unset
ROW_CHICKEN (0xe4f0): 0x00000000
           OK: chicken bits unset
ROW_CHICKEN2 (0xe4f4): 0x00000000
           OK: chicken bits unset
ECOSKPD (0x21d0): 0x00000000
           OK: chicken bits unset

Not sure if that helps. I tried kernels 3.8, 3.12 and 3.13, no difference.

wmertens (wout-mertens) wrote :

...And now the problem is gone again. Things I did:
- use the open source intel drivers for X, using software-properties-gtk (done that multiple times before to no avail)
- Install Mir
- complete shutdown because of low battery
- Disable Mir because it doesn't work (by simply removing the lightdm entry)
- Notice that compiz now works as it should, no black areas
- be stumped

There were some updates in between as well but not to xorg or compiz I think.
So my problem is solved, for now. I don't know how.

Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired

This bug still exists in 13.10.

Tim Artman (timon63) wrote :

also exist in 14.04 beta 2.

Benjamin Xiao (ben-r-xiao) wrote :

I have this issue on Ubuntu 14.04 as well. Running Nvidia proprietary 334.21

Changed in compiz (Ubuntu):
status: Expired → Confirmed
Benjamin Xiao (ben-r-xiao) wrote :

To give more info on this issue:

Laptop specs:
Lenovo W510 with Nvidia Quadro FX 880M running Nvidia Proprietary 334.21

Issue occurs very often after resuming from a suspend. Problem goes away if I do another suspend/resume cycle.

andyczerwonka (andy-czerwonka) wrote :

It's always on my Lenovo w520 and I can't get rid of it. It's not a suspend/resume cycle, it's permanent.

tomDaniel (thomaspdaniel) wrote :

Lenovo W540. 14.04. Downloaded latest updates and boom, I have this all the time. Checking out Mir solution now.

I hate to bump up a 3 years old issue, but I have it on Ubuntu 15.10 and I can't find a fix.
It happens all the time, not only after boot.
Tried both Compiz and Unity - on Compiz the entire window is black. On Unity, it has black borders.
I have a presentation tomorrow, and it's 3am now and I still can't fix it :(

Might have happened after update, I should remember to never update but it's too easy to comply...

$ lsb_release -d
Description: Ubuntu 15.10

$ sudo lshw -C video
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:29 memory:fc000000-fc3fffff memory:d0000000-dfffffff ioport:1800(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:fc400000-fc4fffff

$ cat /etc/lightdm/lightdm.conf
[SeatDefaults]
autologin-guest=false
autologin-user=oria
autologin-user-timeout=0
autologin-session=lightdm-autologin

$ tail ~/.cache/upstart/unity7.log
unhandled buffer attach event, attachment type 79
unhandled buffer attach event, attachment type 79
unhandled buffer attach event, attachment type 82
unhandled buffer attach event, attachment type 82
unhandled buffer attach event, attachment type 79
unhandled buffer attach event, attachment type 79
unhandled buffer attach event, attachment type 82
unhandled buffer attach event, attachment type 88
unhandled buffer attach event, attachment type 82
unhandled buffer attach event, attachment type 79

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers