tribe-2 has severe problems due to screen effects enabled by default

Bug #123263 reported by Rogério Theodoro de Brito on 2007-06-30
12
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Unassigned

Bug Description

Unfortunately, when trying tribe-2 on my system to help friends adopt it, I discovered severeal problems with my system (I think that I will have to file two different reports here).

The most serious of these is that my screen is completely unusable (I have an screenshot to show you) and I can't see almost any menu entry or window contents, since on tribe-2, compiz is enabled by default.

My computer has a KT133 chipset and a Matrox G400 AGP monohead with 16MB of VRAM.

I consider this bug quite severe, since i can't even see the icons on the desktop and I can't turn off the "special effects" enabled by compiz. :-(

I have a screenshot here that shows the severity of the problem and I would like to show you this, but I don't know how to attach things in this bugsystem (I'm used to Debian's).

Please let me know if other things are desired (like the logs of the X server or anything else).

Thanks in advance, Rogério Brito.

I just discovered that I can attach a file and here goes one screenshot.

It was taken when I switched to a console, exported DISPLAY=:0 and then lauched an xterm. After this, I used gnome-screenshot to grab the screenshot that I attach here.

Thanks.

Martin Pitt (pitti) wrote :

Thank you for your report. Can you please attach /etc/X11/xorg.conf and give us the output of

  lspci -n | grep 0300

and do

  xdpyinfo > xdpyinfo.txt
  glxinfo > glxinfo.txt

and attach both files here? Those two need to run with a valid $DISPLAY, too, but you already figured out how to do that. Thank you!

Hi, Martin.

Thank you very much for your kind response. I'm sending you the requested files.

As you can see by this file, I do have DRI enabled with my card.

You didn't ask, but I'm including it here: Xorg.0.log.

It shouldn't hurt.

Oh, and here is what I see when I'm trying to use gutsy... :-(

Hi there.

What is missing for this bug to be considere as a "real" bug? Do I have to include further information? I think that I have provided with sufficient information, but I can provide whatever else is needed.

I sincerely want to have Ubuntu working on my systems so that not only I can use this machine (actually, I'm thinking of teaching older people in my family to use it).

And, as can be seen from the attachments, this is a quite severe/limiting bug regarding gutsy. (Unfortunately).

Thank you very much, Rogério Brito.

Travis Watkins (amaranth) wrote :

Can you make sure /apps/compiz/general/screen0/options/detect_outputs is checked in gconf-editor? If you can't get to that easily boot in recovery mode (option in grub) and change your xorg.conf to use the 'vesa' driver instead of the 'mga' driver.

Dear Travis,

On Jul 15 2007, Travis Watkins wrote:
> Can you make sure /apps/compiz/general/screen0/options/detect_outputs
> is checked in gconf-editor? If you can't get to that easily boot in
> recovery mode (option in grub) and change your xorg.conf to use the
> 'vesa' driver instead of the 'mga' driver.

I'm not in front of my computer right now, but I can tell you that if I
*boot* (not change, as you mentioned) in vesa ("safe graphics mode"),
then I don't have problems.

Also, if I go to a console and put a resolution bigger than 1280x1024,
then, I think that due to the lack of VRAM, compiz is disabled and I get
a normal desktop, without the effects.

I would like to use the 3D effects, and I bought a Matrox G400 exactly
because it is/was one of best supported cards on Linux, with
specifications for the (at the time) XFree86 developers (so that I
wasn't tied to Linux only).

I don't know if my guess regarding the resolution is correct, but it
surely seems to be the case. I will get to my computer as soon as I can
and I will try to see if */detect_outputs is enabled or not.

Thanks, Rogério Brito.

--
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Hi, Travis.

After a lot of fighting with my computer, I discovered that yes, /apps/compiz/general/screen0/options/detect_outputs *is* checked.

Do you want me to perform any other test?

I'd be glad to help avoid those pictures that I've attached to this bugreport (because that's what I see, unfortunately). If you need more information, please, don't hesitate to ask.

Thanks, Rogério Brito.

P.S.: I accidentally went to an xterm and this is what I discovered (it may help):
ubuntu@ubuntu:~$ compiz --help
Checking for Xgl: not present.
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Converting gconf plugin list: ''
Checking for nVidia: not present.
Checking for Xgl: not present.
Usage: /usr/bin/compiz.real [--display DISPLAY] [--bg-image PNG] [--refresh-rate RATE]
       [--fast-filter] [--indirect-rendering] [--loose-binding] [--replace]
       [--sm-disable] [--sm-client-id ID] [--no-detection]
       [--ignore-desktop-hints] [--only-current-screen] [--use-root-window]
       [--version] [--help] [PLUGIN]...
ubuntu@ubuntu:~$

Michael R. Head (burner) wrote :

Is this a dupe of bug 122961 ?

Hi, Michael.

On Aug 9, 2007, at 8:50 PM, Michael R. Head wrote:
> 122961

Well, perhaps it is the same bug, but I am not exactly sure. I have
posted some screenshots and some pictures that I took from my
computer. Perhaps you could tell if the problem is the same or not,
but it is extreme to the point of being unusable, unfortunately.

The resolution with which the computer is started is 1280x1204 with
24 bits per pixel and I lack the memory for this to work,
unfortunately (I only have a G400 with 16MB of VRAM, as you may
already have read from my other posts to this bug).

If you have any solution, please let me know.

Regards, Rogério Brito.

--
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Michael Vogt (mvo) wrote :

Compiz should not be started on a system like this with so little graphic memory.

Changed in compiz:
importance: Undecided → High
status: Incomplete → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

Is this similar to Bug #122961 ?

Hi, Michael.

As promised, I got todays i386 image of gutsy and it doesn't have the problems with compiz anymore. If you wish me to send any further information, please let me know.

Regards, Rogério Brito.

Henrik Nilsen Omma (henrik) wrote :

Confirmed fixed by the submitter.

Changed in compiz:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers