Ubuntu

Wrongly placed maximized window with cloned display

Reported by Andreas Schildbach on 2007-06-30
96
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Medium
Travis Watkins
Hardy
Medium
Travis Watkins

Bug Description

Binary package hint: compiz

I am using Gutsy Tribe 2 on an Intel-Graphics based Notebook, and have switched the default "i810" driver to "intel". This driver by default clones the workspace content on both external and internal display, which means that my internal display only shows a subset (1280 x 768) of the external display (1920 x 1200).

Now on to the bug: When I maximize a window, it is maximized to the smaller (internal) display rather than the whole workspace. This looks and feels very strange.

I have seen other variations of this bug. When gksu dims the display, a "free-floating" compiz shadow is drawn around the virtual bounds of the smaller display, although there is no window that this shadow could belong to. The process of dimming up and down reveals a rectangle in the size of the smaller display. I've also had occasions of window move stickyness to the bounds of the smaller display.

To cut a long story short: Although the workspace is extended to the larger display, the bounds of the smaller display still play a role, which I think it shouldn't. I haven't had such effects with metacity.

This issue is still present on Tribe 5.

Changed in compiz:
importance: Undecided → Low

This issue is still present on Gutsy Beta, on its default configuration!

I am attaching an image that shows a "maximized" Firefox. Here are 3 easy steps to reproduce:

1. Boot Live-CD or freshly installed Ubuntu, Login.
2. Open Firefox
3. Maximize Firefox

Michael Vogt (mvo) on 2007-10-01
Changed in compiz:
importance: Low → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

I can reproduce this here on my i830 based laptop with intel driver.

Michael, just for the record: Do you have connected an external monitor and which one? Which resolution do both panels have?

Jonas Jørgensen (jonasj) wrote :

I can also reproduce this on a laptop with a GMA 950 (don't remember what the chipset is called), using the intel driver.

Jonas Jørgensen (jonasj) wrote :

solution from <http://ubuntuforums.org/showthread.php?t=582551&page=2> (I haven't tested it):

"Problem solved. Here's how to:

- Install Compiz Advanced Desktop Setting;
- Open it and go to "General Options", then "Display Settings";
- Uncheck "Detect Outputs";
- In "Ouputs", edit the resolution (mine was set at 800x600x0x0) to your external display's resolution (mine is now 1050x1680).

This should solve the problem."

This issue is still present on Hardy Alpha 1.

Changed in compiz:
assignee: nobody → compiz
assignee: compiz → ubuntu-desktop-effects
Kieran Hogg (xerosis) wrote :

Still present as of (almost) alpha 4. This is a pretty terrible bug for people who use projectors. It makes presentations exceptionally difficult as when you go full screen for the presentation it only covers the smaller desktop.

Same problem on my external monitor 1680x1050: the image is not centered .. like ten black centimeters on left side.

I have not any graphic effect actived, any way I have follow the instructions:
* Uncheck "Detect Outputs";
* In "Ouputs": 1680x1050+0+0

I have to hack the i180 on every reboot with:

915resolution 3a 1680 1050 8 1840 1080
915resolution 4b 1680 1050 16 1840 1080
915resolution 5a 1680 1050 32 1840 1080

I obtain the resolution but the image is not centered.

For the record:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I am sorry, this bug is about a problem with the maximized windows.. my problem is with the total of the image..

Sorry.

Changed in compiz:
assignee: ubuntu-desktop-effects → nobody
Fred (frederic-lespez) wrote :

See this bug in Hardy Alpha 5 (with an intel GMA X3100).
As a workaround, if you doesn't use the internal display of your laptop, you can switch of the internal with an xrandr command (xrandr --output LVDS --off) and restart compiz. After that compiz works fine when maximizing. It also shows that Compiz doesn't use the internal display resolution if the internal display is turned off : Maybe Compiz uses the resolution of the first screen it found ?

Travis Watkins (amaranth) wrote :

No, it just has a bad solution to this hard problem. You have two outputs overlapping each other (the small screen is inside the large screen's area) and it can't say "this window is on this monitor" because they're on both monitors. The most obvious answer would be "whatever monitor the top-left corner is in" but I can think of a few cases where that doesn't work. The next most obvious is "whatever one the window is most in" but then once you get it to maximize to the larger monitor the smaller one is completely filled by this window so that one falls over. I think this is how compiz works now.

Here is another workaround: Instead of using compiz, use the new compositing mode of Metacity in Hardy. Go back to "no visual effects", then execute "gconftool-2 -s --type bool /apps/metacity/general/compositing_manager true". The effects are very similar to "normal" mode, and it does not choke up with cloned displays.

Travis Watkins (amaranth) wrote :

Will be fixed when we update to latest upstream code.

Changed in compiz:
status: Confirmed → In Progress
Changed in compiz:
assignee: nobody → amaranth
Ian Hinder (ian-hinder) wrote :

This bug is still present in Hardy Beta.

silverius (rsilvarodriguez) wrote :

I can also reproduce this on a Mac Mini with a GMA 945, Intel 945G Express Chipset

MiguelGL (miguelgl) wrote :

Just for the record, I'm experiencing this same issue on a Sony Vaio with an NVIDIA GeForce Go 7600.

In fact, I filled a bug report not being aware of the previous existence of this one (https://bugs.launchpad.net/bugs/208835). Therefore, my bug was marked as duplicate. Sorry about that, should have checked before.

Kev (ukev) wrote :

I can also confirm this bug with my laptop with intel 945gm. This bug exists in Gutsy as well as now in Hardy beta (all updates!).
Laptop resolution is 1280*768 and external monitor (vga) is 1680*1050.
This bug also concerns all compiz effects, for example the zoom effect (see attached picture).
It is a really strange problem.

Is there a way to set a virtual screen in the bigger resolution for the smaller display, which is activated as soon as the external monitor (with bigger size) is plugged in and activated?
I've seen that a time ago, when you move your mouse out of the smaller screen, the smaller screen moves.
Maybe that would be a really good workaround for the bug, because you see on both displays what you are doing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.7.4-0ubuntu4

---------------
compiz (1:0.7.4-0ubuntu4) hardy; urgency=low

  [ Travis Watkins ]
  * debian/patches/037_fullscreen_stacking_fixes.patch:
    - check for valid window (LP: #206866)

compiz (1:0.7.4-0ubuntu3) hardy; urgency=low

  * add forgoten epoch to compiz-core dependency

compiz (1:0.7.4-0ubuntu2) hardy; urgency=low

  * tighten dependencies

compiz (1:0.7.4-0ubuntu1) hardy; urgency=low

  * new upstream release:
    + Configurable handling of overlapping output devices.
    + Enhanced focus stealing prevention with configurable amount
      of focus stealing prevention.
    + Added configurable, optional delay for edge actions to prevent
      accidential invocation.
    + Generalized vertex system to improve plugin compatibility.
    + Optimized gaussian blur shaders to support more hardware.
    + Improved unredirection of fullscreen windows.
    + Several bugfixes.
    + Translation updates.
  * This fixes: LP: #123205, #105220, #156908

compiz (1:0.7.2+git20080403-0ubuntu1) hardy; urgency=low

  * new git snapshot:
    + fix session management
    + improve xrandr 1.2 support (overlapping outputs)
    + fix unredirection for games/apps that change the resolution
    + Switch viewports on window activation, not on focus change.
    + focus stealing fixes
    + window managment fixes
    + ABI bump
  * debian/patches/013-add-cursor-theme-support.patch:
    - updated to current code
  * debian/patches/030_fix_screensaver:
    - updated to current code
  * debian/patches/041-start-decorator.patch:
    - removed, part of upstream now
  * debian/patches/042-compiz-manager-default-plugin.patch:
    - always load core first
  * debian/control:
    - ABI bump, updated dependencies accordingly
    - remove dependency on compiz-core from compiz-dev

 -- Michael Vogt <email address hidden> Fri, 11 Apr 2008 17:37:59 +0200

Changed in compiz:
status: In Progress → Fix Released
Russell Smith (mr-russ) wrote :

Hi Jurik,

I'm unsure why the linux kernel was added to this bug after the compiz fix was released. What issues are you experiencing with this bug?

Thanks

Changed in linux:
status: New → Incomplete
dino99 (9d9) on 2012-08-31
Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers