Cannot move certain windows via the top half of the titlebar in Ubuntu 13.10

Bug #1228507 reported by Rocko on 2013-09-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
0.9.10
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend

Bug Description

If I click and hold the mouse button down on the top-half of the titlebar of certain smaller windows (eg update-manager and nautilus' file copy window) in Ubuntu 13.10, the window gets the focus but does not move when you drag the mouse. I have to click on the bottom half of these windows to move them.

This is not the case with all windows - eg gnome-terminal doesn't seem to have the problem, no matter how small I make it.

Note that if I expand the details panel of update-manager's window, drag-to-move now *does* work.

To reproduce:

1. Run update-manager but do not expand on the details panel.
2. Try to move the window by clicking and holding on the top half of the titlebar. It should move, but doesn't.
3. Try to move the window by clicking and holding on the bottom half of the titlebar. It should move as expected.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz 1:0.9.10+13.10.20130920-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Sep 21 15:33:57 2013
DistUpgraded: 2013-09-01 08:39:13,069 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:050e]
 NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev ff) (prog-if ff)
InstallationDate: Installed on 2012-08-25 (391 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
MachineType: Dell Inc. Dell System XPS L502X
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-8-generic root=UUID=67083065-b92e-4596-a218-817c1dfc8ae7 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to saucy on 2013-09-01 (20 days ago)
XorgConf:
 Section "Device"
  Identifier "Card0"
  Driver "intel"
  Option "AccelMethod" "sna"
 EndSection
dmi.bios.date: 05/29/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0NJT03
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd05/29/2012:svnDellInc.:pnDellSystemXPSL502X:pvr:rvnDellInc.:rn0NJT03:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L502X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.10+13.10.20130920-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu6
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Sat Sep 21 15:25:12 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 41063
 vendor DEL
xserver.version: 2:1.14.2.901-2ubuntu4

Related branches

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

Since it's probably a unity-compiz issue, the version of unity I'm running is 7.1.0+13.10.20130920-0ubuntu1.

Christopher Townsend (townsend) wrote :

I have confirmed this by trying to drag System Settings by the top half of the title bar. Very strange behavior...

Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in compiz:
status: New → Triaged
importance: Undecided → High
Rocko (rockorequin) wrote :

Perhaps the problem occurs for any window that isn't resizable?

gnome-disks is another program that shows this bug, and like System Settings it isn't resizable but it is a lot larger than the windows I first noticed it on.

Christopher Townsend (townsend) wrote :

@Rocko,

You are correct and it also affects semi-maximized windows as well. I'm currently debugging this rather strange issue.

Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
milestone: none → 0.9.11.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.11.0

Changed in compiz:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.10 at revision None, scheduled for release in compiz, milestone 0.9.10.2

Changed in compiz:
status: Fix Committed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.10+13.10.20131004-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Chris Townsend ]
  * Fix issue where non-resizable windows and semi-maximized window
    would have an area near the top of the title bar that could not be
    grabbed. (LP: #1228507)

  [ Marco Trevisan (Treviño) ]
  * ActionMenu: weak ref the action menu on creation, and unref it on
    destroy Also, now the widget destruction automatically unset the
    menu. This makes the object to be correctly finalized (not only
    disposed) making sure the internal idle into WnckActionMenu gets
    stopped. (LP: #1191853)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3794
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:23:02 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Rocko (rockorequin) wrote :

I'm using the numix theme (http://www.webupd8.org/2013/08/new-ppa-for-numix-gtk-and-icon-themes.html), and while the window drag behaviour is certainly improved with compiz 1:0.9.10+13.10.20131004-0ubuntu1, I still can't move some windows if I click near the top of the title bar. It's quite odd - the Gnome Disks window works fine now, but System Settings doesn't drag if I click higher than 3/4 of the way up the title bar.

Is this something that needs to be addressed on a theme-by-theme basis? It was working fine in ubuntu 13.04, so it seems strange that it is broken now, but I don't know what the underlying issue is.

@Rocko,

I don't test any other themes, but I do have an idea of what *may* be the problem. If make a test package available in my PPA, do you think you can test it and let me know the results?

Thanks!

@Rocko,

I went ahead and put up a test package in my PPA: ppa:townsend/compiz-test

Thanks!

Rocko (rockorequin) wrote :

Thanks for the test package! I tried compiz 0.9.10+13.10.20131004-0ubuntu1test1, and unfortunately I still can't move the System Settings window by dragging near the top part of the titlebar.

If System Settings were a resizable window, I suspect that when I hover the mouse over this part of the title bar, the mouse icon would change to indicate I can now use the mouse to resize the window, and with this feedback I don't expect to be able to move the window by dragging it. But when it's a non-resizable window the mouse cursor icon doesn't change and so I expect to be able to drag the window - but it nothing happens when I click and move the mouse. Is this what you suspect is happening?

jpileborg (arrow-pileborg) wrote :

I don't know if it's related or not, but since a month or so back I can not drag or move *any* window. Fully updated Ubuntu 13.10 with Unity 7.1.2 and Compiz 0.9.10.2.

While I have a dual-screen setup, I can't drag a window even withing a single screen. I can maximize, minimize and resize normally, just not drag it.

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

marking as closed (0.9.10 series is obsolete)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers