Ubuntu

gtk-window-decorator crashed with signal 5 in g_logv()

Reported by Toby Smithe on 2007-06-26
78
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I'm not sure when this occurred, although when I started my session earlier, I had to manually open gtk-window-decorator.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Tue Jun 26 19:26:26 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gtk-window-decorator
NonfreeKernelModules: cdrom
Package: compiz-gnome 1:0.5.1+git20070621-0ubuntu3
PackageArchitecture: i386
ProcCmdline: /usr/bin/gtk-window-decorator --replace
ProcCwd: /home/toby
ProcEnviron:
 PATH=/home/toby/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: compiz
StacktraceTop:
 g_logv () from /usr/lib/libglib-2.0.so.0
 g_log () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? ()
Title: gtk-window-decorator crashed with signal 5 in g_logv()
Uname: Linux leopard 2.6.22-7-generic #1 SMP Mon Jun 25 17:33:14 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy fuse games lpadmin netdev plugdev powerdev pulse pulse-access pulse-rt scanner video

Toby Smithe (tsmithe) wrote :

StacktraceTop:IA__g_logv (log_domain=<value optimized out>, log_level=G_LOG_LEVEL_ERROR, format=0xb79f75a0 "%s", args1=0xbffc7c2c "8f\024\b\002")
IA__g_log (log_domain=0xb79db0a3 "Gdk", log_level=G_LOG_LEVEL_ERROR, format=0xb79f75a0 "%s") at /build/buildd/glib2.0-2.13.5/glib/gmessages.c:517
gdk_x_error (display=0x806f4f8, error=0xbffc7cd8) at /build/buildd/gtk+2.0-2.11.4/gdk/x11/gdkmain-x11.c:641
_XError (dpy=0x806f4f8, rep=0xbffc7da0) at ../../src/XlibInt.c:2907
_XReply (dpy=0x806f4f8, rep=0xbffc7da0, extra=0, discard=1) at ../../src/XlibInt.c:1833

Changed in compiz:
importance: Undecided → Medium
status: New → Triaged
Sebastien Bacher (seb128) wrote :

It's stopping on gdk_x_error() not in g_logv()

Bryce Harrington (bryce) wrote :

gdk_x_error() looks to be just an error message handler, the real bug is a bit higher up.

It's trying to allocate a scratch image to draw on, then XSync gets called and things go to pot it'd be interesting to see an strace on that one. I wonder if an X error return code is being ignored?

clynx (clynx) wrote :

Looks like this happens for me when I enable Xinerma and Compiz

Travis Watkins (amaranth) wrote :

Toby are you using xinerama with nvidia too?

Changed in compiz:
status: Triaged → Incomplete
Travis Watkins (amaranth) wrote :

Caused by using xinerama with nvidia which nvidia considers an unsupported configuration. It shouldn't crash but people should not be using this configuration anyway. Lowering priority.

Changed in compiz:
importance: Medium → Low
status: Incomplete → Confirmed
clynx (clynx) wrote :

What 'should' they using in that case?

Travis Watkins (amaranth) wrote :

Twinview.

sorry it s not aboy xinerama

2007/9/13, Travis Watkins <email address hidden>:
>
> Twinview.
>
> --
> gtk-window-decorator crashed with signal 5 in g_logv()
> https://bugs.launchpad.net/bugs/122389
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Changed in compiz:
status: Confirmed → Invalid
Jens (jens.timmerman) wrote :

xinerama seems to be the default way of starting a dual head setup in ubuntu using the screens and graphics tool (in system-> administration)
but this can be changed (for nvidia cards) when you run sudo nvidia-settings and in 'x serer dislay configuration' you shoose twinview instead of seperate x screen and save to x configuration file.

Barry Warsaw (barry) wrote :

Just to point out that from a user perspective, AFAIK Twinview and Xinerama behave differently so there's a good reason to choose Xinerama over Twinview some times.

Andrew Conkling (andrewski) wrote :

Also, pointing out that I had neither enabled in my case.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed

I'm changing this back to confirmed because it is clearly a userland bug, not a driver bug - some users in the bug reports that are marked as duplicates of this bug have indicated that they are running Intel and ATI systems as well as Nvidia.

On my own system, I have an nVidia GF6800 card, using the 185-series driver, running in Twinview mode with two 1280x1024 Dell flat panel monitors. GLX is most definitely working fine - glxgears (whether it is a benchmark or not) gives me over 20,000 frames per second, and apps like Google Earth, OpenArena, and so on work perfectly fine.

XFCE's composite manager runs perfectly fine and has no issues whatsoever that I've noticed. I have of course tried disabling it before attempting to run Compiz, but that of course doesn't work.

Compiz simply will not work for me. All the windows get hidden briefly, then shown without window decorations for a moment, and then once in a while I can *just* catch the window decorations changing to what Emerald provides. Whether Emerald is visible or not, compiz only lasts for a split second before dieing with a segmentation fault:

-----
vanessa@rainbird:~$ compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (2560x1024) to maximum 3D texture size (4096): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Couldn't find a perfect decorator match; trying all decorators
Starting emerald
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Segmentation fault

[ I have to hit control-C after the segfault to restore the ]
[ XFCE window manager and get my prompt back ]

vanessa@rainbird:~$
-----

The above is while running XFCE. Gnome also fails to start compiz, though the error it gives is a generic "couldn't be started" error dialog. I don't know what that 8bit pixmap format is about, as I'm running in 24 bit mode.

On my husband's box, which has an even older nVidia MX4000 running the 96-series driver, with only one fairly non-descript 1280x1024 Dell flat panel (i.e. no multi-head), compiz runs fine.

In an attempt to sort out an unrelated issue, I've downgraded to the 173-series nVidia driver. Everything works as it should, but Compiz still refuses to run, citing the same errors as before. This should confirm once and for all that this segfault is not a video driver issue.

Minor correction to my comment - I was misreading the glxgears output, the figure stated is number of frames in 5 seconds, not frames per second. Still, it's within the normal range for my hardware.

That aside, Compiz works fine under Gentoo, with the same hardware, same driver version, and same xorg.conf as under Ubuntu.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. Compiz, in particular, is in heavy development and this bug may have been fixed in the newest version of Ubuntu (12.04). If you are able, it would be of great help if you could confirm if the bug still exists.

Thank you for your help and patience.

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
Toby Smithe (tsmithe) wrote :

Well, considering I wasn't able to describe how to reproduce the bug in the original report, and noting that the original report was almost five years ago, I could not possibly even begin to confirm the continued existence of the bug right now. You may as well close this report, unless anyone else cares to try. Thanks for the response, though: considering the last activity was three years late, being only two years late is a substantial improvement!

I would appreciate a less cheeky response, Toby. If you would like, I could cease triaging bugs altogether in the chance that I have the gall to try and clean up old bugs.

Considering your contributions to packaging, I would hope that you'd know better.

Changed in compiz (Ubuntu):
status: Incomplete → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers