Number of rows of desktops forgotten if no switcher on panel

Bug #116807 reported by Scott James Remnant (Canonical) on 2007-05-25
6
Affects Status Importance Assigned to Milestone
Metacity
Invalid
Medium
compiz (Ubuntu)
Medium
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
metacity (Ubuntu)
Medium
Ubuntu Desktop Bugs
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

Binary package hint: compiz

I had configured 3 rows of desktops; since compiz will have the cute wall plugin, there's no particular need for a switcher on the panel anymore.

I removed the switcher.

Next time I logged in, compiz had forgotten that I had three rows of desktops, and instead gave me a single line of twelve desktops.

(High: composite-by-default blocker)

Changed in compiz:
importance: Undecided → High

(after discussion, upgrading all composite-by-default problems to Critical, since these must be closed for gutsy)

Changed in compiz:
importance: High → Critical

This bug may be in error, it seems that if you use viewports, compiz DOES remember the size (hsize and vsize)

and the problem is just that the switcher is setting up the wrong things, and doesn't support compiz correctly

Sergio Zanchetta (primes2h) wrote :

Hi Scott, I think that this Bug #102309 is related in some way to yours.
It has 16 duplicates and I think it's critical as well as yours.
May you please change its importance to critical? (If you think it is, obviously) :-)
Thanks.

Travis Watkins (amaranth) wrote :

No, that other bug is desktop-effects doing something wrong, this bug is about compiz and the workspace switcher applet not playing nice together. This bug is marked as critical because it's considered a blocker for having compiz enabled by default in gutsy. The other bug is not considered critical because in feisty compiz was considered experimental and the desktop-effects tool will be replaced in gutsy so it won't affect us.

Changed in compiz:
status: New → Confirmed
Anthony S (aaaantoine) on 2007-09-05
Changed in compiz:
assignee: nobody → ubuntu-desktop-effects
Travis Watkins (amaranth) wrote :

Lowering priority and adding metacity task. This doesn't work there either.

Changed in compiz:
importance: Critical → Medium
Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined. According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates

Changed in metacity:
assignee: nobody → desktop-bugs
Changed in metacity:
status: New → Invalid
Travis Watkins (amaranth) wrote :

Well, if metacity isn't going to do it...

Changed in compiz:
status: Confirmed → Invalid

No explaination was given why this has been marked Invalid, this is still a bug!

Changed in compiz:
assignee: ubuntu-desktop-effects → nobody
status: Invalid → Confirmed
Changed in metacity:
status: Invalid → Confirmed

(Though it's worth pointing out that it's a bug that our compiz configuration fixes by dealing with viewports and storing them in compiz's own configuration)

Changed in compiz:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :
Changed in metacity:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in metacity:
status: Unknown → New
Thomas Thurman (marnanel) wrote :

This is a matter for the workspace switcher to decide. Metacity merely uses the setting that's set in the workspace switcher. I can't see how this is metacity's problem.

Thomas Thurman (marnanel) wrote :

I would like to finish dealing with this bug from Metacity's point of view. We have two options here:

1) We can say that this is an invalid bug, because the EWMH says that the switcher decides the workplace layout, and if you remove the switcher, you won't have a workplace layout. Then we can close this bug.

2) We can say that the EWMH is actually wrong, or at least that we're going to work around it here, and get Metacity to go and do this part of the switcher's job for it if the switcher isn't present. (I can't really see this being accepted upstream, but it could be an Ubuntu-specific patch.) We could also try and get the EWMH changed.

It is rather infelicitous that a visible widget is tied to a desktop function in this way.

Thomas Thurman (marnanel) wrote :

A further thought occurred to me while attempting to explain this to someone at 1am over a cheese sandwich.

The EWMH doesn't actually say that the switcher decides the workspace layout. What it says is that _NET_DESKTOP_LAYOUT (which is what decides the number of rows) must only be set by the switcher and never by the window manager.

So if the switcher isn't on the panel, and hasn't been since we started, _NET_DESKTOP_LAYOUT won't be set on a screen at all. Now suppose we started up and found that this wasn't so... well, perhaps the panel hadn't started, so we'd set a timer and come back to the matter a second or so later, and if it still hadn't, we could fish the number of rows out of gconf and pretend we'd read it instead.

The trouble with this, though, is that the number of rows is stored as a property of the applet, so we'd need somewhere else to keep it for this one particular case.

Changed in metacity:
status: New → Invalid

This bug is very old and I was not able to reproduce it with Ubuntu 10.04. Therefore I am closing it. If this is still an issue for anyone with Ubuntu 10.04, please open a new bug. Thanks.

Changed in metacity (Ubuntu):
status: Triaged → Invalid
Changed in metacity:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.