unity showing only blank desktop, no dash nor decorations

Bug #1166765 reported by Leonardo Corato on 2013-04-09
This bug affects 36 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
compiz (Ubuntu)

Bug Description

On startup Unity showed only desktop, no dash, no menus, no window placement nor decorations

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 7.0.0daily13.04.08-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
Uname: Linux 3.8.0-17-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 313.26 Wed Feb 27 13:04:31 PST 2013
 GCC version: gcc version 4.7.3 (Ubuntu/Linaro 4.7.2-23ubuntu2)

ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
CheckboxSubmission: a1c955fd38d4502805ce6f6dc842fe78
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Tue Apr 9 14:39:20 2013
DistUpgraded: 2012-07-27 12:10:50,751 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
 nvidia-313-updates, 313.26, 3.8.0-17-generic, x86_64: installedError! Could not locate dkms.conf file.
 File: does not exist.
 NVIDIA Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:053c]
InstallationDate: Installed on 2011-09-05 (582 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Dell Inc. Vostro 420 Series
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-17-generic root=/dev/mapper/hostname-root ro quiet splash
SourcePackage: unity
UpgradeStatus: Upgraded to raring on 2012-07-27 (256 days ago)
dmi.bios.date: 09/24/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.2
dmi.board.name: 0R038D
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.2:bd09/24/2008:svnDellInc.:pnVostro420Series:pvr:rvnDellInc.:rn0R038D:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: Vostro 420 Series
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.9~daily13.04.05-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.3-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.5-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Tue Apr 9 14:38:29 2013
xserver.configfile: default
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input USB Optical Mouse MOUSE, id 8
 input Dell Dell USB Keyboard KEYBOARD, id 9

xserver.logfile: /var/log/Xorg.0.log

xserver.version: 2:1.13.3-0ubuntu5

Leonardo Corato (leocor) wrote :
Ads20000 (ads20000) wrote :

Sounds like Compiz has crashed...

circum (ferenc-engard) wrote :

Same here. Happened when I installed nvidia-310 package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Christopher Townsend (townsend) wrote :

Some recent bug reports seem to indicate that compiz is crashing when using nVidia hardware. Not sure if this is due to the nVidia drivers or a recent update to compiz. The bug reported in bug #1168151 indicated they also tried the nouveau driver, so it may not be the nVidia driver.

Kai Mast (kai-mast) wrote :

Is there a workaround for this?

When this happens, could you try to press Ctrl+Alt+T, to open a terminal move the mouse over (it seems enough to get the focus on it), and run on that "unity" (or compiz --replace) ?

bp (badpazzword) wrote :

When you do either, the net result is window decorations vanish and windows stop accepting input properly. This makes it hard to post the output for bonus points, but basically the opengl plugin seems to fail to load.

The only way to recover window decorations that I've found is ctrl-alt-f1, login, sudo killall lightdm; sudo lightdm &; login again.

Iain Lane (laney) wrote :

Can someone affected by this please run

  gsettings get org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

in a terminal and paste the output to this bug?

Also please attach your ~/.xsession-errors file.

Then try running

  gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

and restarting/logging out and in to see if you get your session back.

bp (badpazzword) wrote :

$ gsettings get org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
['core', 'ccp', 'composite', 'compiztoolbox', 'decor', 'snap', 'gnomecompat', 'regex', 'resize', 'place', 'grid', 'imgpng', 'vpswitch', 'move', 'mousepoll', 'workarounds', 'session']

$ grep -i error ~/.xsession-errors
compiz (core) - Error: Plugin 'opengl' not loaded.
compiz (core) - Error: Plugin 'opengl' not loaded.
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
[2406:2532:0413/191714:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[2406:2532:0413/191714:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[2406:2406:0413/191716:ERROR:content_settings_pref_provider.cc(492)] Invalid pattern strings: ,*
[2406:2406:0413/191716:ERROR:content_settings_pref_provider.cc(396)] Invalid pattern strings: ,*
[2406:2406:0413/191719:ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
[2406:2406:0413/191754:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[2406:2406:0413/191757:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
** (nautilus:2437): WARNING **: Error calling current_status: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist

bp (badpazzword) wrote :

> gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

Yep, this did the trick. Turns out that "compiz (core) - Error: Plugin 'opengl' not loaded." means "opengl was not loaded and you need to fix this" and not "opengl was not loaded because of an error."

Thank you!

Iain Lane (laney) wrote :

Thanks. I think it's a bug in compiz that when it can't load some plugins for whatever reason (-310 being temporarily broken in this case - presumably you fell back to nouveau and then this didn't work for some reason, which is possibly a separate bug that should be filed if someone can verify that is the case) then it doesn't ever again try to do it until you make it forget. I'll move this bug to compiz. Glad the workaround worked for you.

affects: unity (Ubuntu) → compiz (Ubuntu)
Paweł Bylica (chfast) wrote :

active-plugins: ['core', 'ccp', 'composite', 'compiztoolbox', 'decor', 'vpswitch', 'snap', 'mousepoll', 'resize', 'place', 'move', 'grid', 'regex', 'imgpng', 'session', 'gnomecompat', 'workarounds']

Resetting "active-plugins" does not work for me.

And I'm using Intel i915 driver, but I have Nvidia card also.

bp (badpazzword) wrote :

> -310 being temporarily broken in this case - presumably you fell back to nouveau and then this didn't work for some reason, which is possibly a separate bug that should be filed if someone can verify that is the case

Actually -310 works fine; I can tell which drivers are loaded because Ctrl-Alt-F1 and TF2 work differently based on whichever driver is active.

Changed in compiz:
status: New → Confirmed
importance: Undecided → Critical
milestone: none →
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in compiz (Ubuntu):
importance: Undecided → Critical
Simplehuman (simplehuman) wrote :

It happens to me only after today's updates. Christopher Townsend marked my report as a duplicate. But everything was fine with yesterday's updates.

I have Nvidia GeForce 285GTX and I tried Nouveau driver, 310 driver, and 313-updates drivers.

Simplehuman (simplehuman) wrote :

Workaround of comment #11 works for me

Sam Spilsbury (smspillaz) wrote :

Upon looking at the attached .xsession-errors, I don't think this is a compiz bug:

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".

(gnome-settings-daemon:2437): GnomeDesktop-WARNING **: GL_MAX_TEXTURE_SIZE helper quit unexpectedly

(you can confirm similar errors when running glxinfo &)

What is certainly curious about this is that the Xorg logs and xdpyinfo suggest that the glx extension is loaded on the server side, but the currently loaded libGL.so doesn't think it is, so it refuses to create a context and everything dies after that.

What would be curious is to learn exactly what libGL.so the opengl plugin is being linked to. You can figure that out with the following:

ldd /usr/lib/compiz/libopengl.so

Changed in compiz:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz:
importance: Critical → Undecided
milestone: → none
Changed in compiz (Ubuntu):
importance: Critical → Undecided
brian mullan (bmullan) wrote :

just a comment but before upgrading to the 13.04 beta from 12.10 .. I used clonezilla to copy my 12.10 to a 2nd HD.
When the problem happened to the 13.04 system I figured while troubleshooting I'd just use the 12.10 disk when needed.
It worked okay until a sudo apt-get update && sudo apt-get upgrade on that disk updated something also.
Now... both the 12.10 and the 13.04 disks (separate HDs booted via grub)... are having this same problem.
Only posting this because I thought there might have been a common update to both 13.04 and 12.10 that could give a clue to root cause.

rue (ruenoak) wrote :

gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

This worked for me aswell, I'm using the nvidia-310-updates (proprietary) Driver

brian mullan (bmullan) wrote :

The command:
gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

does work for me ... but its not permanent. After a couple reboots I end up with same problem and have to use that command again to restore the unity desktop's launcher and top panel bar again.

Jamie Lawler (jamie-lawler) wrote :

I'm on a system with both intel HD4000 and a separate nVidia graphics card. Unity was previously fine on 12.10, but after upgrading to 13.04 unity no longer displays.

The fix in comment #11 does NOT work for my system.

Fastjack (skillful) wrote :

Same bug here. Have a Dell Studio 1555, 64-bit, with Nvidia. Unity was working on Ubuntu 12.x, but after upgrading, no more unity. I've tried resetting unity, reinstalling, upgrading my distro, forcing OpenGL to work (doesn't start). I've tried with and without Nvidia's proprietary drivers (even forced beta drivers), to no avail. I've also tried many proposed solutions on the ubuntu forum. I've tried different xorg.conf too. Now I'm considering reverting to a Commodore 64 and emulating linux from the terminal, and live happy ever after ;-) Just kidding. Hope you find a solution.

JG (jozef-gabaj) wrote :
Download full text (5.5 KiB)

Hi all,

Thank you Brian Mullan. Your Command has solved my problem.

info Dell 740 with Nvidia.

MyUserHome@Ubuntu1304:~$ cat .xsession-errors
Script for cjkv started at run_im.
Script for default started at run_im.
Script for cjkv started at run_im.
Script for default started at run_im.
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Error: Plugin 'opengl' not loaded.

compiz (core) - Info: Loading plugin: decor
compiz (core) - Info: Starting plugin: decor
compiz (core) - Info: Loading plugin: gnomecompat
compiz (core) - Info: Starting plugin: gnomecompat
compiz (core) - Info: Loading plugin: resize
compiz (core) - Info: Starting plugin: resize
compiz (core) - Info: Loading plugin: snap
compiz (core) - Info: Starting plugin: snap
compiz (core) - Info: Loading plugin: vpswitch
compiz (core) - Info: Starting plugin: vpswitch
compiz (core) - Info: Loading plugin: imgpng
compiz (core) - Info: Starting plugin: imgpng
compiz (core) - Info: Loading plugin: mousepoll
compiz (core) - Info: Starting plugin: mousepoll
compiz (core) - Info: Loading plugin: place
compiz (core) - Info: Starting plugin: place
compiz (core) - Info: Loading plugin: grid
compiz (core) - Info: Starting plugin: grid
compiz (core) - Info: Loading plugin: regex
compiz (core) - Info: Starting plugin: regex
compiz (core) - Info: Loading plugin: move
compiz (core) - Info: Starting plugin: move
compiz (core) - Info: Loading plugin: session
compiz (core) - Info: Starting plugin: session
I/O warning : failed to load external entity "/home/MyUserHome/.compiz/session/1019cb1c48f3c2df7f137161092010398300000026420030"
compiz (core) - Info: Loading plugin: workarounds
compiz (core) - Info: Starting plugin: workarounds
compiz (core) - Error: Plugin 'opengl' not loaded.

** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon

(nautilus:2769): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(nautilus:2769): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (core) - Warn: Attempted to restack relative to 0x1000013 which is not a child of the root window or a window compiz owns

** (nautilus:2769): WARNING **: Error calling current_status: Method "current_status" with signature "" on interface "com.ubuntuone.SyncDaemon.Status" doesn't exist

** (nautilus:2769): CRITICAL **: syncdaemon_status_info_get_online: assertion `SYNCDAEMON_IS_STATUS_INFO (sinfo)' failed
MyUserHome@Ubuntu1304:~$ ll /home/MyUserHome/.compiz/session/1019cb1c48f3c2df7f137161092010398300000026420030
ls: nelze přistoupit k /home/MyUserHome/.compiz/session/1019cb1c48f3c2df7f137161092010398300000026420030: Adresář nebo soubor neexistuje



Adrian Smith (fon) wrote :

After migrating from another PC, I installed all packages (including nvidia drivers). Since my new PC doesn't have an nvidia card, only HD4000, I removed the nvidia with "apt-get purge nvidia*". Then I had this problem. Same errors in .xsession-errors.

"gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins" has fixed it for now.

TL;DR removing nvidia drivers can cause this problem. Should reset compiz after remove.

Otus (jan-varho) wrote :

I got this when switching from using a discrete AMD GPU (HD 7770) to using an integrated Intel GPU (HD 4000). The gsettings line did the trick.

My ubuntu are on external disk. So, I can switch to any PC. This things often makes either compiz or unity not loaded (blank screen). I use nVidia (GeForce 8100 / nForce 720a).

I endup reinstall nvidia driver (nvidia-310) if I face this bug (apt-get purge and install). After that compiz work but not Unity. Well, then I remove dconf user profile (~/.config/dconf/user) and replace with an older one (backup). Anyway, after that, it works...

Now I try for :
gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

Same problem here, with Ubuntu 13.04 on an HP Pavilion dv3 laptop, with ATI graphic card (using ATI non-free driver).

The command provided by Bryan Mullan (i.e., gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins) worked for me (Thanks Bryan!).

I'm having the same issue on my Lenovo Y570.

It started when i noticed my optirun command was no longer able to find my nVidia card (this model has both an intell and nvidia graphics card) and was trying to tweak some settings.

the gsettings reset command did not work for me

Glen Nelson (glen-nelson-1) wrote :

Hit on desktop running 14.04 and nvida gtx 780. Was running nvidia-3nvidia-3340 drivers

Fixed by uninstalling nvidia drivers:

sudo apt-get purge nvidia*

Then running the gsettings command from post 11.

Once I was back in, I installed the nvidia drivers via the 'additional drivers' interface.

> gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

This worked for me too. The problem occured when I switched from nouveau to the proprietry drivers (-331) from Nvidia.

Trying to fix the issue, I switched back to nouveau, but that didn't help. resetting the active-plugins did.

Stephen M. Webb (bregma) on 2014-10-26
Changed in compiz:
milestone: none →
Stephen M. Webb (bregma) wrote :

This continue to be a problem: if the OpenGL plugin detects a problem once it disables itself and the Compiz configuration must be manually reset before it will even activate again. That leaves a less than satisfactory user experience.

Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
importance: Undecided → High
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
milestone: →
jerryb (gerald-britton) wrote :

I hit this bug when upgrading to Nvidia driver version 340.32. I noticed this error in Xorg.0.log:

[2307136.707] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[2307136.707] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[2307136.707] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[2307136.707] (EE) NVIDIA(0): you continue to encounter problems, Please try
[2307136.707] (EE) NVIDIA(0): reinstalling the NVIDIA driver.

So, I checked to see *which* glx module *was* being loaded:

[2307131.587] (II) LoadModule: "glx"
[2307131.706] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[2307133.490] (II) Module glx: vendor="X.Org Foundation"
[2307133.490] compiled for 1.15.1, module version = 1.0.0
[2307133.490] ABI class: X.Org Server Extension, version 8.0

That didn't look right, so I went to the directory in the message and found two modules there:

 libglx.so libglx.so.340.32

So, it appears that, when I installed the Nvidia driver, the installer did not rename the glx drivers, so I did:

cd /usr/lib/xorg/modules/extensions/
mv libglx.so libglx.so.xorg
cp libglx.so.340.32 libglx.so

after rebooting, all is well!

Chris M (c1ris) wrote :


A couple of the things above were required to get mine working. This is what did it (run from the terminal along side of the broken desktop):

# Login
export DISPLAY=:0
cd /usr/lib/xorg/modules/extensions/
sudo mv libglx.so libglx.so.xorg
sudo cp libglx.so.340.32 libglx.so
gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
sudo reboot

Stephen M. Webb (bregma) on 2015-02-03
Changed in compiz:
milestone: →
Piotr Borowski (optiores) wrote :

It happened to me also when I upgraded from 12.04 --> 14.04 --> 14.10. It occurred after the second update (to 14.10). The solution from comment #9 fixed it.

Cristian (cristian0309) wrote :

Dear All,
I'm new to ubuntu.
I've been trying to install nvidia drivers and cuda to use gpu for machine learning.
I tried different versions, once lost the desktop (had a blank screen) and restored it.

Now, icons went missing...
I've been trying whatever but nothing works....

I've got an asus n550j with two graphic cards.
My gpu is a geforce 750m
ubuntu 14.04

solution from comment 34 didn't work (by the way in extensions i have only libglx.so)

$ gsettings get org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

['core', 'composite', 'opengl', 'compiztoolbox', 'decor', 'vpswitch', 'snap', 'mousepoll', 'resize', 'place', 'move', 'wall', 'grid', 'regex', 'imgpng', 'workarounds', 'session', 'gnomecompat', 'animation', 'fade', 'unitymtgrabhandles', 'scale', 'expo', 'ezoom', 'unityshell']

$ cat .xsession-errors

Xlib: extension "GLX" missing on display ":0".
Script per ibus iniziato in run_im.
Script per auto iniziato in run_im.
Script per default iniziato in run_im.
init: Processo main (2039) del job indicator-secret-agent terminato (kill) dal segnale KILL

What else can I do?
Other workarounds? Update to 14.10?
Thank you for your help!

Stephen M. Webb (bregma) wrote :

@Cristian asking questions on how to fix your system is more of a support issue than something appropriate for a bug against a package. Try http://www.ubuntu.com/support for various methods of getting help.

Remember, if you use an officially unsupported driver (such as a driver downloaded from nVidia directly, as opposed to installing one from the Ubuntu archives) it is not officially supported. Hence the adjective 'unsupported'.

The line 'Xlib: extension "GLX" missing on display ":0"' indicates a problem with your video driver installation. That's at least an indication as to where to start troubleshooting your problem.

Ronnie Tucker (ronnietucker) wrote :

This happened to me after a fresh install of Ubuntu 15.04. It's the Unity option in Compiz settings that is disabled, but Compiz settings isn't installed by default (or wasn't for me anyway).

Easiest way to get things back to normal is to open a terminal and do:

sudo apt-get install compizconfig-settings-manager

then do:


That will give you the Compiz settings manager and from in there you can check the box for Unity and the dash and taskbar will start. Even rebooting should keep Unity now.

Quijote Shin (quijote-shin) wrote :

Ubuntu 15.03, I just changed the nvidia to nvidia-340, also I already has ccsm.

Quijote Shin (quijote-shin) wrote :

[EDIT] ronnie is right, I used ccsm and clicked on ubuntu unity plugin (notorious purple button), it enabled opengl, and others modules and the desktop for me <3


Iain Lane (laney) on 2015-09-04
tags: added: rls-w-incoming
Natalia Bidart (nataliabidart) wrote :

This bug also affects me (already clicked on that), a couple extra info:

* Not running any nvidia drivers nor having an nvidia card:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 215a
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 26
 Region 0: Memory at f2000000 (64-bit, non-prefetchable) [size=4M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 1800 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915

* once the issue was present, dconf did not included unity as active plugin:

nessita@miro:~$ dconf read /org/compiz/profiles/unity/plugins/core/active-plugins
['core', 'ccp', 'move', 'regex', 'mousepoll', 'imgpng', 'snap', 'session', 'compiztoolbox', 'commands', 'resize', 'workarounds']

* running a reset on dconf configs fixed it:

dconf reset /org/compiz/profiles/unity/plugins/core/active-plugins

ZhiFeng Hu (hufeng1987) wrote :

My display driver card was old ATI HD4530 family. i got the same problem.

My screen flicker all the time. so i want to disable OpenGL, but i got this problem.

How to disable OpenGL hardware accelerate for Ubuntu Unity desktop?

To post a comment you must log in.