compiz crashed with SIGABRT in __libc_message()

Bug #1131835 reported by Neven Blazic on 2013-02-22
156
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

https://errors.ubuntu.com/problem/01b56d8b9be875ac46e0c1c066d06a1b12d41e3e

.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: compiz-core 1:0.9.9~daily13.02.19-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-6.13-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Fri Feb 22 17:37:21 2013
DistUpgraded: 2013-01-19 22:44:58,817 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1252]
 NVIDIA Corporation GT216 [GeForce GT 325M] [10de:0a35] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1252]
InstallationDate: Installed on 2013-01-19 (33 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MachineType: ASUSTeK Computer INC. N61Jv
MarkForUpload: True
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-6-generic root=UUID=f31b5c33-9c96-4314-8609-281abe7a54b8 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: compiz
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to raring on 2013-01-19 (33 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 (gnome-settings-daemon:1927): color-plugin-WARNING **: failed to reset xrandr-HSD160PHW1-1162 gamma tables: gamma size is zero
 gnome-session[1855]: WARNING: Application 'compiz.desktop' killed by signal 6
 gnome-session[1855]: WARNING: App 'compiz.desktop' respawning too quickly
 gnome-session[1855]: CRITICAL: We failed, but the fail whale is dead. Sorry....
dmi.bios.date: 01/28/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 208
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: N61Jv
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr208:bd01/28/2010:svnASUSTeKComputerINC.:pnN61Jv:pvr1.0:rvnASUSTeKComputerINC.:rnN61Jv:rvr1.0:cvnASUSTeKComputerINC.:ct10:cvr1.0:
dmi.product.name: N61Jv
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.9~daily13.02.19-0ubuntu1
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.2-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Fri Feb 22 17:29:37 2013
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Neven Blazic (nevenblazic) wrote :

StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0xb7567530 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0xb000e58) at malloc.c:4902
 _int_free (av=0xb75a8440 <main_arena>, p=0xb000e50, have_lock=0) at malloc.c:3758
 operator delete (ptr=0xb000e58) at ../../../../src/libstdc++-v3/libsupc++/del_op.cc:48
 CompTimer::~CompTimer (this=0xb172f50, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.9~daily13.02.19/src/timer/src/timer.cpp:192

Changed in compiz (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGABRT in raise()
+ compiz crashed with SIGABRT in __libc_message()
tags: removed: need-i386-retrace
tags: added: saucy
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-09-17
Changed in compiz:
status: New → Triaged
importance: Undecided → Medium
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
information type: Private → Public
Sascha Biermanns (skbierm) wrote :

That bug also occurs on Ubuntu 13.10 Beta

Edwin Pujols (edwinpm5) wrote :

I am on Utopic and apport redirected me to this bug report.

In my case, compiz crashes when I maximize the Devhelp window and then try to minimize it via the panel buttons. (Devhelp on Utopic uses GtkHeaderBar, hence it does not have a minimize button on the main interface.)

tags: added: utopic
removed: i386 raring saucy
Nazar Mokrynskyi (nazar-pc) wrote :

Wanted to minimize gedit 3.12.2 on Utopic, and it cashed, redirected me here.

Will Cooke (willcooke) wrote :

As part of the big bug clear up for 16.04 LTS I am marking this bug as Wont Fix.
These types of crasher are better handled by errors.ubutnu.com which can collate similar crash reports to help us identify persitent bugs rather than one-off crashes.
Sorry we are not able to help with this specific issue. If you are still experiencing this crash, please re-open the bug and add the tag "desktop-bugscrub-reopened". See https://wiki.ubuntu.com/BigDesktopBugScrub for more information.

Changed in compiz:
status: Triaged → Won't Fix
Changed in compiz (Ubuntu):
status: Triaged → Won't Fix
tags: added: desktop-bugscrub-autoclosed
Andrea Amoroso (heiko81) wrote :

I'm experiencing this bug on Ubuntu 16.04 using the Gnome Software app. When I open the app, there is a black frame around the window. Further, I have a double button panel, one on the Unity upper panel and one inside the window frame.
My Ubuntu installation is up to date. The computer features an Nvidia video card (GeForce 9600M GT) and uses nouveau drivers.

Daniel van Vugt (vanvugt) wrote :

Comment #10 no longer applies.

errors.ubuntu.com led me here, so this is the bug to keep open :)

Changed in compiz (Ubuntu):
status: Won't Fix → Confirmed
Changed in compiz:
status: Won't Fix → Confirmed
description: updated
tags: added: desktop-bugscrub-reopened
removed: desktop-bugscrub-autoclosed
To post a comment you must log in.