Alt+Tab stopped working after upgrade to 12.10

Bug #1131361 reported by Gregor Mandel on 2013-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I recently upgraded from PP to QQ which broke the ability to switch between running applications by pressing Alt+Tab.

The affected host is a ThinkPad X61s. I don't know if this is of any relevance but I think Unity/Compiz is running on/in LLVM.

Until now I tried several countermeasures in any combination imaginable to fix this:

1. bound, unbound and rebound the Settings/Keyboard/Shortcuts/Navigation/Switch applications key over and over again
2. massive amount of reboots
3. activated, deactivated, reactivated switchers and set, unset, reset plugins and their key bindings - even other ones as Alt+Tab - in ccsm under
  3.1 Unity Plugin
  3.2 Window Mgmt - Application switcher and Static application switcher
4. deactivated Alt as a hotkey for the HUD
5. even switching keyboard layouts

It may be worth mentioning that the Alt keys themselves are working as shown by xev. I can access the application menu, too. What makes me wonder is the fact that I can get the HUD by tapping Alt_R but not by pressing Alt_L (so I tried removing the HUD key binding which as stated didn't help). App switching itself is not possible using either Alt key.

This behaviour is the same using the internal keyboard as well as a bluetooth one.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1131361/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Gregor Mandel (launghpad) wrote :

Probably compiz causing this

affects: ubuntu → compiz (Ubuntu)
Gregor Mandel (launghpad) wrote :

Alt+Tab wasn't fixed by 13.04. Nevertheless I stumbled upon the fact that Guest can still switch apps with Alt+Tab which makes me wonder even more. It stopped working under my main account with updating to 12.10 but guest is not affected. So there is an incompatibility only occurring under specific circumstances ...

Can anyone provide some tips how to debug further?

Neal McBurnett (nealmcb) wrote :

Is this a dup of bug 1169045? Do you have compiz-plugins installed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers