CCSM: No icons and text in main screen, submenus of the plugins work normally

Bug #1130941 reported by Alan Bell on 2013-02-20
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
MC Return
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

all the plugin icons appear to be broken

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: compizconfig-settings-manager 1:0.9.9~daily13.02.19-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.14-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.8-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Feb 20 22:14:13 2013
DistUpgraded: 2013-01-29 21:13:26,919 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.2.6, 3.5.0-23-generic, x86_64: installed
 vboxhost, 4.2.6, 3.8.0-2-generic, x86_64: installed
 vboxhost, 4.2.6, 3.8.0-5-generic, x86_64: installed
 vboxhost, 4.2.6, 3.8.0-6-generic, x86_64: installed
 vboxhost, 4.2.6, 3.8.0-7-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c06a]
InstallationDate: Installed on 2012-05-01 (295 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120421)
MachineType: SAMSUNG ELECTRONICS CO., LTD. R530/R730
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-7-generic root=UUID=a1919e83-6201-440f-bc38-4482a9274054 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to raring on 2013-01-29 (22 days ago)
dmi.bios.date: 03/12/2010
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 03JV.M011.20100312.hkk
dmi.board.asset.tag: Tag 12345
dmi.board.name: R530/R730
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr03JV.M011.20100312.hkk:bd03/12/2010:svnSAMSUNGELECTRONICSCO.,LTD.:pnR530/R730:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnR530/R730:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: R530/R730
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.9~daily13.02.19-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.2-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Wed Feb 20 21:45:03 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Related branches

Alan Bell (alanbell) wrote :
MC Return (mc-return) on 2013-02-20
Changed in compiz (Ubuntu):
status: New → Confirmed
summary: - no icons in ccsm
+ CCSM: No icons and text in main screen, submenus of the plugins work
+ normally
Changed in compiz:
status: New → Confirmed
MC Return (mc-return) wrote :
Download full text (35.1 KiB)

This is the console output, when starting CCSM:

$ ccsm
compizconfig - Info: Backend : ini
compizconfig - Info: Integration : true
compizconfig - Info: Profile : Default
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Loading icons...
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 54, in apport_excepthook
    if not enabled():
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 27, in enabled
    with open(CONFIG) as f:
RuntimeError: maximum recursion depth exceeded

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 54, in apport_excepthook
    if not enabled():
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 27, in enabled
    with open(CONFIG) as f:
RuntimeError: maximum recursion depth exceeded

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 54, in apport_excepthook
    if not enabled():
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 27, in enabled
    with open(CONFIG) as f:
RuntimeError: maximum recursion depth exceeded

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/ccm/Utils.py", line 190, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursi...

Changing line

        ret = super (PrettyButton, self).do_expose_event (self, event)

to

        ret = gtk.Button.do_expose_event (self, event)

(in /usr/lib/python2.7/dist-packages/ccm/Utils.py)

restores proper functionality for me.

I suppose some classes are mutually inheriting from each other or something similar.

MC Return (mc-return) wrote :

danilo, thanks a lot for finding a fix.
I can confirm it works and will propose a branch merge proposal to fix it in trunk.

Thanks danilo, that fix works for me too.

MC Return (mc-return) on 2013-02-25
Changed in compiz:
assignee: nobody → MC Return (mc-return)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.9.2

Changed in compiz:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.02.26-0ubuntu1

---------------
compiz (1:0.9.9~daily13.02.26-0ubuntu1) raring; urgency=low

  [ Sam Spilsbury ]
  * debian/ccp_plugin.patch:
    - Added new option --no-auto-load-ccp to prevent the ccp
      plugin from autoloading. Useful for tests where having
      this behaviour just causes problems from unwanted side-effects
    - Also adjust test framework to pass the new option
    - Fix typo
  * debian/rules:
    - We already auto-load the ccp plugin, no need to add it to the
      default plugins.
  * debian/control:
    - Add xorg-gtest, xserver-xorg-dev, libxi-dev as build-deps
  * debian/ubuntu_config.patch:
    - Adjust EWMH test for new value

  [ Sam Spilsbury <email address hidden>, Brandon Schaefer ]
  * [2013/02/20] compiz/unity don't run, just loading cpp (LP: #1130679)

  [ Sam Spilsbury ]
  * Unity: wrong window dimensions / location in Java applications (LP:
    #1110138)
  * Add copytex to default/unity profiles (LP: #1130160)
  * Closing windows sometimes shows black areas using Nvidia 313.x
    drivers (LP: #1119608)
  * [2013/02/20] compiz/unity don't run, just loading cpp (LP: #1130679)
  * Run xorg-gtest tests in CI (LP: #1120009)

  [ MC Return ]
  * CCSM: No icons and text in main screen, submenus of the plugins work
    normally (LP: #1130941)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3621
 -- Automatic PS uploader <email address hidden> Tue, 26 Feb 2013 04:02:36 +0000

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Stephen M. Webb (bregma) on 2015-03-19
Changed in compiz:
status: Fix Committed → Fix Released
dman777 (coolio) wrote :

Thank you so much for fixing this!!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers