[clang] Multiple segfaults in test: SetSemantics

Bug #1089251 reported by Daniel van Vugt on 2012-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel van Vugt
compiz (Ubuntu)
High
Daniel van Vugt

Bug Description

[clang] Multiple segfaults in test: SetSemantics/SettingDefaulImplSetFailure

NOTE: You need the fix for bug 1089250 before you can reproduce it.

The following tests FAILED:
 196 - SetSemantics/SettingDefaulImplSetFailure.ToFailValue/2 (SEGFAULT)
 197 - SetSemantics/SettingDefaulImplSetFailure.ToFailValue/3 (SEGFAULT)
 201 - SetSemantics/SettingDefaultImplSet.Construction/3 (SEGFAULT)
 202 - SetSemantics/SettingDefaultImplSet.Construction/4 (SEGFAULT)
 211 - SetSemantics/SettingDefaultImplSet.Construction/13 (SEGFAULT)
 212 - SetSemantics/SettingDefaultImplSet.Construction/14 (SEGFAULT)
 221 - SetSemantics/SettingDefaultImplSet.WithInvalidType/3 (SEGFAULT)
 222 - SetSemantics/SettingDefaultImplSet.WithInvalidType/4 (SEGFAULT)
 231 - SetSemantics/SettingDefaultImplSet.WithInvalidType/13 (SEGFAULT)
 232 - SetSemantics/SettingDefaultImplSet.WithInvalidType/14 (SEGFAULT)
 241 - SetSemantics/SettingDefaultImplSet.ToNewValue/3 (SEGFAULT)
 242 - SetSemantics/SettingDefaultImplSet.ToNewValue/4 (SEGFAULT)
 251 - SetSemantics/SettingDefaultImplSet.ToNewValue/13 (SEGFAULT)
 252 - SetSemantics/SettingDefaultImplSet.ToNewValue/14 (SEGFAULT)
 261 - SetSemantics/SettingDefaultImplSet.ToSameValue/3 (SEGFAULT)
 262 - SetSemantics/SettingDefaultImplSet.ToSameValue/4 (SEGFAULT)
 271 - SetSemantics/SettingDefaultImplSet.ToSameValue/13 (SEGFAULT)
 272 - SetSemantics/SettingDefaultImplSet.ToSameValue/14 (SEGFAULT)
 281 - SetSemantics/SettingDefaultImplSet.ToDefaultValue/3 (SEGFAULT)
 282 - SetSemantics/SettingDefaultImplSet.ToDefaultValue/4 (SEGFAULT)
 291 - SetSemantics/SettingDefaultImplSet.ToDefaultValue/13 (SEGFAULT)
 292 - SetSemantics/SettingDefaultImplSet.ToDefaultValue/14 (SEGFAULT)
 301 - SetSemantics/SettingDefaultImplSet.IsDefaultValue/3 (SEGFAULT)
 302 - SetSemantics/SettingDefaultImplSet.IsDefaultValue/4 (SEGFAULT)
 311 - SetSemantics/SettingDefaultImplSet.IsDefaultValue/13 (SEGFAULT)
 312 - SetSemantics/SettingDefaultImplSet.IsDefaultValue/14 (SEGFAULT)
Errors while running CTest

Related branches

Changed in compiz:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Sam Spilsbury (smspillaz)
description: updated
Changed in compiz:
milestone: none → 0.9.9.0
Daniel van Vugt (vanvugt) wrote :
Download full text (5.5 KiB)

valgrind compizconfig/libcompizconfig/tests/compizconfig_test_ccs_setting
==11525== Memcheck, a memory error detector
==11525== Copyright (C) 2002-2011, and GNU GPL'd, by Julian Seward et al.
==11525== Using Valgrind-3.7.0 and LibVEX; rerun with -h for copyright info
==11525== Command: compizconfig/libcompizconfig/tests/compizconfig_test_ccs_setting
==11525==
Running main() from gtest_main.cc
[==========] Running 126 tests from 4 test cases.
[----------] Global test environment set-up.
[----------] 1 test from CCSSettingTest
[ RUN ] CCSSettingTest.TestMock
[ OK ] CCSSettingTest.TestMock (585 ms)
[----------] 1 test from CCSSettingTest (593 ms total)

[----------] 1 test from CCSSettingDefaultImplTest
[ RUN ] CCSSettingDefaultImplTest.Construction
[ OK ] CCSSettingDefaultImplTest.Construction (77 ms)
[----------] 1 test from CCSSettingDefaultImplTest (78 ms total)

[----------] 120 tests from SetSemantics/SettingDefaultImplSet
[ RUN ] SetSemantics/SettingDefaultImplSet.Construction/0
[ OK ] SetSemantics/SettingDefaultImplSet.Construction/0 (47 ms)
[ RUN ] SetSemantics/SettingDefaultImplSet.Construction/1
[ OK ] SetSemantics/SettingDefaultImplSet.Construction/1 (8 ms)
[ RUN ] SetSemantics/SettingDefaultImplSet.Construction/2
[ OK ] SetSemantics/SettingDefaultImplSet.Construction/2 (5 ms)
[ RUN ] SetSemantics/SettingDefaultImplSet.Construction/3
==11525== Invalid read of size 1
==11525== at 0x4C2BD02: __GI_strlen (in /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
==11525== by 0x5D9CD65: strdup (strdup.c:42)
==11525== by 0x4872A6: (anonymous namespace)::NormalValueContainer<char const*>::getContainedValue(_CCSSettingType, boost::shared_ptr<_CCSSettingInfo> const&) (compizconfig_test_ccs_setting.cpp:501)
==11525== by 0x487598: (anonymous namespace)::TypedSetParam<char const*>::SetUpSetting(boost::function<void ()((anonymous namespace)::MockInitFuncs&)> const&) (compizconfig_test_ccs_setting.cpp:1021)
==11525== by 0x47F442: (anonymous namespace)::SettingDefaultImplSet::SetUp() (compizconfig_test_ccs_setting.cpp:1272)
==11525== by 0x4C741A: void testing::internal::HandleExceptionsInMethodIfSupported<testing::Test, void>(testing::Test*, void (testing::Test::*)(), char const*) (gtest.cc:2090)
==11525== by 0x4B6DA3: testing::Test::Run() (gtest.cc:2157)
==11525== by 0x4B7B3F: testing::TestInfo::Run() (gtest.cc:2338)
==11525== by 0x4B8168: testing::TestCase::Run() (gtest.cc:2445)
==11525== by 0x4BD0C4: testing::internal::UnitTestImpl::RunAllTests() (gtest.cc:4243)
==11525== by 0x4C7D0A: bool testing::internal::HandleExceptionsInMethodIfSupported<testing::internal::UnitTestImpl, bool>(testing::internal::UnitTestImpl*, bool (testing::internal::UnitTestImpl::*)(), char const*) (gtest.cc:2090)
==11525== by 0x4BCD9D: testing::UnitTest::Run() (gtest.cc:3878)
==11525== Address 0x0 is not stack'd, malloc'd or (recently) free'd
==11525==
==11525==
==11525== Process terminating with default action of signal 11 (SIGSEGV)
==11525== Access not within mapped region at address 0x0
==11525== at 0x4C2BD02: __GI_strlen (in /usr/lib/valgrind/vgpreload_memcheck-amd...

Read more...

Changed in compiz:
assignee: Sam Spilsbury (smspillaz) → Daniel van Vugt (vanvugt)
Changed in compiz (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

Only High severity now. The segfaults seem to be caused by bugs in the test cases only.

Changed in compiz:
importance: Critical → High
Changed in compiz (Ubuntu):
importance: Critical → High
Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
summary: - [clang] Multiple segfaults in test:
- SetSemantics/SettingDefaulImplSetFailure.
+ [clang] Multiple segfaults in test: SetSemantics
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.14-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.14-0ubuntu1) raring; urgency=low

  [ sampo555 ]
  * compiz crashed with SIGSEGV in DodgeAnim::applyDodgeTransform() (LP:
    #1048840)
  * compiz crashing if window un-/minimize animation is "Random" (LP:
    #1098185)

  [ Daniel van Vugt ]
  * Several leaks in new GLProgram from compileProgram() from
    GLScreen::getProgram() from GLWindowAutoProgram::getProgram() (LP:
    #1097644)

  [ Sam Spilsbury ]
  * Several leaks in ccsIntegratedSettingListAppend() ... from
    ccsGNOMEIntegrationBackendGetIntegratedSetting() from readSetting
    (gsettings.c:375) (LP: #1097661)

  [ MC Return ]
  * Thumbnail Window Previews: Flickering of background/glow and window
    title text (LP: #1098758)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3561
 -- Automatic PS uploader <email address hidden> Mon, 14 Jan 2013 04:03:09 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers