window management - if a window is always on top, it will always get focus after switching between workspaces

Bug #1073488 reported by Masoud Abkenar on 2012-10-31
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Andrea Azzarone
compiz (Ubuntu)
Medium
Andrea Azzarone
Xenial
Undecided
Unassigned

Bug Description

Imagine I have an small terminal window open all the time for doing quick arithmetics. I have set it to be always on top since I need to constantly see it. I have also some other windows open (other terminals, nautilus etc.) on which I am really working and they have the window focus most of the time.

What happens:
Whenever I switch to another workspace and come back to the current workspace, I see the 'always on top' window gets the focus, even if I left that workspace when another window had the focus.

What should happen:
When some window has the focus in any workspace, it should keep the focus. By switching to a new workspace, focus of the windows of the old workspace should not change.

How to reproduce the bug:
Open several windows in a workspace. Make one of the windows 'always on top' from its window accessibility menu (Window 1). Then click on some other window to give it focus (Window 2). Now go to another workspace (by pressing Ctrl+Alt+Left/Right) and then come back. You will see that Window 1 has the focus, instead of Window 2.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.16.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Oct 31 09:59:56 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.40, 3.2.0-29-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-31-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-32-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 440] [10de:0de0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83b0]
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_experimental_304 - NVIDIA accelerated graphics driver (**experimental** beta) (Proprietary, Disabled, Not in use)
 xorg:nvidia_experimental_310 - NVIDIA accelerated graphics driver (**experimental** beta) (Proprietary, Disabled, Not in use)
MachineType: System manufacturer System Product Name
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-32-generic root=UUID=b8c1967c-1d4e-4034-bed5-3b1357a3d26b ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 09/20/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2001
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8P67 REV 3.1
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2001:bd09/20/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8P67REV3.1:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.8-0ubuntu1.4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-0ubuntu0.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Masoud Abkenar (mabkenar) wrote :
affects: unity (Ubuntu) → compiz (Ubuntu)
Iven Hsu (ivenvd) on 2012-11-01
Changed in compiz:
status: New → Confirmed
Iven Hsu (ivenvd) wrote :

Confirmed here.

Sometimes after a scale, it also gets focus. Maybe related with this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
MC Return (mc-return) on 2012-11-12
tags: added: quantal
MC Return (mc-return) on 2013-05-28
Changed in compiz:
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) on 2013-07-21
Changed in compiz:
milestone: none → 0.9.10.0
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.0 → 0.9.11.0
importance: Undecided → Medium
status: Confirmed → Triaged
Masoud Abkenar (mabkenar) wrote :

I still have this bug on 13.10.

There is also another bug about Window management: snapped windows move unexpectedly when switching between workspaces. I try to look if somebody else has already reported it. If not, I file a new bug.

Masoud Abkenar (mabkenar) wrote :

Bug exists in Ubuntu 14.04.

fcole90 (fcole90) wrote :

As part of the big bug review for 16.04 LTS I have tested this on 15.10 and the bug is still there..

But is it a bug or a feature?

tags: added: desktop-bugscrub-triaged
Masoud Abkenar (mabkenar) wrote :

Being 'Always On Top' is about being visible, not having the focus. (In fact, we usually use this feature when we want the window to be visible when it does NOT have the focus.) Therefore I definitely think this is a bug, not a feature.

Shane Synan (digitalcircuit) wrote :

I often have a calculator or a simple note-pad window always on top for quick reference while I'm typing into a document below it. Switching workspaces means I have to give focus back to the document every time. I agree with ~amirmasoud that this is a bug, not a feature.

If there's any way I may help with debugging (such as running a test build), let me know!

Tom Colley (tcolley) wrote :

I agree with the previous two comments - this is a bug. The problem/behaviour does defeat the purpose of the "Always on Top" feature - to remain visible without retaining focus - when using multiple workspaces. Cheers :-)

Changed in compiz:
assignee: MC Return (mc-return) → Andrea Azzarone (azzar1)
Changed in compiz (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
Changed in compiz:
status: Triaged → In Progress
tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.13.0+16.10.20160801.3-0ubuntu1

---------------
compiz (1:0.9.13.0+16.10.20160801.3-0ubuntu1) yakkety; urgency=medium

  [ Andrea Azzarone ]
  * focusDefaultWindow: focus Most Recently Used (MRU) window and
    fallback to the top window in case MRU list is not available. (LP:
    #1073488, #1459671)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 01 Aug 2016 13:25:42 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Masoud Abkenar (mabkenar) wrote :

Yay! Thank you for fixing this bug. Will this get backported to Xenial?

Hello Masoud, or anyone else affected,

Accepted compiz into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/compiz/1:0.9.12.2+16.04.20160801.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.2+16.04.20160801.3-0ubuntu1

---------------
compiz (1:0.9.12.2+16.04.20160801.3-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Don't activate expo if not needed (1x1 setup) (LP: #1606254)
  * Don't crash if gsettings key is not found. Default value will be
    used. (LP: #1044662)
  * focusDefaultWindow: focus Most Recently Used (MRU) window and
    fallback to the top window in case MRU list is not available. (LP:
    #1073488, LP: #1459671)

  [ Marco Trevisan (Treviño) ]
  * Unity MigrationScript: sync gsettings on exit, and only use dconf on
    failure (LP: #1605011)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 01 Aug 2016 13:41:42 +0000

Changed in compiz (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andrea Azzarone (azzar1) on 2016-11-04
Changed in compiz:
status: In Progress → Fix Released
To post a comment you must log in.