Unity fails to load on old hardware (compiz enabling LLVMpipe has no effect and Mesa tries to use hardware still)

Bug #1066764 reported by Colin Law on 2012-10-15
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
Nux
Triaged
High
Unassigned
compiz (Ubuntu)
High
Łukasz Zemczak
nux (Ubuntu)
High
Unassigned

Bug Description

Following the removal of unity-2d, Unity will not run on some hardware that does not support 3d. On login I get the background image but no launcher or panel.
.xsession-errors attached

If I add to /etc/environment the line
    LIBGL_ALWAYS_SOFTWARE=1
then unity start ok

This problem appeared after the fix to bug #1039155 (Unity fails to load on old hardware (blank desktop; only wallpaper). Missing automatic fallback to LLVMpipe when unity_support_test fails) was released.

Related branches

Colin Law (colin-law) wrote :
Omer Akram (om26er) on 2012-10-15
Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

The fix for bug 1039155 that causes this bug is a distro patch. It doesn't relate to upstream compiz.

Changed in compiz:
status: New → Invalid
Changed in compiz (Ubuntu):
milestone: none → quantal-updates
summary: - Unity fails to load on old hardware (blank desktop; only wallpaper).
+ Unity fails to load on old hardware [BadAlloc ... Minor opcode of failed
+ request: 3 (X_GLXCreateContext)]

The attached nux branch should solve this bug. But only if/after the compiz fix for bug 1039155 is removed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: Invalid → Confirmed
summary: - Unity fails to load on old hardware [BadAlloc ... Minor opcode of failed
- request: 3 (X_GLXCreateContext)]
+ Unity fails to load on old hardware (enabling LLVMpipe has no effect and
+ Mesa tries to use hardware still)
Changed in nux:
status: New → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → High
Changed in nux (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in compiz:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in nux (Ubuntu):
status: Confirmed → Triaged
summary: - Unity fails to load on old hardware (enabling LLVMpipe has no effect and
- Mesa tries to use hardware still)
+ Unity fails to load on old hardware (compiz enabling LLVMpipe has no
+ effect and Mesa tries to use hardware still)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.04.18.1~13.04-0ubuntu4

---------------
compiz (1:0.9.9~daily13.04.18.1~13.04-0ubuntu4) saucy; urgency=low

  * Remove debian/patches/unity_support_test.patch
    - Running the support test from compiz has bad side effects, so we no
      longer require this patch (also LP: #1066764)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Mon, 12 Aug 2013 13:11:18 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

The fix is still missing from upstream lp:compiz. Please don't forget to fix upstream, preferably first.

Changed in nux:
status: In Progress → Triaged
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz (Ubuntu):
milestone: quantal-updates → none
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz:
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in nux:
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in nux (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in compiz:
milestone: none → 0.9.11.0
Changed in compiz:
assignee: Łukasz Zemczak (sil2100) → nobody
Changed in nux:
assignee: Łukasz Zemczak (sil2100) → nobody
Changed in nux (Ubuntu):
assignee: Łukasz Zemczak (sil2100) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers