compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX() from TfpTexture::bindTexImage()

Bug #1060327 reported by Thibaut Brandscheid on 2012-10-02
240
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
0.9.8
High
Daniel van Vugt
compiz (Ubuntu)
High
Sam Spilsbury
Nominated for Quantal by Alan Pope 🍺🐧🐱 🦄

Bug Description

[Test Case]

Making sure the crash does not happen again.

[Regression Potential]

No regression potential.

Original description:

Running Ubuntu in Virtual Box:
Description: Ubuntu quantal (development branch)
Release: 12.10
Codename: quantal
Linux quantal 3.5.0-16-generic #25-Ubuntu SMP Fri Sep 28 22:31:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

The crash window poped up after searching and installing Blender from inside the Dash.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Tue Oct 2 18:52:26 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
SegvAnalysis:
 Segfault happened at: 0x7fbd65dc53aa: mov 0x30(%rax),%rax
 PC (0x7fbd65dc53aa) ok
 source "0x30(%rax)" (0x200000032) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
 compiz::opengl::bindTexImageGLX(ServerGrabInterface*, unsigned long, unsigned long, boost::function<bool (unsigned long)> const&, boost::function<void (unsigned long)> const&, boost::function<void ()> const&, compiz::opengl::_PixmapSource) () from /usr/lib/compiz/libopengl.so
 TfpTexture::bindTexImage(unsigned long const&) () from /usr/lib/compiz/libopengl.so
 TfpTexture::bindPixmapToTexture(unsigned long, int, int, int, compiz::opengl::_PixmapSource) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 gnome-session[1884]: WARNING: Application 'compiz.desktop' killed by signal 11
 gnome-session[1884]: WARNING: App 'compiz.desktop' respawning too quickly
 gnome-session[1884]: CRITICAL: We failed, but the fail whale is dead. Sorry....

Related branches

visibility: private → public
visibility: public → private
summary: - compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX()
+ compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX() from
+ TfpTexture::bindTexImage() from ... from
+ GLTexture::bindPixmapToTexture() from DecorTexture::DecorTexture()
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
milestone: none → 0.9.9.0
information type: Private → Public
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1060327

tags: added: iso-testing
Changed in compiz:
status: New → Confirmed
Para Siva (psivaa) on 2012-12-04
tags: added: qa-daily-testing qa-manual-testing rls-r-incoming
Gema Gomez (gema) on 2012-12-05
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
importance: Undecided → High
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Para Siva (psivaa) wrote :

Attached a crash file occurred with 1:0.9.9~daily12.12.05 version if it would help. I tried using apport to report a bug with the attached crash file to see if it produce the traces but apport only uploads the crash and not allowing to proceed further in reporting it as a bug.
Just to make sure, the crash is occurring in both VBox and KVM and on both amd64 and i386.

Just booting with the iso to the live session (do not need to do anything, just wait till you hear the drums sound) will produce the crash. The result is a black blank screen with only the indicator icons at the right corner of the top bar being present.

'sudo pkill -9 X' will bring back the live session desktop and the installation could go ahead from there.

Daniel van Vugt (vanvugt) wrote :

psivaa:

That .crash file shows a slightly different kind of crash to this one. I would say please log a new bug for it. But first it is worth testing the fix for this bug. The fix has landed in compiz 0.9.9 revision 3511, which looks like it should be in daily12.12.07 or later (not published yet).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily12.12.05-0ubuntu2

---------------
compiz (1:0.9.9~daily12.12.05-0ubuntu2) raring; urgency=low

  * Backport a tentative fix from rev 3387 for LP: #1060327
 -- Didier Roche <email address hidden> Fri, 07 Dec 2012 09:28:46 +0100

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Para Siva (psivaa) wrote :

@vanvugt:
I could not see any crash with the latest compiz, (tried with 20121210) and there fore not reporting a separate bug. Thanks

Daniel van Vugt (vanvugt) wrote :

OK, thanks...

Fix committed to lp:compiz/0.9.8 at revision 3427, scheduled for release in Compiz 0.9.8.8

summary: compiz crashed with SIGSEGV in compiz::opengl::bindTexImageGLX() from
- TfpTexture::bindTexImage() from ... from
- GLTexture::bindPixmapToTexture() from DecorTexture::DecorTexture()
+ TfpTexture::bindTexImage()
description: updated
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

marking as closed (0.9.8 series is obsolete)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers