Ubuntu

Ubuntu 12.10 multi-monitor support is having issues

Reported by zzarko on 2012-09-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

I just installed 12.10 beta 2, and updated all the packages. I was hoping that multi-monitor support will get better, but I was in for a big surprise: not that it isn't better, it's worse than it was in 12.04.

I have a i5 machine with 8GB ram, AMD 7950 graphic card, an Dell 24" monitor and Acer projector. After the installation on HD (I used open source driver), my system was configured in mirror mode, with 1024x768 resolution (Screen01; 1400x1050 was just chosen, not applied, it was changed to 1024x768 before turning off mirror mode). In 12.04, because I was unable to mirror monitor's 1920x1200 to projector's 1024x768, I was keeping them in side-by-side configuration. So, my first impulse was to turn off the mirror mode (Screen02, screenshot of Expo view on Screen03). After clicking on Apply, I got all my windows dissapeared (Screen04, photograph). As it turned out, all my windows were moved to second screen (projector, which was just plugged in, but not turned on), which can be seen on screenshot Screen05. Expo view also gave me nothing (Screen06, photograph), but screenshot of Expo view shows that there are windows (Screen07) - why is this different???

On my next attempt, I turned off Mirror mode AND turned off the projector at the same time, and was finally able to see all windows on the monitor. After that, I changed monitor's resolution to 1920x1200 and I tried to turn mirror mode on, and got completly screwed-up desktop (Screen07). I tried to expand shrinked windows and got something like Screen08. Because it was impossible to recover desktop, I logged out and logged back in, and launcher was gone (Screen10). After several failed attempts to bring it back, I logged out, deleted all settings from home folder (.config, .compiz, .gconf), logged back in and launcher was back.

Additionally, on Display settings, if I click on projector icon (Acer), and then on monitor icon (Dell), I cannot click again on Projector - it just isn't active anymore. By accident, I discovered that area ABOVE the projector icon was active (Screen11, there is no cursor on screenshot, but you can see the tooltip just above from where it is).

My next test was to see if windows are on their places when projector display is turned on and off. Screen12 shows initial window configuration, with projector turned off. After turning projector on (Display settings), the windows were moved, just like in 12.04 (Screen13). Additionally, terminal and text editor were maximized (they weren't before). I then aranged windows to where they should be (Screen14), turned projector off, and they were moved again (Screen15). Notice that terminal and text editor windows are split between two workspaces, but one half of text editor window isn't visible. After clicking on it, the other half became visible (Screen16).

Additionally, whenever I turn projector on or off, the mouse is moved on some seemingly random location.

There is more, but this is what I experienced in the first half hour of trying 12.10 beta 2. All pictures are in attached archive.

If someone needs me to do additional tests, I'll gladly do, because 12.10 in this state just isn't usable for me.

zzarko (zzarko-gmail) wrote :
zzarko (zzarko-gmail) wrote :

The same errors are happening with AMD's proprietary drivers. And, I forgot to mention, I'm using 64-bit version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
summary: - Ubuntu 12.10 Beta 2 multi-monitor support is broken beyond beleif
+ Ubuntu 12.10 multi-monitor support is having issues
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the bug is not easy to deal with because the description describe several issues accross several components

Tthe main problem [1] seems to be compiz's windows placement though , reassigning there though I'm not sure if it wouldn't be better to open different bugs about the different issues

[1] "it turned out, all my windows were moved to second screen (projector, which was just plugged in, but not turned on), which can be seen on screenshot Screen05. Expo view also gave me nothing (Screen06, photograph), but screenshot of Expo view shows that there are windows"

affects: gnome-control-center (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
status: New → Confirmed
zzarko (zzarko-gmail) wrote :

I have waited a bit to install 12.10, and I did it today (all updated). I still have all the issues mentioned here, regarding Display settings:

1. I can click on screen icons and activate them only the first time I click, after that screen icons became inactive and if I want to activate them, I need to click above them

2. Windows are moved around when activating/deactivating screens (except the ones on current workspace)

3. Mouse is placed on seemingly random position after activating/deactivating a screen

Daniel, shall I report them individually like this? What should I put for package (compiz, gnome-control-center, ...)? Maybe ubuntu-bug <package name>?

Pinx (marcel-van-pinxteren) wrote :

I think I am experiencing the same issues. When I use Remmina (remote desktop) or VMWare player, and try to move windows to another screen or workspace, they jump to seemingly random screens.
After some clicking and moving around, I often get the window on the screen I want, but if I switch applications, things get funny again. I try to prevent my colleagues from seeing this; it's embarrassing.
I have been using Mac OSX until recently. I have never seen such good support for multiple monitors. Let's hope Ubuntu gets the same quality. Let's hope this bug gets higher priority. More and more people use multiple monitors.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments