[fglrx] compiz crashed with SIGSEGV in glXDestroyContext() [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen()

Bug #1054724 reported by Flashrom on 2012-09-22
102
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel van Vugt
Compiz Core
High
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

i dont see the taskbar

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8.2+bzr3377-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sat Sep 22 19:33:40 2012
DistUpgraded: 2012-08-02 14:18:46,689 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RS780 [Radeon HD 3200] [1002:9610] (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:4590]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120405)
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-6650
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=cbbb41b2-a4fa-410a-bf4e-ac9b1f39893f ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7fec593cd59b <glXDestroyContext+59>: mov 0x19c(%rbx),%eax
 PC (0x7fec593cd59b) ok
 source "0x19c(%rbx)" (0x101010000019c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 glXDestroyContext () from /usr/lib/fglrx/libGL.so.1
 GLScreen::~GLScreen() () from /usr/lib/compiz/libopengl.so
 GLScreen::~GLScreen() () from /usr/lib/compiz/libopengl.so
 PluginClassHandler<GLScreen, CompScreen, 6>::get(CompScreen*) () from /usr/lib/compiz/libopengl.so
 PrivateGLWindow::PrivateGLWindow(CompWindow*, GLWindow*) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in glXDestroyContext()
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 1: X Error of failed request: BadRequest (invalid request code or no such operation)
   Major opcode of failed request: 153 (GLX)
   Minor opcode of failed request: 19 (X_GLXQueryServerString)
   Serial number of failed request: 22
   Current serial number in output stream: 22
UpgradeStatus: Upgraded to quantal on 2012-08-02 (51 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 10/20/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080015
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7459
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080015:bd10/20/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-6650:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7459:rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-6650
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Related branches

Flashrom (m-schult) wrote :

StacktraceTop:
 ?? () from /tmp/tmp4Bq2dT/usr/lib/fglrx/libGL.so.1
 ?? ()
 modHandler () from /tmp/tmp4Bq2dT/usr/lib/libcompiz_core.so.ABI-20120920
 ?? ()
 GLScreen::~GLScreen (this=0x1010100000000, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.8.2+bzr3377/plugins/opengl/src/screen.cpp:1121

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace

I think this is the same issue as bug 1054257. And both are a side-effect of the fix for bug 944653.

visibility: private → public
summary: compiz crashed with SIGSEGV in glXDestroyContext()
+ [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen()
Changed in compiz:
milestone: none → 0.9.8.4
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
summary: - compiz crashed with SIGSEGV in glXDestroyContext()
+ [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
[/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen()
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3388

Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.4-0ubuntu1

---------------
compiz (1:0.9.8.4-0ubuntu1) quantal-proposed; urgency=low

  * debian/control:
    - Add dependency on gnome-settings-daemon for compiz-gnome, since some
      tests need the g-s-d gsetting schemas
  * New upstream release.
    - FTBFS with -DCOMPIZ_BUILD_TESTING=OFF if libgtest-dev is not installed
      (LP: #1057421)
    - [performance] glXSwapIntervalEXT called every frame, which is very slow
      on Nvidia. (LP: #1051286)
    - opacify plugin: opacity isn't reset after switching window (LP: #1050757)
    - cmake fails on python 2.6 as sys.version_info does not contain
      major_version or minor_version (LP: #1048964)
    - scale mode is not visible if a fullscreen window is unredirected
      (LP: #1047168)
    - Unredirected fullscreen windows flicker briefly when another window
      (like a menu) opens above them (LP: #1046664)
    - Week33 - Grid highlight window appears while switching between workspaces
      (LP: #1037142)
    - gtk-window-decorator leaks large numbers of pixmaps and pixmap memory
      (LP: #1057263)
    - [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
      [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen() (LP: #1054724)
    - Maximized window gets unredirected when it's not fullscreen
      (LP: #1053902)
    - Double shortcuts conflict with gnome-control-center ones (LP: #1050796)
    - gtk-window-decorator leaking window handles. Window operations become
      sluggish after a few days of usage (LP: #1050610)
    - [valgrind] Up to 520,000 bytes lost when running
      CCSGSettingsBackendConceptTest (LP: #1049169)
    - 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
      wrong values (LP: #1042041)
    - Compiz r3275 breaks VirtualBox Guest Additions: black screen or just
      wallpaper (LP: #1030891)
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - ARM build broken with 'swapInterval' is not a member of 'GL'
      (LP: #1056645)
    - compiz.fix_927168 broke ARM building (LP: #1052838)
    - compiz crashed with SIGSEGV in __strcasestr_ia32() from
      ccsStringToModifiers(binding=NULL) (LP: #1041535)
  * Cherry-picked from upstream:
    - ABI bump due to an ABI change in the composite plugin
    - Removed schema keys still used in keybindings and automated tests
      (LP: #1057955)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 27 Sep 2012 15:43:59 +0200

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → High
milestone: none → 0.9.7.10
Changed in compiz-core:
status: New → Triaged
Changed in compiz-core:
milestone: 0.9.7.10 → 0.9.7.12
Changed in compiz-core:
milestone: 0.9.7.12 → 0.9.7.14
Changed in compiz-core:
assignee: Daniel van Vugt (vanvugt) → nobody
To post a comment you must log in.