compiz crashed with SIGSEGV in __normal_iterator() from begin() from functionSetEnabled() from glPaintOutputSetEnabled() from GridScreen::handleEvent()

Bug #1054049 reported by Rustam Sharshenov on 2012-09-21
470
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
0.9.8
High
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

Compiz crashes, when nvidia-current driver is installed on my ubuntu 12.10.
I have a new model Samsung laptop(NP550) with HD4000(i7 ivy bridge) and GeForce 650M.
This bugreport is send from fresh installed Qantal daily build with only official updates.
It works fine till I installed nvidia-current

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8.2+bzr3377-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.43 Sun Aug 19 20:14:03 PDT 2012
 GCC version: gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-1ubuntu1)
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Fri Sep 21 09:26:26 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 304.43, 3.5.0-15-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c0d1]
 NVIDIA Corporation GK107 [GeForce GT 650M] [10de:0fd1] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c0d1]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120921)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 550P5C/550P7C
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=1f6faec5-bb56-41d2-86f6-4e15c801caaf ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f60a2285716 <_ZN10GridScreen11handleEventEP7_XEvent+2198>: mov 0x30(%rax),%rdx
 PC (0x7f60a2285716) ok
 source "0x30(%rax)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 GridScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libgrid.so
 CompScreen::handleEvent(_XEvent*) () from /usr/lib/libcompiz_core.so.ABI-20120920
 RegexScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libregex.so
 CompScreen::handleEvent(_XEvent*) () from /usr/lib/libcompiz_core.so.ABI-20120920
 CompScreen::handleEvent(_XEvent*) () from /usr/lib/libcompiz_core.so.ABI-20120920
Title: compiz crashed with SIGSEGV in GridScreen::handleEvent()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 gnome-session[1862]: WARNING: Child process 1941 was already dead.
 gnome-session[1862]: WARNING: Application 'compiz.desktop' killed by signal 11
 gnome-session[1862]: WARNING: App 'compiz.desktop' respawning too quickly
 gnome-session[1862]: CRITICAL: We failed, but the fail whale is dead. Sorry....
dmi.bios.date: 04/23/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P02AAA.036.120423.dg
dmi.board.asset.tag: No Asset Tag
dmi.board.name: SAMSUNG_NP1234567890
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SEC_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP02AAA.036.120423.dg:bd04/23/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn550P5C/550P7C:pvrP02AAA:rvnSAMSUNGELECTRONICSCO.,LTD.:rnSAMSUNG_NP1234567890:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 550P5C/550P7C
dmi.product.version: P02AAA
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.8.2+bzr3377-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120917.7cfd42ce-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120917.7cfd42ce-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.8-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu1

Rustam Sharshenov (teddybeer) wrote :

StacktraceTop:
 __normal_iterator (__i=@0x30: <error reading variable>, this=<optimized out>) at /usr/include/c++/4.7/bits/stl_iterator.h:728
 begin (this=0x30) at /usr/include/c++/4.7/bits/stl_vector.h:519
 functionSetEnabled (num=0, obj=0x8feda0, this=0x0, enabled=true) at /build/buildd/compiz-0.9.8.2+bzr3377/plugins/../include/core/wrapsystem.h:181
 glPaintOutputSetEnabled (enabled=true, obj=0x8feda0, this=0x0) at /build/buildd/compiz-0.9.8.2+bzr3377/plugins/grid/../opengl/include/opengl/opengl.h:770
 GridScreen::handleEvent (this=0x8fed80, event=<optimized out>) at /build/buildd/compiz-0.9.8.2+bzr3377/plugins/grid/src/grid.cpp:789

Changed in compiz (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in GridScreen::handleEvent()
+ compiz crashed with SIGSEGV in __normal_iterator()
tags: removed: need-amd64-retrace
tags: added: nvidia optimus
tags: added: compiz-0.9

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
visibility: private → public
summary: - compiz crashed with SIGSEGV in __normal_iterator()
+ compiz crashed with SIGSEGV in __normal_iterator() from begin() from
+ functionSetEnabled() from glPaintOutputSetEnabled() from
+ GridScreen::handleEvent() from
summary: compiz crashed with SIGSEGV in __normal_iterator() from begin() from
functionSetEnabled() from glPaintOutputSetEnabled() from
- GridScreen::handleEvent() from
+ GridScreen::handleEvent()
Changed in compiz:
status: New → Confirmed
milestone: none → 0.9.8.4
Rustam Sharshenov (teddybeer) wrote :

New nvidia-driver(304.51) doesn't change the situation. Still the same problem

Sam Spilsbury (smspillaz) wrote :

Hmm, glPaintOutputSetEnabled appears to be called on a null GLScreen instance.

Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Medium → High
tags: added: bugpattern-needed
Alexandrosg (alexandrosg) wrote :

This is not specifically related to nvidia-current. After an update last night I currently have a broken system with ati drivers.

See also bug #1063400

tags: added: raring
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
tags: added: saucy

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
Will Cooke (willcooke) wrote :

As part of the big bug clear up for 16.04 LTS I am marking this bug as Wont Fix.
These types of crasher are better handled by errors.ubutnu.com which can collate similar crash reports to help us identify persitent bugs rather than one-off crashes.
Sorry we are not able to help with this specific issue. If you are still experiencing this crash, please re-open the bug and add the tag "desktop-bugscrub-reopened". See https://wiki.ubuntu.com/BigDesktopBugScrub for more information.

Changed in compiz:
status: Confirmed → Won't Fix
Changed in compiz (Ubuntu):
status: Triaged → Won't Fix
tags: added: desktop-bugscrub-autoclosed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers