Screen sometimes does not redraw upon exiting fullscreen when "Unredirect Fullscreen Windows" is enabled

Bug #1053895 reported by Daniel van Vugt on 2012-09-21
48
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Christopher Townsend
0.9.9
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend
Nominated for Raring by Christopher Townsend
Raring
Undecided
Unassigned

Bug Description

[Impact]

Sometimes old fullscreen window still visible

[Test Case]

1. Enable "Unredirect Fullscreen Windows" in CCSM > Composite.
2.. Open a web page in Chrome.
3. Tap F11 repeatedly to enter and exit fullscreen.

Expected: Window changes smoothly.
Observed: Sometimes the old fullscreen window is still visible behind the restored

[Regression Potential]

None known, uses the occlusion detection.

-----------

Using the latest lp:compiz r3383 and lp:unity r2739...

1. Enable "Unredirect Fullscreen Windows" in CCSM > Composite.
2.. Open a web page in Chrome.
3. Tap F11 repeatedly to enter and exit fullscreen.

Expected: Window changes smoothly.
Observed: Sometimes the old fullscreen window is still visible behind the restored Chrome window. I have to click on the desktop to make it redraw.

Related branches

Daniel van Vugt (vanvugt) wrote :

Actually, this only seems to happen when unityshell is loaded... ?!

Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Daniel van Vugt (vanvugt) wrote :

Hmm, can't reproduce it right now.

Changed in compiz:
status: Triaged → Incomplete
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Benjamin Kraus (ben-benkraus) wrote :

I'm having this problem when minimizing a fullscreen instance of Remmina, and I found another bug report of this problem occuring when minimizing a fullscreen instance of VirtualBox (bug 1096314). The problem started when "Unredirect Fullscreen Windows" became the default (bug 1063690), and the problem goes away when "Unredirect Fullscreen Windows" is unchecked.

Either this bug or bug 1096314 should be marked as a duplicate, but as this one is marked "incomplete" so I'm not sure which should be marked as duplicate.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Ryan Novosielski (novosirj) wrote :

I'm seeing this behavior with VirtualBox on Ubuntu 12.04 LTS.

Christopher Townsend (townsend) wrote :

I have found the root cause of this issue related to unredirect. The opengl compize plugin does not take into account minimized fullscreen apps when unredirected. The fix is pretty simple in that it should check if the window is minimized before making it redirected.

This fixes this issue, but you will still see the behavior in bug #1064155 (missing Launcher and Panel). I will propose a branch to fix this and work on getting it SRU'd and then tackle the missing Launcher and Panel issue.

Changed in compiz:
status: Incomplete → Confirmed
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.10.0

Changed in compiz:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.9 at revision None, scheduled for release in compiz, milestone 0.9.9.2

description: updated
description: updated
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Raring):
status: New → Confirmed

Hello Daniel, or anyone else affected,

Accepted compiz into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.9~daily13.05.31~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Daniel, or anyone else affected,

Accepted compiz into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.9~daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

1:0.9.9~daily13.06.19~13.04-0ubuntu1 (raring-proposed) fixes the issue with minimizing a fullscreen instance of VirtualBox for me. Great, thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.06.19~13.04-0ubuntu1

---------------
compiz (1:0.9.9~daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ Chris Townsend ]
  * Fixed issue where minimizing an unredirect full screen window would
    repaint the full screen window after minimizing it even though it
    isn't really there. This is a backport of lp:compiz revno. 3686.
    (LP: #1053895)

  [ Marco Trevisan (Treviño) ]
  * OpenGL Screen: Ignore the MSAA configs during initialization This
    fixes a crash with new MESA drivers and high monitor resolutions
    caused by the fact that we're accidentally using some MSAA configs
    with some drivers in Mesa 9.0. Taking in account the values of
    GLX_SAMPLES and GLX_SAMPLE_BUFFERS fixes the issue. See mesa bug
    https://bugs.freedesktop.org/show_bug.cgi?id=61182. (LP: #1174495)

  [ Hu Kang ]
  * Use XIDefineCursor rather than XDefineCursor. compiz should show a
    busy cursor during the application startup stage. the corresponding
    code is in scr/screen.cpp:
    cps::StartupSequenceImpl::updateStateFeedback () the patch changes
    all XDefineCursor to XIDefineCursor (see XInput2 extension) (LP:
    #1179155). (LP: #1179155)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3657 (bootstrap)
  * Automatic snapshot from revision 3658

compiz (1:0.9.9~daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  * Automatic snapshot from revision 3652

compiz (1:0.9.9~daily13.05.01.1ubuntu.unity.next-0ubuntu1) raring; urgency=low

  * Automatic snapshot from revision 3651 (ubuntu-unity/next)
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:02:36 +0000

Changed in compiz (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Stephen M. Webb (bregma) on 2013-07-23
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (70.8 KiB)

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130822-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130822-0ubuntu1) saucy; urgency=low

  [ Sam Spilsbury ]
  * Bump version to 0.9.10

  [ Łukasz 'sil2100' Zemczak ]
  * Remove debian/patches/unity_support_test.patch:
    - Running the support test from compiz has bad side effects, from now
      on we run it from Xsession.d
  * Automatic snapshot from revision 3644

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ Mehrdad Afshari ]
  * Added "move window to previous monitor" feature to compiz Put
    plugin. (LP: #1178581)

  [ Hu Kang ]
  * gtk-window-decorator: destroy action menu when any of the (close,
    min, max) buttons on the title bar is pressed. (LP: #1101648)
  * Remove redundant src/logmessage/include/core/logmessage.h (LP:
    #1067246). (LP: #1067246)

  [ Steve Langasek ]
  * Fix for bug #763148 (with added test cases): when the desktop is
    resized, windows should stay on their original workspace. (LP:
    #763148)

  [ Brandon Schaefer ]
  * Unrevert 3728, fix failing tests. Change the behaviour of
    undecorating windows. Previously when a window was undecorated, we
    would shift it back to an appropriate position according to its
    gravity member. That behaviour was problematic because in the
    StaticGravity case the window has to just stay in the same place.
    But then if you had a window with StaticGravity which then did get a
    decoration and later removed it, it would be placed as though it was
    decorated and appear to be in the wrong place. The correct behaviour
    is to place all windows as though they have decorations, and then
    when decorations are removed, to move the window back to the corner
    as indicated in its gravity and then expand its size to cover the
    obscured regions no longer hidden because the decorations went away.
    (LP: #1165343).   1. Completely remove decorOffsetMove and other
    related code from      decor.cpp. Put the logic to handle the
    window->input () - window->border ()      placement offset inside of
    setWindowFrameExtents instead. Now the window      will always be
    offset from its original non-decorated position to the new
         decorated position, rather than having to guess between
    decoration sizes.   2. Make saveGeometry and restoreGeometry work
    relative to window->border ()      a...

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Closing Compiz 0.9.9 task (0.9.9 series is obsolete)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.