Double shortcuts conflict with gnome-control-center ones

Bug #1050796 reported by Timo Jyrinki on 2012-09-14
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
compiz (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

As of 0.9.8.2, there are still two conflicting shortcut keys for "Launch terminal" shortcut (see bug #1040081) and the screenshot related shortcuts. The conflicts come from gnome-control-center-data's 01-screenshot.xml and 01-launchers, which have similar entries as 50-compiz-launchers.xml and 50-compiz-screenshot.xml.

(it seems, though, that the keys for both duplicates work now)

The suggestion would seem to be using the system ones instead of org.compiz.integrated ones.

Related branches

summary: - Double "Launch terminal" shortcut, the org.compiz.integrated one isn't
- listened
+ Double shortcuts, the org.compiz.integrated one isn't listened
description: updated
summary: - Double shortcuts, the org.compiz.integrated one isn't listened
+ Double shortcuts conflict with gnome-control-center ones
description: updated
Changed in compiz:
importance: Undecided → Medium
milestone: none → 0.9.8.4
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Putting as high because the conflict make the keybind not working 100% of the time.

Changed in compiz (Ubuntu Quantal):
importance: Undecided → High
Changed in compiz:
importance: Medium → High
status: New → Triaged
Changed in compiz (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
tags: added: gsettings
Changed in compiz:
status: Triaged → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3393

Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.4-0ubuntu1

---------------
compiz (1:0.9.8.4-0ubuntu1) quantal-proposed; urgency=low

  * debian/control:
    - Add dependency on gnome-settings-daemon for compiz-gnome, since some
      tests need the g-s-d gsetting schemas
  * New upstream release.
    - FTBFS with -DCOMPIZ_BUILD_TESTING=OFF if libgtest-dev is not installed
      (LP: #1057421)
    - [performance] glXSwapIntervalEXT called every frame, which is very slow
      on Nvidia. (LP: #1051286)
    - opacify plugin: opacity isn't reset after switching window (LP: #1050757)
    - cmake fails on python 2.6 as sys.version_info does not contain
      major_version or minor_version (LP: #1048964)
    - scale mode is not visible if a fullscreen window is unredirected
      (LP: #1047168)
    - Unredirected fullscreen windows flicker briefly when another window
      (like a menu) opens above them (LP: #1046664)
    - Week33 - Grid highlight window appears while switching between workspaces
      (LP: #1037142)
    - gtk-window-decorator leaks large numbers of pixmaps and pixmap memory
      (LP: #1057263)
    - [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
      [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen() (LP: #1054724)
    - Maximized window gets unredirected when it's not fullscreen
      (LP: #1053902)
    - Double shortcuts conflict with gnome-control-center ones (LP: #1050796)
    - gtk-window-decorator leaking window handles. Window operations become
      sluggish after a few days of usage (LP: #1050610)
    - [valgrind] Up to 520,000 bytes lost when running
      CCSGSettingsBackendConceptTest (LP: #1049169)
    - 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
      wrong values (LP: #1042041)
    - Compiz r3275 breaks VirtualBox Guest Additions: black screen or just
      wallpaper (LP: #1030891)
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - ARM build broken with 'swapInterval' is not a member of 'GL'
      (LP: #1056645)
    - compiz.fix_927168 broke ARM building (LP: #1052838)
    - compiz crashed with SIGSEGV in __strcasestr_ia32() from
      ccsStringToModifiers(binding=NULL) (LP: #1041535)
  * Cherry-picked from upstream:
    - ABI bump due to an ABI change in the composite plugin
    - Removed schema keys still used in keybindings and automated tests
      (LP: #1057955)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 27 Sep 2012 15:43:59 +0200

Changed in compiz (Ubuntu Quantal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers