Ubuntu

[FFE][UIFE][regression] workspace switcher layout needs adjustments

Reported by Omer Akram on 2012-09-06
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Workspace switcher layout should centralized as it was in 12.04. currently it looks like as attached in the screenshot.

== CHANGE ==

A distro patch from 12.04 didn't get ported over. It was ported to use the new compiz API when linaro released their version of compiz for 12.04, so I've taken this patch as it was and applied it. A few changes were made to get the code under test.

== TEST ==

Unit tests are included, they don't cover a very large amount of the code (many changes in the diff are as a result of refactoring some larger functions into smaller ones, and these changes are not trivially testable).

The tests that are there they do cover functionality which is substantially new, such as the code to calculate the spread view offset in world co-ordinate space (60 tests) and the code to determine which viewports should be lit (5 tests).

== WHY ==

If we don't have this patch, we'll regress significantly from 12.04 in a way that is easily avoidable.

== REGRESSIONS? ==

Not anything substantial from 12.04, the only potential is regressions that might stem from the subsequent changes to get the code under test (however I found that doing this caught a lot more potential bugs).

Related branches

lp:~timo-jyrinki/ubuntu/quantal/compiz/fix_expo
Merged into lp:ubuntu/quantal/compiz at revision 3297
Timo Jyrinki (community): Needs Information on 2012-09-13
Ubuntu branches: Pending requested 2012-09-13
Omer Akram (om26er) wrote :
affects: compiz → compiz (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Yeah, quantal is using the upstream expo plugin now. Seems to have lost all of the custom patches that precise had for expo (although it's likely those won't work in quantal at all).

Changed in compiz (Ubuntu):
status: New → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
summary: - [regression] workspace switcher layout needs adjustments
+ [FFE][UIFE][regression] workspace switcher layout needs adjustments
Omer Akram (om26er) on 2012-09-07
Changed in compiz (Ubuntu):
importance: Undecided → Medium
description: updated
Jeremy Bicha (jbicha) wrote :

Great. Thanks. +1 from the Docs Team since it gets the workspace switcher back to the 12.04 state.

Iain Lane (laney) wrote :

approved to get landed before B2 freeze (Thursday 20th)

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
tags: added: ffe uife
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers