compiz crashed with SIGABRT in assert from boost::shared_ptr<CompRect>::operator-> from ResizeLogic::enableOrDisableVerticalMaximization() from ResizeLogic::handleMotionEvent()

Bug #1045191 reported by Jean-Baptiste Lallement on 2012-09-03
122
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel d'Andrada
compiz (Ubuntu)
Critical
Daniel d'Andrada
Quantal
Critical
Daniel d'Andrada

Bug Description

Compiz crash when a window is resized with the middle mouse button.

TEST CASE:
1. Open a terminal
2. Resize the window with ALT+Middle Button

ACTUAL RESULT
This crash

EXPECTED RESULT
Window is resized and compiz doesn't crash.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity 6.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Mon Sep 3 08:51:09 2012
ExecutablePath: /usr/bin/compiz
ExecutableTimestamp: 1346448992
ProcCmdline: compiz
ProcCwd: /home/j-lallement
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/compiz/libresize.so
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to quantal on 2012-01-31 (215 days ago)
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare sbuild vboxusers

Related branches

Jean-Baptiste Lallement (jibel) wrote :

StacktraceTop:
 __assert_fail_base (fmt=<optimized out>, assertion=0x7f1c84565e58 "px != 0", file=0x7f1c84565e28 "/usr/include/boost/smart_ptr/shared_ptr.hpp", line=<optimized out>, function=<optimized out>) at assert.c:94
 __GI___assert_fail (assertion=0x7f1c84565e58 "px != 0", file=0x7f1c84565e28 "/usr/include/boost/smart_ptr/shared_ptr.hpp", line=424, function=0x7f1c8456a0e0 "T* boost::shared_ptr<T>::operator->() const [with T = CompRect]") at assert.c:103
 boost::shared_ptr<CompRect>::operator-> (this=<optimized out>) at /usr/include/boost/smart_ptr/shared_ptr.hpp:424
 ResizeLogic::enableOrDisableVerticalMaximization (this=this@entry=0x26d2f58, yRoot=yRoot@entry=340) at /build/buildd/compiz-0.9.8.0/plugins/resize/src/logic/src/resize-logic.cpp:1112
 ResizeLogic::handleMotionEvent (this=this@entry=0x26d2f58, xRoot=515, yRoot=340) at /build/buildd/compiz-0.9.8.0/plugins/resize/src/logic/src/resize-logic.cpp:498

Changed in unity (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGABRT in raise()
+ compiz crashed with SIGABRT in __assert_fail_base()
tags: removed: need-amd64-retrace
visibility: private → public
summary: - compiz crashed with SIGABRT in __assert_fail_base()
+ compiz crashed with SIGABRT in assert from
+ boost::shared_ptr<CompRect>::operator-> from
+ ResizeLogic::enableOrDisableVerticalMaximization() from
+ ResizeLogic::handleMotionEvent()
affects: unity (Ubuntu) → compiz (Ubuntu)
affects: compiz-core → compiz
Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Medium → High
Changed in compiz:
milestone: none → 0.9.8.2
assignee: nobody → Daniel d'Andrada (dandrader)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: New → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3334

tags: added: rls-q-incoming
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) on 2012-09-12
Changed in compiz (Ubuntu Quantal):
importance: High → Critical
status: Triaged → In Progress
Omer Akram (om26er) on 2012-09-12
tags: added: pspriority
Omer Akram (om26er) on 2012-09-12
Changed in compiz (Ubuntu Quantal):
assignee: nobody → Daniel d'Andrada (dandrader)
status: In Progress → Fix Committed
milestone: none → ubuntu-12.10-beta-2
tags: removed: rls-q-incoming
Andrei Dziahel (develop7) wrote :

Quite a time passed but fixed compiz package seems not hit repositories yet. Any chances to have him delivered? An issue is quite annoying.
Thanks in advance.

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers