Minimize animation only works for one window at a time

Bug #1045126 reported by Marco Biscaro on 2012-09-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Steps to reproduce:
1. Open two windows and place them in the same point on the screen
2. Move the mouse to the minimize button
3. Click the minimize button twice

What should happens?
The two windows should minimize with the nice effect.

What happens instead?
The first windows (on top) minimizes with the effect, but the second one simply disappear.

This bug is easily noticeable if you set the dconf keys com.canonical.unity.minimize-count to zero and com.canonical.unity.minimize-slow-duration to something high (like 2000).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.2.0-0ubuntu4 [modified: usr/lib/compiz/libunitymtgrabhandles.so usr/lib/compiz/libunityshell.so usr/share/compiz/unitymtgrabhandles/images/handle-0.png usr/share/compiz/unitymtgrabhandles/images/handle-1.png usr/share/compiz/unitymtgrabhandles/images/handle-2.png usr/share/compiz/unitymtgrabhandles/images/handle-3.png usr/share/compiz/unitymtgrabhandles/images/handle-4.png usr/share/compiz/unitymtgrabhandles/images/handle-5.png usr/share/compiz/unitymtgrabhandles/images/handle-6.png usr/share/compiz/unitymtgrabhandles/images/handle-7.png usr/share/compiz/unitymtgrabhandles/images/handle-8.png usr/share/compiz/unityshell.xml]
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Sun Sep 2 20:19:26 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device [1297:2013]
MachineType: OEM B14HM21
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=c88768b5-067c-4efd-ac87-b1cf07603dcb ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/01/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.02.002.E3 Test Only
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: B14HM21
dmi.board.vendor: OEM
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: OEM
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.02.002.E3TestOnly:bd03/01/2011:svnOEM:pnB14HM21:pvrTobefilledbyO.E.M.:rvnOEM:rnB14HM21:rvrTobefilledbyO.E.M.:cvnOEM:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: B14HM21
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: OEM
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Daniel van Vugt (vanvugt) wrote :

I can't reproduce this with standard Ubuntu packages. Please make sure you are using official ubuntu package versions before logging behavioural bugs:

Package: unity 6.2.0-0ubuntu4 [modified: usr/lib/compiz/libunitymtgrabhandles.so usr/lib/compiz/libunityshell.so usr/share/compiz/unitymtgrabhandles/images/handle-0.png usr/share/compiz/unitymtgrabhandles/images/handle-1.png usr/share/compiz/unitymtgrabhandles/images/handle-2.png usr/share/compiz/unitymtgrabhandles/images/handle-3.png usr/share/compiz/unitymtgrabhandles/images/handle-4.png usr/share/compiz/unitymtgrabhandles/images/handle-5.png usr/share/compiz/unitymtgrabhandles/images/handle-6.png usr/share/compiz/unitymtgrabhandles/images/handle-7.png usr/share/compiz/unitymtgrabhandles/images/handle-8.png usr/share/compiz/unityshell.xml]

affects: unity → compiz
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete

I'm using the latest unity trunk. Shouldn't I report this kind of bug?

2012/9/3 Daniel van Vugt <email address hidden>:
> I can't reproduce this with standard Ubuntu packages. Please make sure
> you are using official ubuntu package versions before logging
> behavioural bugs:

Yes, please do log bugs.

OK, let's return to New. But I can't confirm this bug because I cannot reproduce it.

Changed in compiz:
status: Incomplete → New
Changed in compiz (Ubuntu):
status: Incomplete → Invalid
Marco Scannadinari (zheoffec) wrote :

BTW You can set minimize-speed-threshold to something like two, and on the second minimize, the window will go amazingly fast because it has reached the treshold, because the minimize count will have hit two (the threshold). Shouldnt the minimize speed be static?

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Changed in compiz:
status: New → Confirmed
importance: Undecided → Low
Changed in compiz (Ubuntu):
importance: Undecided → Low
Changed in compiz:
milestone: none → 0.9.9.0
summary: - minimize effect broken
+ Minimize animation only works for one window at a time
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
MC Return (mc-return) wrote :

Confirmed in 0.9.10-dev.

Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers