1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to wrong values

Bug #1042041 reported by Martin Pitt on 2012-08-27
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
compiz (Ubuntu)
High
Unassigned

Bug Description

I have configured compiz to do sloppy focus-follows-mouse without autoraise. Until Friday this was working fine, but after the weekend's dist-upgrades, which included compiz 1:0.9.8+bzr3319-0ubuntu2 (from 1:0.9.8+bzr3249-0ubuntu4), windows now auto-raise when the mouse pointer is in them.

This does not seem to be an issue in the gsettings migration, as the settings look fine:

$ gsettings list-recursively|egrep 'raise|focus'
org.gnome.desktop.wm.preferences auto-raise false
org.gnome.desktop.wm.preferences auto-raise-delay 1000
org.gnome.desktop.wm.preferences focus-mode 'sloppy'
org.gnome.desktop.wm.preferences focus-new-windows 'smart'
org.gnome.desktop.wm.preferences raise-on-click true
org.gnome.desktop.wm.keybindings raise ['disabled']
org.gnome.desktop.wm.keybindings raise-or-lower @as []

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:0.9.8+bzr3319-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Aug 27 06:36:54 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215a]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
MachineType: LENOVO 3323REG
PackageArchitecture: all
PlymouthDebug: Error: [Errno 13] Keine Berechtigung: '/var/log/plymouth-debug.log'
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-11-generic root=UUID=8f327c01-56d7-401c-8bd1-5442854e3c85 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/07/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET46WW (1.16 )
dmi.board.name: 3323REG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET46WW(1.16):bd06/07/2010:svnLENOVO:pn3323REG:pvrThinkPadX201:rvnLENOVO:rn3323REG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3323REG
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.8+bzr3319-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Related branches

Martin Pitt (pitti) wrote :
tags: added: regression-release
Martin Pitt (pitti) wrote :

After restarting compiz/unity again, it works now. Lots of other things are broken (Ctrl+Alt+T, Windows+Up/Down, etc.), but at least this unnerving thing seems to have been an one-time issue.

Changed in compiz (Ubuntu):
status: New → Invalid
Martin Pitt (pitti) wrote :

It's back. It seems compiz randomly applies this or not on startup, depending on the moon phase or other unobvious circumstances.

Changed in compiz (Ubuntu):
status: Invalid → New
tags: added: compiz-0.9
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: gsettings
removed: compiz-0.9
tags: added: compiz-0.9 verification-done
Martin Pitt (pitti) on 2012-08-29
summary: - 1:0.9.8+bzr3319-0ubuntu1 regression: wrong auto-raise, cannot be
- disabled
+ 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
+ wrong values
Martin Pitt (pitti) wrote :

After this morning's login, it's back. It set

  org.gnome.desktop.wm.preferences auto-raise true

to true again, although I never set that. Yesterday I "reset" the key, so that it was definitively not in my ~/.config/dconf/.

It also set the maximize/unmaximize keys back from my custom Super+Up/Down to the default:

org.gnome.desktop.wm.keybindings maximize ['<Control><Primary><Super>Up']
org.gnome.desktop.wm.keybindings unmaximize ['<Control><Primary><Super>Down']

I checked in dconf-editor, the keys are set in ~/.config/dconf, they did not get reset to the default.

Finally it keeps deleting my keybinding for

  org.gnome.desktop.wm.keybindings lower ['disabled']

when I set it back to Alt+B (for the umpteenth time) in control, center, this is how it should be:

  org.gnome.desktop.wm.keybindings lower ['<Alt>b']

Please note that the schema default is [], not ['disabled'], so once again it invents this "disabled" value or gets it from another migration source.

Where are these values copied or generated from at startup? I might have some other settings somewhere which did not affect compiz versions prior to 1:0.9.8+bzr3319-0ubuntu1, but now keep messing up my settings.

affects: compiz-core → compiz
Changed in compiz:
milestone: none → 0.9.8.2
Martin Pitt (pitti) wrote :

For the record, now I have the original problem again, I was not halucinating:

$ gsettings get org.gnome.desktop.wm.preferences auto-raise
false

but still compiz is auto-raising windows again. I don't know how to stop it from doing that..

Changed in compiz:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
Steve McInerney (spm) wrote :

Unsure if what I'm seeing is the same as pitti or not; but sounds similar.
manually unset "click to focus" via compizsettings/general/focus
click the back button
go forward to the focus page; and 'click to focus' is checked again.

Can't seem to convince things that I really want focus-follows-mouse.

quantal beta.

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.4-0ubuntu1

---------------
compiz (1:0.9.8.4-0ubuntu1) quantal-proposed; urgency=low

  * debian/control:
    - Add dependency on gnome-settings-daemon for compiz-gnome, since some
      tests need the g-s-d gsetting schemas
  * New upstream release.
    - FTBFS with -DCOMPIZ_BUILD_TESTING=OFF if libgtest-dev is not installed
      (LP: #1057421)
    - [performance] glXSwapIntervalEXT called every frame, which is very slow
      on Nvidia. (LP: #1051286)
    - opacify plugin: opacity isn't reset after switching window (LP: #1050757)
    - cmake fails on python 2.6 as sys.version_info does not contain
      major_version or minor_version (LP: #1048964)
    - scale mode is not visible if a fullscreen window is unredirected
      (LP: #1047168)
    - Unredirected fullscreen windows flicker briefly when another window
      (like a menu) opens above them (LP: #1046664)
    - Week33 - Grid highlight window appears while switching between workspaces
      (LP: #1037142)
    - gtk-window-decorator leaks large numbers of pixmaps and pixmap memory
      (LP: #1057263)
    - [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
      [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen() (LP: #1054724)
    - Maximized window gets unredirected when it's not fullscreen
      (LP: #1053902)
    - Double shortcuts conflict with gnome-control-center ones (LP: #1050796)
    - gtk-window-decorator leaking window handles. Window operations become
      sluggish after a few days of usage (LP: #1050610)
    - [valgrind] Up to 520,000 bytes lost when running
      CCSGSettingsBackendConceptTest (LP: #1049169)
    - 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
      wrong values (LP: #1042041)
    - Compiz r3275 breaks VirtualBox Guest Additions: black screen or just
      wallpaper (LP: #1030891)
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - ARM build broken with 'swapInterval' is not a member of 'GL'
      (LP: #1056645)
    - compiz.fix_927168 broke ARM building (LP: #1052838)
    - compiz crashed with SIGSEGV in __strcasestr_ia32() from
      ccsStringToModifiers(binding=NULL) (LP: #1041535)
  * Cherry-picked from upstream:
    - ABI bump due to an ABI change in the composite plugin
    - Removed schema keys still used in keybindings and automated tests
      (LP: #1057955)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 27 Sep 2012 15:43:59 +0200

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

This is still an issue, reported as bug 1063617.

everflux (tklaunchpad) wrote :

I have the same problem, this bug is not fixed.

Daniel van Vugt (vanvugt) wrote :

This bug is Fix Released. Please post new comments in the new bug; bug 1063617.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers