gsettings-data-convert issues on invalid compiz .convert

Bug #1041631 reported by Dominic Jänichen on 2012-08-25
112
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
Undecided
Sebastien Bacher
compiz (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
unity (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

dist-upgraded from precise to quantal today. After rebooting, this came up.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gconf2 3.2.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-30.47-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Sat Aug 25 21:46:27 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gsettings-data-convert
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-Default.convert
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gconf
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_settings_set_value () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_settings_set () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? ()
Title: gsettings-data-convert crashed with signal 5 in g_settings_set_value()
UpgradeStatus: Upgraded to quantal on 2012-08-25 (0 days ago)
UserGroups: adm audio cdrom davfs2 dialout dip fuse lpadmin netdev plugdev powerdev sambashare scanner sudo video

Related branches

Dominic Jänichen (jaenichd) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #945144, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace

Not sure whether it indeed is a duplicate of bug #945144, so removing the link for now.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you run "gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-Default.convert" and copy the log there?

Changed in gconf (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

could you run "gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-unity.convert" as well?

Changed in gconf (Ubuntu):
importance: Low → High
Sebastien Bacher (seb128) wrote :

one of the duplicates has

" g_settings_schema_get_value (schema=schema@entry=0x1e92440, key=key@entry=0x1e98d20 "alt-tab-bias_viewport") at /build/buildd/glib2.0-2.33.10/./gio/gsettingsschema.c:640
 g_settings_schema_key_init (key=key@entry=0x7fff092aeef0, schema=0x1e92440, name=name@entry=0x1e98d20 "alt-tab-bias_viewport") at /build/buildd/glib2.0-2.33.10/./gio/gsettingsschema.c:751
 g_settings_set_value (settings=settings@entry=0x1e845e0, key=key@entry=0x1e98d20 "alt-tab-bias_viewport", value=0x1e998a0) at /build/buildd/glib2.0-2.33.10/./gio/gsettings.c:1350"

not sure if all bugs there have the same issue, for those who reported a duplicate having the output of those command and it they raise an error would be useful;

gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-Default.convert
gsettings-data-convert --file=/usr/lib/compiz/migration/compiz-profile-active-unity.convert

Sebastien Bacher (seb128) wrote :

Confirmed, the .convert from compiz list alt-tab-bias_viewport but the key is names -viewport

affects: gconf (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Incomplete → Triaged
Sebastien Bacher (seb128) wrote :

looking to the .convert those keys are also - vs _ buggy
top-edge_action
top-edge_threshold
toggle-window_maximized-button

Sebastien Bacher (seb128) wrote :

ok, to complete the list:

alt-tab-detail_start
close_window_button
panel-first_menu

summary: - gsettings-data-convert crashed with signal 5 in g_settings_set_value()
+ gsettings-data-convert issues on invalid compiz .convert
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu3

---------------
compiz (1:0.9.8+bzr3319-0ubuntu3) quantal; urgency=low

  * debian/control.in:
    - Recommends python-gconf for the migration script (lp: #1041498)
  * postinst/convert-files/compiz-profile-active-Default.convert,
    postinst/convert-files/compiz-profile-Default.convert:
    - updated to fix some key names typos in the list (lp: #1041631)
 -- Sebastien Bacher <email address hidden> Tue, 28 Aug 2012 19:50:29 +0200

Changed in compiz (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in unity (Ubuntu Quantal):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.2.0-0ubuntu4

---------------
unity (6.2.0-0ubuntu4) quantal; urgency=low

  * debian/control:
    - Depends on compiz-plugins-default rather than on a transitional one
  * tools/convert-files/compiz-profile-(active)-unity.convert:
    - updated to fix some key names typos in the list (lp: #1041631)
 -- Sebastien Bacher <email address hidden> Tue, 28 Aug 2012 22:05:26 +0200

Changed in unity (Ubuntu Quantal):
status: New → Fix Released
Changed in compiz:
status: New → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3326

Changed in unity:
status: New → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Update: Unity 6.4 is revision 2632, so this is actually fix committed for Unity 6.6.

Changed in unity:
milestone: none → 6.6
Changed in unity:
milestone: 6.6 → 7.0
assignee: nobody → Sebastien Bacher (seb128)
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers