compiz crashed with SIGSEGV in __strcasestr_ia32() from ccsStringToModifiers(binding=NULL)

Bug #1041535 reported by Hans Joachim Desserud on 2012-08-25
142
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Sam Spilsbury
compiz (Ubuntu)
Critical
Unassigned
Quantal
Critical
Unassigned

Bug Description

Compiz crash from time to time in Quantal.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8+bzr3319-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic i686
.tmp.unity.support.test.1:

ApportVersion: 2.4-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Sat Aug 25 13:36:47 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-10-generic root=UUID=fcf184df-c524-4a5c-b045-04a0c1b568fc ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0xb740a4ea: movzbl (%eax),%edx
 PC (0xb740a4ea) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ccsStringToModifiers () from /usr/lib/libcompizconfig.so.0
 ?? () from /usr/lib/compizconfig/backends/libgconf.so
 ccsIntegrationReadOptionIntoSetting () from /usr/lib/libcompizconfig.so.0
 ?? () from /usr/lib/compizconfig/backends/libgconf.so
Title: compiz crashed with SIGSEGV in ccsStringToModifiers()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.8+bzr3319-0ubuntu2
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Related branches

Hans Joachim Desserud (hjd) wrote :

StacktraceTop:
 __strcasestr_ia32 (haystack_start=0x0, needle_start=0xb65ef101 "<Shift>") at ../string/strcasestr.c:76
 ccsStringToModifiers (binding=0x0) at /build/buildd/compiz-0.9.8+bzr3319/compizconfig/libcompizconfig/src/bindings.c:241
 ?? ()
 ?? ()

Changed in compiz (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in ccsStringToModifiers()
+ compiz crashed with SIGSEGV in __strcasestr_ia32()
tags: removed: need-i386-retrace
visibility: private → public
summary: - compiz crashed with SIGSEGV in __strcasestr_ia32()
+ compiz crashed with SIGSEGV in __strcasestr_ia32() from
+ ccsStringToModifiers()
Changed in compiz:
milestone: none → 0.9.8.1
summary: compiz crashed with SIGSEGV in __strcasestr_ia32() from
- ccsStringToModifiers()
+ ccsStringToModifiers(binding=NULL)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
Changed in compiz:
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Medium → High
tags: added: gsettings
Ursula Junque (ursinha) wrote :

This happened to me today after dist-upgrading from precise to quantal. Once the machine returned from reboot, I logged in and hit this bug. I actually didn't run any commands for this to happen.

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
status: Confirmed → In Progress
Changed in compiz (Ubuntu Quantal):
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-09-24
Changed in compiz:
importance: High → Critical
Changed in compiz (Ubuntu Quantal):
importance: High → Critical
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3389

Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.4-0ubuntu1

---------------
compiz (1:0.9.8.4-0ubuntu1) quantal-proposed; urgency=low

  * debian/control:
    - Add dependency on gnome-settings-daemon for compiz-gnome, since some
      tests need the g-s-d gsetting schemas
  * New upstream release.
    - FTBFS with -DCOMPIZ_BUILD_TESTING=OFF if libgtest-dev is not installed
      (LP: #1057421)
    - [performance] glXSwapIntervalEXT called every frame, which is very slow
      on Nvidia. (LP: #1051286)
    - opacify plugin: opacity isn't reset after switching window (LP: #1050757)
    - cmake fails on python 2.6 as sys.version_info does not contain
      major_version or minor_version (LP: #1048964)
    - scale mode is not visible if a fullscreen window is unredirected
      (LP: #1047168)
    - Unredirected fullscreen windows flicker briefly when another window
      (like a menu) opens above them (LP: #1046664)
    - Week33 - Grid highlight window appears while switching between workspaces
      (LP: #1037142)
    - gtk-window-decorator leaks large numbers of pixmaps and pixmap memory
      (LP: #1057263)
    - [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
      [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen() (LP: #1054724)
    - Maximized window gets unredirected when it's not fullscreen
      (LP: #1053902)
    - Double shortcuts conflict with gnome-control-center ones (LP: #1050796)
    - gtk-window-decorator leaking window handles. Window operations become
      sluggish after a few days of usage (LP: #1050610)
    - [valgrind] Up to 520,000 bytes lost when running
      CCSGSettingsBackendConceptTest (LP: #1049169)
    - 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
      wrong values (LP: #1042041)
    - Compiz r3275 breaks VirtualBox Guest Additions: black screen or just
      wallpaper (LP: #1030891)
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - ARM build broken with 'swapInterval' is not a member of 'GL'
      (LP: #1056645)
    - compiz.fix_927168 broke ARM building (LP: #1052838)
    - compiz crashed with SIGSEGV in __strcasestr_ia32() from
      ccsStringToModifiers(binding=NULL) (LP: #1041535)
  * Cherry-picked from upstream:
    - ABI bump due to an ABI change in the composite plugin
    - Removed schema keys still used in keybindings and automated tests
      (LP: #1057955)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 27 Sep 2012 15:43:59 +0200

Changed in compiz (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.