Tearing at top of laptop screen

Bug #1037710 reported by Ben Frania on 2012-08-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Compiz Linaro Team
compiz (Ubuntu)
Medium
Unassigned

Bug Description

This tearing occurs only at the very top of my laptop's panel within about a two centimeter margin. It is usually produced in the title bar of a fully extended window moved side to side. Also occurs in this spot with Youtube videos when positioned between the first and third workspace. Had the same problem with a lower resolution panel that I recently replaced with my current one. Also see it running Mint and Arch with Compiz Fusion or Cairo Compmgr.

The laptop is a Clevo W251ESQ. System76 currently sells two nearly indentical laptops from the series, they likely have the same screens as mine. The panels I have used are the LG LP156WH4(TL)(A1) and LP156WF1(TL)(B2). Rendering with an i3-2350M as the Nvidia card must be run via Bumblebee. My Ubuntu version is 12.04 fully upgraded as of August 16th.

Same issue posted but unsolved in February: http://ubuntuforums.org/showthread.php?t=1921773

Related branches

description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1037710/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → compiz (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

This will be fixed by the fix for bug 901097, which is the gles2 branch.

But until then, there is a simple workaround. In CCSM, Workarounds, enable "Force full screen redraw (buffer swap) on repaint".

Changed in compiz:
status: New → In Progress
assignee: nobody → Compiz Linaro Team (compiz-linaro-team)
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz:
milestone: none → 0.9.8.0
Omer Akram (om26er) on 2012-08-17
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3320

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.0-0ubuntu1

---------------
compiz (1:0.9.8.0-0ubuntu1) quantal-proposed; urgency=low

  * debian/control, debian/rules:
    - enable gles on armel and armhf
    - use dh-translations rather than custom code

  [ Sam Spilsbury ]
  * Enable OpenGL ES building
    - Refresh debian/patches/workaround_broken_drivers.patch
    - Remove non-ported plugins from compiz-plugins
    - Add FindOpenGLES2.cmake to compiz-dev

  [ Timo Jyrinki ]
  * New upstream release.
    - Code to make compiz work on GLES. This includes several changes
      to the compiz API. (LP: #201342) (LP: #901097) (LP: #1004251)
      (LP: #1037710)
    - Draft first 0.9.8.0 NEWS and bump VERSION
  * debian/patches/compiz-package-gles2.patch:
    - Remove, obsoleted by the upstream GLES work
  * Disable plugins that don't work on pure GLES on armhf/armel:
    - bench, firepaint, mblur, showmouse, splash, showrepaint, td, widget
 -- Sebastien Bacher <email address hidden> Fri, 31 Aug 2012 22:59:50 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers