Week33 - Grid highlight window appears while switching between workspaces

Bug #1037142 reported by Nice Testhouse on 2012-08-15
114
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

Week 33 - Ubuntu 12.10 Quantal with ppa:timo-jyrinki/prerelease with graphic card (Intel, Radeon, Nvidia)

Issue:
Empty translucent window appears on left half of the screen while switching between workspaces, mostly on workspace 1. Please see screenshot.
It might be difficult to reproduce this, when I tried reproducing it, same issue did not occur everytime the below steps were actioned. But I was able to reproduce it more than once on 3 different machines with same quantal and ppa.
Clicking on workspace switcher icon on launcher makes the translucent window go away, clicking elsewhere on the desktop does not affect the translucent window and it stays.

Action:-
- Open 3 terminal windows
- Click workspace switcher icon to activate workspace view
- Move 1 terminal window to another workspace
- Click back on one of the terminal windows in workspace 1
- Continue to move between workspaces

Please note :-
Simple switching between workspaces with or without an open application also produces this issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.2.0-0ubuntu2~test2
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.4-0ubuntu6
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Aug 15 15:40:54 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Limited. Device [10cf:1507]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120713.1)
MachineType: FUJITSU LIFEBOOK E780
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-10-generic root=UUID=2ad466df-f86d-4d80-9b6c-e14f0b5f0a71 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/24/2011
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.20
dmi.board.name: FJNB210
dmi.board.vendor: FUJITSU
dmi.board.version: CP477721-02
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU
dmi.chassis.version: E78__
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.20:bd01/24/2011:svnFUJITSU:pnLIFEBOOKE780:pvr:rvnFUJITSU:rnFJNB210:rvrCP477721-02:cvnFUJITSU:ct10:cvrE78__:
dmi.product.name: LIFEBOOK E780
dmi.sys.vendor: FUJITSU
version.compiz: compiz 1:0.9.8+bzr3307-0ubuntu1~test1
version.libdrm2: libdrm2 2.4.38-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.1.902-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~really6.14.4-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-1build1

Related branches

Nice Testhouse (testhouse) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Edward Donovan (edward.donovan) wrote :

I've experienced this -- excuse me, as I don't know the window management vocabulary, here. The window that appears is the 'guide window' that you see when you when you snap a window to the left of the screen, and unity shows you that it will be maximized on the left half of the screen.

It's my impression that I have seen this bug only in sessions where I have previously snapped a window to the left or right. If I haven't done so, since I logged in, I don't see this spurious 'guide window'. I can't be sure if that's 100% accurate. Thanks.

summary: - Week33 - Empty translucent window appears while switching between
+ Week33 - Grid highlight window appears while switching between
workspaces
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz-core:
status: New → Confirmed
Omer Akram (om26er) wrote :

I reported that last night on IRC to Renato, I believe it started with bzr3307

affects: compiz-core → compiz
Nice Testhouse (testhouse) wrote :

Week 34: Same issue observed again on ubuntu quantal with ppa:timo-jyrinki/prerelease on machines with (Intel, Nvidia, Radeon) GPU

Edward Donovan (edward.donovan) wrote :

It looks like I was wrong, about seeing this after snapping a window to the side. I'm seeing the bug in sessions where I don't have any snapped windows, and don't recall having made any. Thanks.

Omer Akram (om26er) on 2012-08-29
Changed in compiz:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-1
Sami Jaktholm (sjakthol) wrote :

A little more reliable way to reproduce this bug:
1. Open a new window (not maximized)
2. Start workspace switcher
3. Click once on the opened, non-maximized window [Workspace switcher closes]
4. Move mouse to the top/left/right edge of your screen
5. An orange grid overlay appears covering whole/left half/right half screen

Changed in compiz:
milestone: none → 0.9.8.2
Omer Akram (om26er) on 2012-09-04
Changed in compiz (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-1 → ubuntu-12.10-beta-2
Edward Donovan (edward.donovan) wrote :

 I've been seeing a new behavior for a couple weeks now. (I'm afraid I don't recall the version when I first saw it.)

Once in a while, after the grid highlight window appears, an actual window from another workspace appears in the highlighted area, snapping into that half-maximized position. Without me ever touching that window.

Thanks.

Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Daniel d'Andrada (dandrader) wrote :

I use the top left and top right corners to activate the scale (window selection) and the expo (workspace selection) plugins respectively. Frequently when doing so (either window or workspace selection) I get the grid plugin effect showing up.

Nice Testhouse (testhouse) wrote :

Week 38 - Same issue observed on Ubuntu 12.10 Quantal with ppa:unity-team/staging

Jeffrey Tees (jeff-tees) wrote :

Acer Aspire One D260 (Intel Atom)

- Just ran update to 12.10 from 12.04, plus most recent updates

I am observing the orange translucent half-screen appear on a regular basis whenever I move the pointer to either left or right edge of screen (does not appear on my system if pointer moved to top or bottom of screen) and appears either on left or right half dependant on which side of the screen edge the pointer is.

The overlay is persistent even if Hud or menu screen are entered, and does not seem to matter if window on screen is maximsed or not and only goes away if workspace switcher is activated.

Have not noted any windows moving into this area from other workspaces, but I've only just upgraded and have not started real work yet.

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Fabio Marconi (fabiomarconi) wrote :

no more affecting my system.
nvidia with propretary experimental.
Can someone confirm ?

Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3394

Changed in compiz:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.8.4-0ubuntu1

---------------
compiz (1:0.9.8.4-0ubuntu1) quantal-proposed; urgency=low

  * debian/control:
    - Add dependency on gnome-settings-daemon for compiz-gnome, since some
      tests need the g-s-d gsetting schemas
  * New upstream release.
    - FTBFS with -DCOMPIZ_BUILD_TESTING=OFF if libgtest-dev is not installed
      (LP: #1057421)
    - [performance] glXSwapIntervalEXT called every frame, which is very slow
      on Nvidia. (LP: #1051286)
    - opacify plugin: opacity isn't reset after switching window (LP: #1050757)
    - cmake fails on python 2.6 as sys.version_info does not contain
      major_version or minor_version (LP: #1048964)
    - scale mode is not visible if a fullscreen window is unredirected
      (LP: #1047168)
    - Unredirected fullscreen windows flicker briefly when another window
      (like a menu) opens above them (LP: #1046664)
    - Week33 - Grid highlight window appears while switching between workspaces
      (LP: #1037142)
    - gtk-window-decorator leaks large numbers of pixmaps and pixmap memory
      (LP: #1057263)
    - [fglrx] compiz crashed with SIGSEGV in glXDestroyContext()
      [/usr/lib/fglrx/libGL.so.1] from GLScreen::~GLScreen() (LP: #1054724)
    - Maximized window gets unredirected when it's not fullscreen
      (LP: #1053902)
    - Double shortcuts conflict with gnome-control-center ones (LP: #1050796)
    - gtk-window-decorator leaking window handles. Window operations become
      sluggish after a few days of usage (LP: #1050610)
    - [valgrind] Up to 520,000 bytes lost when running
      CCSGSettingsBackendConceptTest (LP: #1049169)
    - 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
      wrong values (LP: #1042041)
    - Compiz r3275 breaks VirtualBox Guest Additions: black screen or just
      wallpaper (LP: #1030891)
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - ARM build broken with 'swapInterval' is not a member of 'GL'
      (LP: #1056645)
    - compiz.fix_927168 broke ARM building (LP: #1052838)
    - compiz crashed with SIGSEGV in __strcasestr_ia32() from
      ccsStringToModifiers(binding=NULL) (LP: #1041535)
  * Cherry-picked from upstream:
    - ABI bump due to an ABI change in the composite plugin
    - Removed schema keys still used in keybindings and automated tests
      (LP: #1057955)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 27 Sep 2012 15:43:59 +0200

Changed in compiz (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in compiz:
status: Fix Released → Fix Committed
Daniel van Vugt (vanvugt) wrote :

ps-jenkins needs a bigger brain.

Changed in compiz:
status: Fix Committed → Fix Released
Taras (tiras-dude) wrote :

The bug is still there in package compiz - 1:0.9.8.6-0ubuntu1.

Quantal amd64
Nvidia Proprietary 310 from official repository.
VirtualBox

Cheers

Taras (tiras-dude) wrote :

Forgot to mention, that disabling grid in compizconfig helps get rid of it.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1037142

tags: added: package-qa-testing
To post a comment you must log in.