[regression] compiz crashed with SIGSEGV in g_main_context_iteration() from ... from CcpScreen::timeout()

Bug #1036490 reported by Edward Donovan on 2012-08-14
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
High
Daniel van Vugt
compiz (Ubuntu)
High
Unassigned

Bug Description

My session on vt7 had been hidden, while a second user session had been running on vt8. The second user logged out, and the display came back to my session, showing LDM with 'click to log in'. I clicked, and on return to my session, compiz crashed. It restarted automatically, with my applications still running and apport popped up. (Though Firefox windows were visually corrupted, I had to quit the app.)

Don't know if these circumstances could be relevant: there had been unusual memory pressure on the system; the second session had had a giant firefox instance running, and the system was into swap, for the first time I can remember. The other user's programs were all done, and the system was paging things around while I resumed my session.

On another occasion, returning to my session had left a white screen; apps were running but inacessible. I considered that an instance of bug 966744, but I'm not too sure.

I can't try to reproduce this right now, but hope to have a chance soon. Thanks.

Intel video drivers on Ivy Bridge HD4000 graphics.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: compiz-core 1:0.9.8+bzr3249-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
CrashCounter: 1
Date: Tue Aug 14 00:01:52 2012
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f20c8c15120 <gdk_property_change>: mov 0x18(%rdi),%rax
 PC (0x7f20c8c15120) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 gdk_property_change (window=0x0, property=0x68, type=0x4, format=32, mode=GDK_PROP_MODE_REPLACE, data=0x204dfc0 "\224", nelements=10) at /build/buildd/gtk+3.0-3.5.10/./gdk/gdkwindow.c:11360
 _gtk_selection_request (widget=0x1e8e6d0, event=0x7f20a402e180) at /build/buildd/gtk+3.0-3.5.10/./gtk/gtkselection.c:2453
 _gtk_marshal_BOOLEAN__BOXEDv (closure=0x10aaa70, return_value=0x7fff6dcc3450, instance=0x1e8e6d0, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x10aaaa0) at /build/buildd/gtk+3.0-3.5.10/./gtk/gtkmarshalers.c:130
 _g_closure_invoke_va (closure=0x10aaa70, return_value=0x7fff6dcc3450, instance=0x1e8e6d0, args=0x7fff6dcc3618, n_params=1, param_types=0x10aaaa0) at /build/buildd/glib2.0-2.33.8/./gobject/gclosure.c:840
 g_signal_emit_valist (instance=0x1e8e6d0, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fff6dcc3618) at /build/buildd/glib2.0-2.33.8/./gobject/gsignal.c:3211
Title: compiz crashed with SIGSEGV in gdk_property_change()
UpgradeStatus: Upgraded to quantal on 2012-06-14 (60 days ago)
UserGroups: adm cdrom dip lpadmin nopasswdlogin plugdev sambashare sudo

Related branches

Edward Donovan (edward.donovan) wrote :
visibility: private → public
description: updated
description: updated

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Daniel van Vugt (vanvugt) wrote :

This is a regression of bug 970488.

It appears we lost the fix for that bug when the ccp plugin was merged into the main 0.9.8 tree.

summary: - compiz crashed with SIGSEGV in gdk_property_change()
+ compiz crashed with SIGSEGV in g_main_context_iteration() from ... from
+ CcpScreen::timeout()
summary: - compiz crashed with SIGSEGV in g_main_context_iteration() from ... from
- CcpScreen::timeout()
+ [regression] compiz crashed with SIGSEGV in g_main_context_iteration()
+ from ... from CcpScreen::timeout()
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
importance: Undecided → High
milestone: none → 0.9.8.0
tags: added: regression-release
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Triaged
Changed in compiz (Ubuntu):
status: New → Triaged
Edward Donovan (edward.donovan) wrote :

Thank you, Daniel, for seeing what was going on -- much, much sooner that I was going to.

tags: added: compiz-0.9
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz:
status: Triaged → In Progress
Changed in compiz:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3308

Launchpad Janitor (janitor) wrote :
Download full text (7.9 KiB)

This bug was fixed in the package compiz - 1:0.9.8+bzr3319-0ubuntu1

---------------
compiz (1:0.9.8+bzr3319-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/patches/ubuntu-config.patch:
    - refresh with latest trunk
  * debian/*docs:
    - remove the TODO copy now removed upstream
  * debian/compiz-plugins.install:
    - install stackswitch, trip plugins
  * debian/rules, debian/control:
    - remove the compiz gnome-control-center key sedding through metacity.
      Compiz now directly ships them.
    - we do not need metacity-common anymore as a build-dep then
  * debian/compiz-gnome.migrations, debian/control:
    - build-dep on dh-migrations and ship gconf -> gsettings migration file

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix Compiz crash in movementWindowOnScreen (LP: #1015151)
    - Start window decorator when decor plugin starts (LP: #1014461)
    - Fixed: Crash in compiz::wall::movementWindowOnScreen (LP: #1015151)
    - Don't waste memory leaving /bin/sh running (LP: #1015422)
    - Add reliable detection of the compiz bin directory (LP: #1015898)
    - Check if the window would actually paint before painting the shadow,
      since it is possible that another plugin could be inhibiting paint of
      the dock window. (LP: #1012956)
    - Don't insert the window into the server list above the window it was
      created above. (LP: #1008020) (LP: #886605)
    - makes compiz enhanced zoom and show mouse plugins considerably
      smoother to use (LP: #930783)
    - Don't set decoration contexts on undecorated windows, since that
      might be read later and code will assume the window is decorated when
      it isn't. (LP: #1015593)
    - Fix potentially unterminated string leading to an uninitialized memory
      read (LP: #1018302)
    - Lift the 31/32 character restriction on key names that was causing so
      many warnings. It's now 1024 characters according to glib. (LP: #1018730)
    - Don't print the result of BUILD_DEB. It prevents ccsm et al from
      installing. (LP: #1018916)
    - Use the XDamage extension more efficiently (the way it was designed to be
      used). This dramatically reduces CPU usage, reduces wakeups, and
      increases frame rates. It also solves at least one observed performance
      bug (LP: #1007299) and probably several more.
    - Do the initial work to get libcompizconfig under test. (LP: #990690)
    - Add support for initiating window picker in other than nomal mode. For
      now added only the additional 'All windows' picker (LP: #933776)
      (LP: #955035)
    - Fixes (LP: #1018602) : An invalid read when using g_variant_iter_loop.
    - Don't allow unbinds of textures kept around for animations in any case,
      not just resizing. (LP: #1016366)
    - Wait for the server to finish processing requests before doing a bind
      (LP: #1016367)
    - Using the next/previous bindings the wall plugin didn't calculate
      correctly the next workspace when it reaches the begin or the end of a
      row of workspaces, so it didn't jump to the n...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers