Multi-Monitor. Workspace switcher on monitor 2 is drawn under launcher

Bug #1031710 reported by Nice Testhouse on 2012-08-01
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Christopher Townsend
0.9.10
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend

Bug Description

12.04 precise with ppa:sil2100. All GPUs

Whilst running 2 monitors and having launcher on all desktops.
clicking on the workspace switcher
the workspaces on monitor 2 are drawn under the laucher. See screen shot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.14.0-0ubuntu2~test2 [origin: LP-PPA-sil2100-precise]
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic-pae 3.2.21
Uname: Linux 3.2.0-27-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CrashDB: unity
CurrentDmesg:
 [ 16.082223] tg3 0000:03:00.0: eth0: Link is up at 100 Mbps, full duplex
 [ 16.082225] tg3 0000:03:00.0: eth0: Flow control is off for TX and off for RX
 [ 16.082329] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 26.547020] eth0: no IPv6 routers present
Date: Wed Aug 1 11:40:26 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Cedar PRO [Radeon HD 5450] [1002:68f9] (prog-if 00 [VGA controller])
   Subsystem: Dell XPS 8300 [1028:010e]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: Dell Inc. Inspiron 580
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic-pae root=UUID=4cf29856-233b-4450-9075-65f6e2e49281 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/30/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 033FF6
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd11/30/2009:svnDellInc.:pnInspiron580:pvr:rvnDellInc.:rn033FF6:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: Inspiron 580
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.8-0ubuntu1.2
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Nice Testhouse (testhouse) wrote :
tags: added: multimonitor
Changed in unity:
importance: Undecided → Medium
Changed in compiz:
importance: Undecided → Medium
milestone: none → 0.9.8.0
Changed in unity:
milestone: none → 6.2
Omer Akram (om26er) on 2012-08-02
Changed in compiz:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in unity:
milestone: 6.4 → 6.6
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in unity:
milestone: 6.6 → 7.0
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Stephen M. Webb (bregma) wrote :

The offset/overlap on the second monitor because significantly more pronounced after upgrading to raring from quantal.

Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-04-26
Changed in unity:
milestone: 7.0.1 → 7.1.0
summary: - Multi-Monitor. Workspace swither on monitor 2 is drawn under launcher
+ Multi-Monitor. Workspace switcher on monitor 2 is drawn under launcher
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
status: Confirmed → In Progress
Changed in compiz:
status: Confirmed → In Progress
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.0 → 0.9.11.0
Stephen M. Webb (bregma) on 2013-07-26
Changed in unity:
milestone: 7.1.0 → 7.1.1
Christopher Townsend (townsend) wrote :

This is really an issue with the Expo plugin in Compiz and not in Unity. Removing the Unity part of the bug.

no longer affects: unity
Changed in compiz (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.10 at revision None, scheduled for release in compiz, milestone 0.9.10.2

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130828.2-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130828.2-0ubuntu1) saucy; urgency=low

  [ Chris Townsend ]
  * Removed logic in the calculateWallOffset() function in the Expo
    plugin that only accounted for offsetting the expo animation on the
    left-most and top-most monitor. Also removed the
    TestNoOffsetIfOutputIsNotOrigin test since this test is now invalid.
    (LP: #1031710)
  * Ctrl-Alt-Del should open the gnome-system-monitor at the processes
    tab. This fix uses the commands plugin to override the default
    action. This includes: - Install the commands plugin by default. -
    Breaks/Replaces the compiz-plugins package for versions earlier than
    0.9.10. - Patch commands.xml and integrated.xml to map gnome-system-
    monitor to Ctrl-Alt-Del by default. - Start the command plugin upon
    Compiz starting. (LP: #890747)

  [ Łukasz 'sil2100' Zemczak ]
  * Fix the Replaces/Breaks version in the default plugin

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3785
 -- Ubuntu daily release <email address hidden> Wed, 28 Aug 2013 19:13:51 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision None, scheduled for release in compiz, milestone 0.9.11.0

Changed in compiz:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

marking as closed (0.9.10 series is obsolete)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints