Laggy/ghosting rectangle is visible with Unity/Compiz

Bug #1012401 reported by yossarian_uk on 2012-06-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Low
Compiz Linaro Team
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

When running the Unigine heaven benchmark demo

http://unigine.com/products/heaven/

In Unity (3D) there are rendering issues (i.e a weird rectangle in the middle of the screen) when running in Fullscreen that doesn't occur in any other desktop environment I have tried - i.e cinnamon, kde, lxde, xfce, Unity2d

I have a Nvidia 450gts , also unity 3d is far slower at 3d rendering that other DE's.

I have latest updates for Ubuntu 12.04 .

Related branches

Daniel van Vugt (vanvugt) wrote :

Hi, could you please test Gnome Classic too (install "gnome-session-fallback")? That will allow us to determine if the problem is compiz or unity.

If possible, please also provide a screenshot or video of the problem.

Changed in unity (Ubuntu):
status: New → Incomplete

Hi

Thanks for the response.

I will test tonight and let you know.

A screen shot won't really show it - its like the middle of the screen
is lagging compared to the rest of the screen - this only happens with
Unity3D so far.

Can you suggest a (good) method of recording a small vid (for a full
screen app) ?

Many regards

On 13 June 2012 03:20, Daniel van Vugt <email address hidden> wrote:
> Hi, could you please test Gnome Classic too (install "gnome-session-
> fallback")? That will allow us to determine if the problem is compiz or
> unity.
>
> If possible, please also provide a screenshot or video of the problem.
>
> ** Changed in: unity (Ubuntu)
>       Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1012401
>
> Title:
>  unity (3D) + Nvidia has rendering issues with Unigine heaven benchmark
>  - Unity 2D is fine as are all other DE's (kde,xfce,etc)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1012401/+subscriptions

I think I might know what you mean.

In compiz, if you have multiple rectangles of the screen being updated simultaneously, compiz will render each separately. If those rectangles overlap at all, then sometimes you might see one rectangle get rendered a frame before/after the other. This can happen particularly if you have sync to vblank enabled and rendering of some of the rectangles takes longer than the refresh rate of your monitor. Then the remainder will be drawn on the next refresh cycle of the monitor and you will see a ghostly rectangle that lags compared to its surroundings.

This is something I think we can fix in the opengl plugin. But until then there are a couple of potential workarounds in CCSM. You will need to install package compizconfig-settings-manager and then run: ccsm

Workaround #1:
OpenGL > Sync To Vblank = off

Workaround #2:
Workarounds > Force full screen redraws (buffer swap) on repaint

Daniel van Vugt (vanvugt) wrote :

Normally, to record a desktop video, install: gtk-recordmydesktop

However, since this sounds like a hardware sync problem that won't be visible if recorded in software, you should probably take a video with a camera or phone instead.

Omer Akram (om26er) on 2012-06-13
Changed in unity:
status: New → Incomplete
yossarian_uk (morgancoxuk) wrote :

Ok a couple of things I have found out....

Firstly this is not just 1 PC - I have an my new i5 / nvidia 450gts and and older amd x2 4600/nvidia 8500 - completely different motherboard types, etc - same issues.

gnome-session-fallback - gives the exact same issues. (unless I disable compiz effects) so its a Compiz issue by the looks of things...

Workaround #1: OpenGL > Sync To Vblank = off :-

- This worked to solve the rectangle issue !
- however performance was still really really terrible,
- its odd, it registers the same fps as when you disable compiz however its really jerky, unresponsive and totally not acceptable
- its the same with pretty much all fullscreen games under compiz on my 450gts is like watching a geforce FX...
- if compiz is disabled (i.e gnome-fallback / no effects) its normal, the difference is obvious, its almost like having a GPU upgrade in comparison.

Workaround #2: Force full screen redraws (buffer swap) on repaint

- Sorry couldn't find that option...

However if I enable

composite -> "unredirect fullscreen windows" it fixes ALL performance issues - regardless of the ' Sync To Vblank' setting ... It's the same speed as kde (with /without desktop effects), xfce, lxde, etc

So for anyone having any speed, rendering issues with unity it is worth trying to enable that option.

Daniel van Vugt (vanvugt) wrote :

Thanks for testing all that. Glad you found a workaround that works for you.

This bug will remain open regarding the laggy/ghosting square issue.

Please discuss performance issues in bug 988079 or elsewhere. One bug per bug report :)

summary: - unity (3D) + Nvidia has rendering issues with Unigine heaven benchmark -
- Unity 2D is fine as are all other DE's (kde,xfce,etc)
+ Laggy/ghosting rectangle is visible with Unity/Compiz
Changed in compiz:
status: New → Confirmed
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
no longer affects: unity
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
yossarian_uk (morgancoxuk) wrote :

Is there an ETA when this is going to be fixed.

'Out of the box' Unity still has this issue.

i.e one of the best 3d bechmarking apps doesn't render correctly in ubuntu (unity) it does in just about any other desktop...

Daniel van Vugt (vanvugt) wrote :

This was fixed, or at least hidden by the default settings, with the introduction of new buffer-swapping code in compiz 0.9.8.0, which should hit Ubuntu 12.10 soon.

Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → Compiz Linaro Team (compiz-linaro-team)
milestone: none → 0.9.8.0
status: Confirmed → Fix Released
importance: Undecided → Low
Daniel van Vugt (vanvugt) wrote :

... so therefore it seems...

This bug was fixed in the package compiz - 1:0.9.8.0-0ubuntu1

---------------
compiz (1:0.9.8.0-0ubuntu1) quantal-proposed; urgency=low

  * debian/control, debian/rules:
    - enable gles on armel and armhf
    - use dh-translations rather than custom code

  [ Sam Spilsbury ]
  * Enable OpenGL ES building
    - Refresh debian/patches/workaround_broken_drivers.patch
    - Remove non-ported plugins from compiz-plugins
    - Add FindOpenGLES2.cmake to compiz-dev

  [ Timo Jyrinki ]
  * New upstream release.
    - Code to make compiz work on GLES. This includes several changes
      to the compiz API. (LP: #201342) (LP: #901097) (LP: #1004251)
      (LP: #1037710)
    - Draft first 0.9.8.0 NEWS and bump VERSION
  * debian/patches/compiz-package-gles2.patch:
    - Remove, obsoleted by the upstream GLES work
  * Disable plugins that don't work on pure GLES on armhf/armel:
    - bench, firepaint, mblur, showmouse, splash, showrepaint, td, widget
 -- Sebastien Bacher <email address hidden> Fri, 31 Aug 2012 22:59:50 +0200

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers