vpswitch plugin doesn't consume keyboard events (keys are sent to the active window)

Bug #953834 reported by Jean-Baptiste Lallement on 2012-03-13
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
Medium
Daniel van Vugt
Compiz Viewport Switcher Plugin
Fix Committed
Medium
Daniel van Vugt
compiz-plugins-main (Ubuntu)
High
Canonical Desktop Experience Team
Precise
High
Canonical Desktop Experience Team

Bug Description

TEST CASE:
1. In keyboard shortcut setting, set keybindings CTRL+Fn to switch to workspace n
2. In Workspace 1, open a terminal and give it focus
3. Switch to Workspace 2 with CTRL+F2
4. Switch back to WS1 and check the content of the terminal

ACTUAL RESULT:
Terminal shows the string ";5Q"

EXPECTED RESULT
Content of the terminal is unchanged

This is even worst with Firefox for example, because CTRL+F4 is the shortcut to close tabs, which means that when firefox has focus, and I switch to WS4, it closes the active tab.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz-plugins-main 1:0.9.7.0~bzr19-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Tue Mar 13 09:56:25 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: compiz-plugins-main
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Daniel van Vugt (vanvugt) wrote :

Quote: "Please log a bug agains compiz-plugins-main. The problem is VPSwitchScreen::terminateNumbered returning false (should be true)"

Changed in compiz-plugins-main:
status: New → Triaged
Changed in compiz-vpswitch-plugin:
importance: Undecided → Medium
status: New → Triaged
Changed in compiz-plugins-main:
importance: Undecided → Medium
summary: - compiz doesn't consume keyboard events (CTRL+Fn)
+ vpswitch plugin doesn't consume keyboard events (CTRL+Fn)
Changed in compiz-plugins-main:
milestone: none → 0.9.7.0
milestone: 0.9.7.0 → none

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
summary: - vpswitch plugin doesn't consume keyboard events (CTRL+Fn)
+ vpswitch plugin doesn't consume keyboard events (keys are sent to the
+ active window)
tags: added: rls-mgr-p-tracking
Changed in compiz-plugins-main (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
tags: added: rls-p-tracking
Changed in compiz-vpswitch-plugin:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-plugins-main:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-plugins-main:
status: Triaged → In Progress
Changed in compiz-vpswitch-plugin:
status: Triaged → In Progress
Lee Willis (junk-talpa) wrote :

I've marked Bug #953349 as a duplicate of this bug.

Changed in compiz-plugins-main:
milestone: none → 0.9.7.2
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-plugins-main at revision 24

Changed in compiz-plugins-main:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-vpswitch-plugin at revision 58

Changed in compiz-vpswitch-plugin:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu7

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu7) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/patches/shift_954079.patch:
    - cherry picked the shift plugin patch for fixing an issue with compiz crashes
      on right-click. This removes an unused option in the plugin. (LP: #954079)
  * debian/patches/fix_broken_build.patch:
    - fixes the build with the newer compiz
  * debian/patches/vpswitch_953834.patch:
    - don't pass through keystrokes you are using to the active window (LP: #953834)

  [ Didier Roche ]
  * debian/control:
    - bump compiz-dev and libcompizconfig0-dev build-dep for ABI break
  * debian/patches/fix_930192.patch:
    - Animations of large or full-screen windows skip frames (not smooth) (LP: #930192)
 -- Didier Roche <email address hidden> Wed, 21 Mar 2012 11:46:41 +0100

Changed in compiz-plugins-main (Ubuntu Precise):
status: Confirmed → Fix Released
joopbraak (joopbraak) on 2012-03-27
description: updated
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Main Plugins 0.9.7.2

Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers