Fit Zoomed Area to Window Enabled

Bug #953278 reported by johnf on 2012-03-12
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
Undecided
Matthias Niess
compiz-plugins-main (Ubuntu)
Undecided
Unassigned

Bug Description

By default in 12.04 the "Fit zoomed area to window" functionality of the Enhanced Zoom Desktop plugin is enabled. If you press Super+r you will zoom your desktop to fit the currently focused window. There is no way to zoom out after and it's difficult to interact with the desktop. Using CCSM I was able to create a new binding and to zoom out.

I believe that this function should be disabled by default, if there's a compeling reason to leave it enabled their should be a way to zoom out as well.

This binding affects Super+R, a common key press for people coming from windows or running windows VMs, which may increase the impact on Ubuntu users.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.0~bzr2995-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Mar 12 14:41:27 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.8, 3.2.0-17-generic, x86_64: installed
 virtualbox, 4.1.8, 3.2.0-18-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d2]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: LENOVO 417152U
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=98330161-4187-4750-9a8b-c3d9cf840798 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/16/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET28WW (1.05 )
dmi.board.asset.tag: Not Available
dmi.board.name: 417152U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET28WW(1.05):bd02/16/2011:svnLENOVO:pn417152U:pvrThinkPadT420s:rvnLENOVO:rn417152U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 417152U
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

johnf (johnfzc) wrote :
Doug McMahon (mc3man) wrote :

The option is only seen in gconf-editor which makes it unknown to most users. There is no key in gconf to reverse unless it's to hit Super+R again which doesn't work

Changed in compiz (Ubuntu):
status: New → Confirmed
bwat47 (bwat47) wrote :

Same issue here. To get out of it I ended up goin to a tty and rebooting. hitting super + r again did nothing.

Patrick Gillespie (vermontpoet) wrote :

Same here. Had Super+R assigned to Run on the Xubuntu side. Pressed it absent-mindedly in 12.04 Beta (Unity) and couldn't get out of it. Had to hard reboot.

johnf (johnfzc) wrote :

If you are able to launch CCSM while you are experiencing this issue then you can create a new key mapping inside the Enhanced Zoom Desktop plugin that will permit you to zoom out. I was able to do this but I could only really manipulate the window because I could use it on my second desktop. It was almost impossible to interact with the zoomed in desktop.

anatoly techtonik (techtonik) wrote :

I've managed to get rid of it without reboot by disabling Accessibility feature in CCSM, after which Unity crashed, but windows were restored ok.

It would interesting to dig the source history to ask the author of this idea. =)

Achim Behrens (k1l) wrote :

just had this "bug".

toggle didnt work. could manage to get into ccsm because the zoom was only on the external monitor. disabled the ezoom plugin and after some hanging unity restartet and all opened windows were still open.

Matt Deaton (matt-d10online) wrote :

I found this bug by mistake this morning. I found out I could get back to "normal" by hitting Super + R again as long as I was on an empty desktop. Super + R zoomed in on a open window Ctrl + Atl + arrow key to an empty desktop Super + R zoomed out to normal.

Matthias Niess (mniess) wrote :

Okay.. I don't think this is wanted behavior.. I just found the schema that sets this default. I always wanted to try the nice bzr/launchpad integration, so I'll assign myself now ;)

Changed in compiz (Ubuntu):
assignee: nobody → mniess (mniess)
Matthias Niess (mniess) on 2012-03-26
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
assignee: mniess (mniess) → nobody
Changed in compiz-plugins-main:
assignee: nobody → mniess (mniess)
status: New → Fix Committed
Matthias Niess (mniess) on 2012-03-26
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Didier Roche (didrocks) on 2012-03-28
Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu8

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu8) precise; urgency=low

  [ Matthias Niess]
  * debian/patchs/ubuntu-config.patch:
    - disable ezoom bad default of Super+r causing zoom to current window
      (LP: #953278)

  [ Didier Roche ]
  * debian/patches/ubuntu_config.patch: (LP: #969235)
    - update shortcuts per design request:
      Ctrl + Super + Cursor Left or Right Semi-maximises current window
 -- Didier Roche <email address hidden> Tue, 03 Apr 2012 15:45:04 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers