12.04, Compiz Wall plugin default shortcut keys are incorrect

Bug #940085 reported by psypher on 2012-02-24
128
This bug affects 21 people
Affects Status Importance Assigned to Milestone
compiz-plugins-main (Ubuntu)
High
Didier Roche
metacity (Ubuntu)
High
Didier Roche

Bug Description

Since updating this morning the shortcut keys for "move within wall" changed from the know default of ctrl+alt+left/right/up/down to
shift+super+left/right/up/down.

Yet to move an application within a wall is still the same??

This same key combination has been like this for years, please elaborate as to why it has to change now?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.0~bzr2995-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
.tmp.unity.scope.cities: Error: [Errno 21] Is a directory: '/tmp/unity-scope-cities'
.tmp.unity.support.test.0:

ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Feb 24 08:38:31 2012
DistUpgraded: Log time: 2011-12-21 10:30:51.848974
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.8, 3.2.0-17-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 NVIDIA Corporation GF106 [GeForce GT 445M] [10de:0dd2] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:046c]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
MachineType: Dell Inc. XPS L701X
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=4d02337e-4d2f-46d2-8ff7-6bfd4cd1fb0a ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to precise on 2011-12-21 (64 days ago)
dmi.bios.date: 11/29/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/29/2010:svnDellInc.:pnXPSL701X:pvrA06:rvnDellInc.:rn:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: XPS L701X
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

psypher (psypher246) wrote :
Download full text (3.6 KiB)

On Fri, 24 Feb 2012, psypher wrote:

> Public bug reported:
>
> Since updating this morning the shortcut keys for "move within wall" changed from the know default of ctrl+alt+left/right/up/down to
> shift+super+left/right/up/down.
>
> Yet to move an application within a wall is still the same??
>
> This same key combination has been like this for years, please elaborate
> as to why it has to change now?
>

The keys were changed on request from design. I am not sure about
move-within-wall, but either it should be disabled or changed to be
consistent.

> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: compiz 1:0.9.7.0~bzr2995-0ubuntu5
> ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
> Uname: Linux 3.2.0-17-generic x86_64
> .tmp.unity.scope.cities: Error: [Errno 21] Is a directory: '/tmp/unity-scope-cities'
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.93-0ubuntu2
> Architecture: amd64
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> Date: Fri Feb 24 08:38:31 2012
> DistUpgraded: Log time: 2011-12-21 10:30:51.848974
> DistroCodename: precise
> DistroVariant: ubuntu
> DkmsStatus: virtualbox, 4.1.8, 3.2.0-17-generic, x86_64: installed
> EcryptfsInUse: Yes
> GraphicsCard:
> NVIDIA Corporation GF106 [GeForce GT 445M] [10de:0dd2] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Dell Device [1028:046c]
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
> MachineType: Dell Inc. XPS L701X
> PackageArchitecture: all
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=4d02337e-4d2f-46d2-8ff7-6bfd4cd1fb0a ro quiet splash vt.handoff=7
> SourcePackage: compiz
> UpgradeStatus: Upgraded to precise on 2011-12-21 (64 days ago)
> dmi.bios.date: 11/29/2010
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A06
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A06
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.chassis.version: A06
> dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/29/2010:svnDellInc.:pnXPSL701X:pvrA06:rvnDellInc.:rn:rvrA06:cvnDellInc.:ct8:cvrA06:
> dmi.product.name: XPS L701X
> dmi.product.version: A06
> dmi.sys.vendor: Dell Inc.
> version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
> version.ia32-libs: ia32-libs N/A
> version.libdrm2: libdrm2 2.4.30-1ubuntu1
> version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu1
> version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
> version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu1
> version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
> version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
> version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
> version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
> version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2
>
> ** Affects: compiz (Ubuntu)
> Importance: Undecided
> Status: New
>
>
> ** Tags: amd64 apport-bug compiz-0.9 precise ubuntu
>
> --
> You received this bug notification because you are a member of compiz
> pa...

Read more...

psypher (psypher246) wrote :

Thats very dissapointing. I would like to know the reason for this? Now I keep having to hide the dash cos it keeps popping up after doing shift super. Or while holding down dash and moving between windows the dash overlay screen comes on over the desktop wall.

This is a bad design decision unless there is a really good reason to use ctrl alt for something else. these keys have been this way for as long as I have been used multiple desktops.

psypher (psypher246) wrote :

I would like to add that there is another bug caused by this. now the overlay numbers brought up over the primary icons in the dash stay there after you perform a shift+super shortcut key combo. only way to get them away is to hold the super key down for a while and let go

Sam_ (and-sam) wrote :

Changelog is there.
metacity (1:2.34.1-1ubuntu6) precise; urgency=low

  * debian/metacity-common.gconf-defaults:
    toggling keybindings value as per design request (metacity and integration
    with gnome-control-center part for compiz): (LP: #891757)
    - Show desktop is <Super>d
    - Maximize is <Super>Up
    - UnMaximize is <Super>Down
    - Toggle Maximize is <Control><Alt>KP_5
    - Minimize is <Control><Alt>KP_0
    - Navigate to ws is <Super><Shift> + cursor keys
    - Move focus window to a different workspace is <Super><Alt>Cursor Keys

Sam_ (and-sam) wrote :

As reading the corresponding 891757
< ... However where there is no conflict between the existing keyboard shortcuts and the new shortcuts, the existing shortcuts should always be preserved. >

I don't see a conflict between those and ctrl+alt+arrow to switch the workspace.
In fact I've reversed it right away and made the pre-existing mandatory otherwise the reverse gets reverted again on logout or reboot. No conflict experienced here yet.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Chris (fabricator4) wrote :

However there IS conflict between the new shortcut keys and other uses of the super key. Now, when I press and hold shift-super in preparation for pressing the arrow keys I get several unwanted and annoying behaviours:

1) The Launcher pops out, all numbered up

2) The Hint screen for shortcut keys pops up and overlays the wall

3) Only _after_ the workspace is selected does the wall come to the foreground - apart from that it's behind shortcut key help screen. It's very annoying and confusing

4) The whole things works so slow that most of the time you are looking at the shortcut key hint screen, with the wall out of focus below it. Every time I press an arrow key the shortcut key help screen comes to the foreground while the animation on the wall is occurring.

5) I get very annoyed and wonder if someone actually thought this through. If this goes out as it is in LTS then it will be seriously broken.

Chris

Paul White (paulw2u) wrote :

This change affects Gnome Shell users too.

 I can't see any side affects when using Gnome Shell but it's annoying as I find Alt-Shift or Super-Shift shortcuts much more difficult to action and remember.

psypher (psypher246) wrote :

I agree with Chris. With the advent of the dash and the hud pretty much any key combo with alt or super in it sometimes bring the respective interface up and jams the process you were trying to achieve.

Ctrl-alt was however just right to switch desktops

Krzysztof Klimonda (kklimonda) wrote :

If the switch is indeed necessary could we at least try a different combination (like ctrl+super)? shift+super doesn't feel ergonomic, every time I change the workspace I feel like I'm back in emacs pressing combinations like M-x or C-x C-f

Chris Johnston (cjohnston) wrote :

I can confirm Chris' points 1, 2, and 3. All three of these do occur. The dash shows up, the hint screen shows up, and you have to wait for the hint screen to go away before you can see the wall. I can also confirm Krzysztof's point that <super><shift> does not feel ergonomic.

no longer affects: compiz-core
Maarten Kossen (mpkossen) wrote :

I agree that <super> <shift> does not at all feel ergonomic. I'd really like to know the "design" reason for this as well.

Maarten Kossen (mpkossen) wrote :

Oh man, this is *crazy*. I get the keyboard shortcut overlay all the time, the launcher sometimes stays open (I have autohide on) with the numbers on the icons and the search window pops up every now and then when switching workspaces.

Didier Roche (didrocks) on 2012-02-28
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu5

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu5) precise; urgency=low

  * debian/control:
    - build against libjpeg-dev instead of the 62 flavor
  * debian/patches/ubuntu_config.patch:
    - revert the keybinding workspace changes as we can't keep the old one in
      addition to the new one. Some plan on compiz will be done for next cycle
      to support this and give another try to the new keybinding. (LP: #940085)
 -- Didier Roche <email address hidden> Tue, 28 Feb 2012 10:59:52 +0100

Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Released
Maarten Kossen (mpkossen) wrote :

I'm not getting the old keybindings back after having installed the fixed package. Should I manually fix the key bindings? Is anybody else having this problem?

psypher (psypher246) wrote :

What exactly has been fixed? The same new keys are still default after update to: 1:0.9.7.0~bzr19

Am i supposed to be doing a unity reset to revert all my settings to the package default?

psypher (psypher246) wrote :

@Maarten, seems we had the same idea at the same time :)

Didier Roche (didrocks) on 2012-02-28
Changed in metacity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
psypher (psypher246) wrote :

FYI clicking the little restore to default icon next to the key combo in CCSM sets it correctly back to the preferred default we all know and love AND MISSED!

Trying to set the combo manually by doing key grabs does not work for some reason. pressing ctrl is not registered in the capture at all, and if you try and set it and close the app the combos don't work very well. When i went back in again and restored the default my problem was fixed, YAY!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.34.1-1ubuntu7

---------------
metacity (1:2.34.1-1ubuntu7) precise; urgency=low

  * debian/metacity-common.gconf-defaults:
    - remove the new ws keybinding as in compiz for unity-2d and some upgrade
      race thanks to compiz (LP: #940085)
 -- Didier Roche <email address hidden> Tue, 28 Feb 2012 14:19:59 +0100

Changed in metacity (Ubuntu):
status: Fix Committed → Fix Released
Oier Mees (oier) wrote :

well then the overlay hints should be corrected, since it suggests to use the wrong key combo. Is there a bug opened for that?

John Lea (johnlea) on 2012-04-19
no longer affects: ayatana-design
To post a comment you must log in.