Workspace switcher makes windows lose decorations

Bug #853951 reported by Marc Deslauriers
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Sam Spilsbury
compiz-plugins-main (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Since updating to the new workspace switcher preview layout some time last week, windows often lose decorations when using the workspace switcher.

Steps to reproduce:
1- click on the workspace switcher
2- double-click on a different desktop
3- repeat 5-10 times until window decorations don't appear

Often just clicking on a window will make them come back, but sometimes I need to switch workspaces again for them to reappear.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,vpswitch,regex,place,grid,animation,session,snap,workarounds,gnomecompat,move,mousepoll,imgpng,unitymtgrabhandles,expo,wall,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Mon Sep 19 11:34:04 2011
DistUpgraded: Log time: 2011-08-16 08:17:50.192798
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
MachineType: LENOVO 4313CTO
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=66b32bb3-1e18-436e-8f6e-62b8419ed48d ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-08-16 (34 days ago)
dmi.bios.date: 05/24/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET86WW (1.46 )
dmi.board.name: 4313CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET86WW(1.46):bd05/24/2011:svnLENOVO:pn4313CTO:pvrThinkPadT510:rvnLENOVO:rn4313CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4313CTO
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :
Didier Roche (didrocks)
Changed in unity:
milestone: none → 4.18.0
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Didier Roche (didrocks)
Changed in unity:
milestone: 4.18.0 → 4.20.0
Didier Roche (didrocks)
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in unity:
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu1

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu1) oneiric; urgency=low

  * New upstream snapshot:
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #861793)
    - sometimes, restored window placed too high (LP: #716521)
    - can't maximize windows on second monitor and Qt windows displayed in
      wrong place (LP: #861341)
  * 091_no_use_gnome_but_desktop_file.patch:
    - partially committed upstream, no more needed
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 09:21:42 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Didier Roche (didrocks)
Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
Didier Roche (didrocks)
affects: compiz (Ubuntu Oneiric) → compiz-plugins-main (Ubuntu Oneiric)
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Marc, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Ngassam Nkwenga (cyrildz) wrote :

Doesn't seem to be reproductible to be. I take it as fixed.

I'm on the proposed repository

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

I can't reproduce this either, so it appears it's properly fixed. Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4) oneiric-proposed; urgency=low

  * debian/patches/fix-872161.patch:
    - When grabbing a window to demaximize it after dragging it up,
      sometimes the position will not be where you expect it to be
      (LP: #872161)

compiz-plugins-main (1:0.9.6-0ubuntu3) oneiric-proposed; urgency=low

  * Cherry-pick upstream fixes:
    - unmaximizable windows still show orange glow but fail to maximize
      (LP: #827560)
    - compiz crashed with SIGSEGV in CompWindow::serverBorderRect()
      (LP: #834585)
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - Windows get corrupted sometimes when semi-maximizing them (LP: #865177)
    - Windows like gnome-terminal have awkward space around them after being
      semi-maximized (LP: #865179)
    - Grid plugin behaviour random (LP: #862260)
    - Don't apply snapping to maximized windows (LP: #862261)
    - snap movements can cause infinite loops in window movements (LP: #860646)
    - it is possible to see a window in it's pre-animation state during unmap
      animations (LP: #864476)
    - Rendering glitches when resuming from expo mode (LP: #868121)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:49:59 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: New → Fix Committed
Tim Penhey (thumper)
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers