staticswitcher/ Alt-Tab can be slow to appear

Bug #684843 reported by Didier Roche on 2010-12-03
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
compiz-plugins-main (Ubuntu)
High
Didier Roche
Natty
High
Didier Roche

Bug Description

Binary package hint: compiz

When pressing Alt + Tab, staticswitcher can be very slow to appear depending on the "heavyness" of the applications present on the application on the current workspace.

That's reported by people using intel and nvidia cards. It wasn't the case with compiz 0.8 on the same hardware.
It can be easily reproduce in opening an image with a big resolution on eog for instance.

so:
- go an empty workspace
- open some applications
- open eog with a "big enough" image (like 1024x768 is enough here)
- see that alt + tab takes longer and longer to appear (thumbnailing?)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.2.1+glibmainloop2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-6.17-generic 2.6.37-rc3
Uname: Linux 2.6.37-6-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: No value set for `/apps/compiz/general/allscreens/options/active_plugins'
Date: Fri Dec 3 18:02:54 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100918)
MachineType: Dell Inc. MP061
PackageArchitecture: all
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G71 [GeForce Go 7900 GS] [10de:0298] (rev a1) (prog-if 00 [VGA controller])
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-6-generic root=UUID=4b292599-da9a-4cb5-908f-a911be09c61a ro quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9~git20100924-0ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.0-1ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu1
SourcePackage: compiz
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0YD479
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd04/02/2007:svnDellInc.:pnMP061:pvr:rvnDellInc.:rn0YD479:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MP061
dmi.sys.vendor: Dell Inc.
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-6-generic

Didier Roche (didrocks) wrote :
description: updated
Paul Sladen (sladen) wrote :

Confirming, this was picked up as a side issue in the process of investigating bug #683635.

In the extreme case of this, the "paging in" of the images can cause swapping issues.

Changed in compiz (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2010-12-03
Changed in compiz (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Didier Roche (didrocks) on 2011-01-06
Changed in compiz (Ubuntu):
milestone: none → ubuntu-11.04-beta
tags: added: compiz-0.9
Sam Spilsbury (smspillaz) wrote :

Got a fix for this upcoming should be in the next upload

Changed in compiz (Ubuntu Natty):
status: Confirmed → In Progress
David Barth (dbarth) on 2011-02-09
tags: added: unity
Changed in compiz (Ubuntu Natty):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

as discussed with sam, it's not fixed and only appear on some configuration (nvidia and ATI for now) with midmapping activated

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Triaged
importance: Medium → High
tags: added: dids-top-ten
Sam Spilsbury (smspillaz) wrote :

We are currently looking into whether or not to disable mipmapping entirely since this is causing the slowness

Changed in compiz (Ubuntu Natty):
status: Triaged → In Progress
Didier Roche (didrocks) wrote :

Disabling mipmapping for now, let's revisit that for oneiric to find a more long-term solution

Changed in compiz (Ubuntu Natty):
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Didier Roche (didrocks)
affects: compiz (Ubuntu Natty) → compiz-plugins-main (Ubuntu Natty)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 0.9.4-0ubuntu3

---------------
compiz-plugins-main (0.9.4-0ubuntu3) natty; urgency=low

  * 03_default_options.patch:
    - change default option from 0.2s delay to 0s for compiz staticswitcher plugin
    - don't get a close animation on gnome-screenshot (LP: #93234)
    - Change <Super> + e to <Super> + s for switch workspace (trigger expo mode)
      in the classic session as in unity (LP: #723273)
    - deactivate mipmapping in staticswitcher as it can make alt Tab very slow
      (some seconds) on some hardware (LP: #684843)
 -- Didier Roche <email address hidden> Wed, 16 Mar 2011 19:21:19 +0100

Changed in compiz-plugins-main (Ubuntu Natty):
status: In Progress → Fix Released
Moc (mochouinard-moctel) wrote :

Reason I found it was slow to appear for me, is because of the default 0.2 second delay before it get shown in the compiz config. I think it should be defaulted to 0.0. Option name is : Popup Window Delay (popup_delay)

Shane StClair (srstclair) wrote :

Agree, popup window delay should default to 0. This fixed the issue for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers