Using grid-resize prevents windows from maximizing correctly

Bug #1093757 reported by Esokrates on 2012-12-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Undecided
Unassigned

Bug Description

Using the grid plugin to resize a window in the corner, and then maximizing the window will result in the window being maximized in-place, rather than covering the whole screen.

ORIGINAL DESCRIPTION:

If you use the shortcuts to place a window in the corners (for example the bottom left corner <Control><Alt>KP1) then some applications like Gnome Terminal get not resized correctly, which results in free spaces left to the workspace edges. (All settings for Gnome Terminal are default).
This happens for Compiz 0.9.9 using Nvidia 313.x drivers.
Most applications like Nautilus work perfect, though.
But for all tested applications one bug is common:
Part 2:
If you place the window in any corner and then press <Control><Alt>KP5 the window does not get placed correctly (the application gets resized correctly but is placed somewhere in between the workspaces. This varies from position to position. It gets distributed to all workspaces symmetric.)

Related branches

Esokrates (esokrarkose) on 2012-12-26
description: updated
Esokrates (esokrarkose) wrote :
  • 2 Edit (1.9 MiB, application/octet-stream)

Screenshot 2 and 3 were taken after placing the window in the upper left workspace in the bottom right corner.

Esokrates (esokrarkose) wrote :
  • 3 Edit (1.9 MiB, application/octet-stream)
description: updated
Esokrates (esokrarkose) wrote :

http://ubuntuone.com/7FZPuXm0KYtV9eHrlRJdf3

This bug consists of two issues:
1. The space issue is only true for specific applications as for the terminal.
2. The maximize issue is true for all applications. It only occurs for snapped windows in corners and semi maximized windows (but here in a from similar to bug 1093767).

Changed in compiz-plugins-main (Ubuntu):
status: New → Invalid
Sam Spilsbury (smspillaz) wrote :

Not specifically a problem with the ppa

Changed in compiz:
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.9.0
tags: removed: compiz-experimental-ppa
Sam Spilsbury (smspillaz) wrote :

In addition, I'm inclined to say that the spacing between the terminal windows here is not a bug.

Terminals set specific size hints so that they aren't resized to exactly fit their contents in character size. If the window can't be allocated to a position that exactly fits those size hints, then we resize it a little smaller. The only case where we don't do that is in the semi-maximize and maximize case, and that's fine.

The maximization bug, however, is.

description: updated
summary: - Placing Windows in corners does not always work as expected
+ Using grid-resize prevents windows from maximizing correctly
Sam Spilsbury (smspillaz) wrote :

Terminal spacing split out into bug 1095688

Changed in compiz:
status: New → In Progress
Changed in compiz (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
status: In Progress → Fix Committed
Esokrates (esokrarkose) wrote :

After maximizing, the window does not get placed correctly in the upper corners by using the shortcut. (e.g. <Control><Alt>KP9).
Everything else is fixed by the fix commited.
This can be seen in the following video:
http://ubuntuone.com/6N42jasIsueBiLpdCzkdBo

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3536, scheduled for release in Compiz 0.9.9.0

Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.14-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.14-0ubuntu1) raring; urgency=low

  [ sampo555 ]
  * compiz crashed with SIGSEGV in DodgeAnim::applyDodgeTransform() (LP:
    #1048840)
  * compiz crashing if window un-/minimize animation is "Random" (LP:
    #1098185)

  [ Daniel van Vugt ]
  * Several leaks in new GLProgram from compileProgram() from
    GLScreen::getProgram() from GLWindowAutoProgram::getProgram() (LP:
    #1097644)

  [ Sam Spilsbury ]
  * Several leaks in ccsIntegratedSettingListAppend() ... from
    ccsGNOMEIntegrationBackendGetIntegratedSetting() from readSetting
    (gsettings.c:375) (LP: #1097661)

  [ MC Return ]
  * Thumbnail Window Previews: Flickering of background/glow and window
    title text (LP: #1098758)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3561
 -- Automatic PS uploader <email address hidden> Mon, 14 Jan 2013 04:03:09 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers