Please remove compiz-plugins-experimental from eoan-proposed

Bug #1844626 reported by Mathieu Trudel-Lapierre
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
New
Undecided
Unassigned
compiz-plugins-experimental (Ubuntu)
Fix Released
Undecided
Unassigned
compizconfig-python (Ubuntu)
Fix Released
Undecided
Unassigned
simple-ccsm (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Please remove compiz-plugins-experimental 2:0.8.16-2

All architectures are in Dependency wait; compiz-plugins-experimental is waiting on the whole compiz stack with 2:0.8.16-2. Past feature-freeze and DI freeze, this is unlikely to land right now and may be re-synced later together with the other compiz packages.

Revision history for this message
Steve Langasek (vorlon) wrote :

I'm not sure what the correct action is here, as the package depends on an older version of compiz than we have in Ubuntu but with a higher epoch. Should the epoch on the compiz package be bumped in Ubuntu?

Changed in compiz-plugins-experimental (Ubuntu):
status: New → Incomplete
Revision history for this message
Steve Langasek (vorlon) wrote :

And if we do bump the epoch on compiz, will this package build or does it actually depend on compiz 0.8 instead of compiz 0.9?

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

It is part of compiz-reloaded (a fork of old compiz which is in debian)

https://gitlab.com/compiz

https://gitlab.com/compiz/compiz-plugins-experimental.

So it is unlikely that unlikely that it will work with 0.9.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

It will not work with Compiz 0.9 and should be removed, yes.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

These came back in groovy.
https://launchpad.net/ubuntu/+source/compizconfig-python/2:0.8.16-2
https://launchpad.net/ubuntu/+source/compiz-plugins-experimental/2:0.8.18-1

Both as expected blocked by build deps due to the epoch.
Checked on IRC:
[16:16] <cpaelzer> seb128: Laney: in proposed are all kind of things around *compiz* 2:0.8.18 most of them blocked on missing build dep (one epoch away). I come from a +1 POV, is Desktop handling these and I can go on without looking into it?
[16:18] <cpaelzer> "all kind" may be too much
[16:18] <cpaelzer> looking a bit deeper it is down to two things
[16:18] <cpaelzer> https://launchpad.net/ubuntu/+source/compiz-plugins-experimental/2:0.8.18-1
[16:18] <cpaelzer> https://launchpad.net/ubuntu/+source/compizconfig-python/2:0.8.16-2
[16:18] <seb128> cpaelzer, I don't think anyone in desktop has been working or interested by those
[16:18] <seb128> mitya57 might know better the status
[16:19] <cpaelzer> seb128: I'm clearing out packages like these - if I could get a clear "we don't need and are not interestd in those" that woudl be enough
[16:19] <cpaelzer> mitya57: let me know once you read that
[16:20] <mitya57> cpaelzer: Debian decided to use a fork of Compiz 0.8. We are using 0.9 where all code is in a single source, so all those source packages should be deleted/blacklisted.
[16:20] <cpaelzer> thank you
[16:20] <cpaelzer> will let that happen then

I'll make sync-blacklisting them part of the MP that I'll submit.
That should avoid that from happening again.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

simple-ccsm is affected as well, from excuses:

simple-ccsm (- to 2:0.8.18-1)
Migration status for simple-ccsm (- to 2:0.8.18-1): BLOCKED: Rejected/violates migration policy/introduces a regression
Issues preventing migration:
simple-ccsm has no binaries on any arch
simple-ccsm unsatisfiable Build-Depends(-Arch) on amd64: python3-compizconfig (>= 2:0.8.14-0~)
nothing built yet, autopkgtest delayed
Additional info:
106 days old

Added a bug task for it and to the list of remove&sync-block packages.

Revision history for this message
Matthias Klose (doko) wrote :

removed from groovy-proposed, and added to the sync blacklist

Changed in compiz-plugins-experimental (Ubuntu):
status: Incomplete → Fix Released
Changed in compizconfig-python (Ubuntu):
status: New → Fix Released
Changed in simple-ccsm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers