Older version still exists unlike other related packages which have moved to 0.8.2

Bug #349201 reported by Rizwan Rafique on 2009-03-26
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-unsupported (Ubuntu)
Medium
Michael Vogt
Jaunty
Medium
Michael Vogt
Karmic
Medium
Michael Vogt

Bug Description

compiz-fusion-plugins-unsupported is still 0.7.8 whereas other related packages have been bumped to 0.8.2 in jaunty.

TEST CASE:
1. install compiz-fusion-plugins-unsupported and compizconfig-settings-manager
2. try to enable the snow plugin by starting "ccsm" and selecting "snow"
3. verify that pressing ctrl-f3 does not produce snow on the screen when compiz is running

4. enable jaunty-proposed
5. install the updated compiz-fusion-plugins-unsupported
6. restart the session and repeat step 2
7. verify that pressing ctrl-f3 brings snow on the screen

It should probably be bumped to 0.8.2 or dropped altogether.

I agree. It has caused SERIOUS problems for me when I tried to solve it. Ended up losing compiz for a while, then had to reset my profile (compiz profile), then visual effects wouldn't get enabled :'(

Just upgrade the package please :)

Mohegan (jack-mohegan) wrote :

There is a problem when you install this package. In fact, we can't active the plugins (like tile). In order to resolve this, you can download the source in http://releases.compiz.org/0.8.2/compiz-plugins-unsupported-0.8.2.tar.bz2. Extract the files and :
=> configure --prefix=/usr
=> make
=> sudo make install
=> and replace compiz : Alt + F2 : compiz --replace$
With compizconfig-settings-manager, you can active the unsupported pluggins.

I think the package would be rebuild with the good source like the other compiz packages.

this is a known problem.

Changed in compiz-fusion-plugins-unsupported (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2009-04-28
Changed in compiz-fusion-plugins-unsupported (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Medium
milestone: none → jaunty-updates
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

I uploaded a fixed version to jaunty-proposed

description: updated
Martin Pitt (pitti) wrote :

please reupload with an SRUish version number, since 0.8.2-1 is in Debian and will/should be synced to karmic.

Also, please prepare bug tasks for SRU.

Michael Vogt (mvo) wrote :

Sorry for the version number error. I uploaded a fixed one now (0.8.2-0ubuntu1) and should then be copied to karmic as well.

(I accidentally uploaded a 0.8.2-1ubuntu1 (0.8.2-**1**ubuntu1) version too, please reject that as well :(

Steve Langasek (vorlon) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz-fusion-plugins-unsupported (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Changed in compiz-fusion-plugins-unsupported (Ubuntu Jaunty):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Medium
milestone: none → jaunty-updates
status: Fix Committed → New
status: New → Fix Committed
Changed in compiz-fusion-plugins-unsupported (Ubuntu Karmic):
milestone: jaunty-updates → none
Paul Elliott (omahn) wrote :

I can confirm that compiz-fusion-plugins-unsupported 0.8.2-1ubuntu1 from jaunty-proposed resolves this issue after following the test case with one minor modification.

On my system with a default install of the package, the snow plugin is mapped to Super-F3. As this is unrelated to the issue at hand that the -proposed package does resolve, I'm happy to give the package the thumbs up.

Martin Pitt (pitti) on 2009-05-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-fusion-plugins-unsupported - 0.8.2-1ubuntu1

---------------
compiz-fusion-plugins-unsupported (0.8.2-1ubuntu1) jaunty-proposed; urgency=low

  * New upstream release 0.8.2
  * the 0.7.8 version of compiz-fusion-plugins-unsupported will
    not work with compiz 0.8.2 so this update is needed (LP: #349201)
  * add compiz-fusion-plugins-main to b-d

 -- Michael Vogt <email address hidden> Tue, 28 Apr 2009 10:18:53 +0200

Changed in compiz-fusion-plugins-unsupported (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to karmic

Changed in compiz-fusion-plugins-unsupported (Ubuntu Karmic):
status: In Progress → Fix Released
Sam Liddicott (sam-liddicott) wrote :

On 9.10:

$ sudo apt-get install compiz-fusion-plugins-unsupported
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package compiz-fusion-plugins-unsupported

I have karmic-{security,updates,propsed,backports} and main,universe,restricted,multiverse selected as sources, so I don't know why I can't find my christmas snow plugin.

Steve Langasek (vorlon) wrote :

Because subsequent to being copied to karmic, compiz-fusion-plugins-unsupported was removed from karmic:

 Deleted on 2009-10-12 by James Westby
 Unsupported, outdated, currently broken (LP: #440731)

https://launchpad.net/ubuntu/+source/compiz-fusion-plugins-unsupported/+publishinghistory

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers