compiz.real crashed with SIGSEGV

Bug #145372 reported by Brett Alton on 2007-09-26
6
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-main (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

I apologize: I do not know how to add the debugging information from Apport to a current bug!

ProblemType: Crash
Architecture: i386
Date: Wed Sep 26 16:35:31 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: vmnet vmmon nvidia
Package: compiz-core 1:0.5.2+git20070918-0ubuntu5
PackageArchitecture: i386
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --loose-binding --sm-client-id default0 ccp
ProcCwd: /home/brett
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: compiz
Stacktrace:
 #0 0xb6245fad in ?? () from /usr/lib/compiz/libanimation.so
 #1 0x08643f98 in ?? ()
 #2 0xb6a14ae4 in ?? ()
 #3 0xb6a14ac0 in ?? ()
 #4 0x00000000 in ?? ()
StacktraceTop:
 ?? () from /usr/lib/compiz/libanimation.so
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: compiz.real crashed with SIGSEGV
Uname: Linux dell-xps-gen5 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video
SegvAnalysis:
 Segfault happened at: 0xb6245fad <_fini+40265>: flds 0x94(%eax)
 PC (0xb6245fad) ok
 source "0x94(%eax)" (0x008b011e) not located in a known VMA region (needed readable region)!
SegvReason: reading unknown VMA

StacktraceTop:animPreparePaintScreen (s=0x815c980, msSinceLastPaint=20) at animation.c:2164
fadePreparePaintScreen (s=0x815c980, msSinceLastPaint=20) at ../../plugins/fade.c:181
scalePreparePaintScreen (s=0x815c980, msSinceLastPaint=20) at ../../plugins/scale.c:922
expoPreparePaintScreen (s=0x815c980, ms=20) at expo.c:560
switchPreparePaintScreen (s=0x815c980, msSinceLastPaint=20) at ../../plugins/switcher.c:1286

Changed in compiz:
importance: Undecided → Medium
Kees Cook (kees) on 2009-09-16
description: updated
Travis Watkins (amaranth) wrote :

This bug was fixed some time ago and should not occur in a current release of Ubuntu (9.04).

Changed in compiz-fusion-plugins-main (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers