compiz.real crashed with SIGSEGV in polygonsUpdateBB()

Bug #144991 reported by macgee7 on 2007-09-25
22
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-main (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

I am having problems with compiz eg not running then running again with no input from me at the moment it just wont work ful stop

Regards

Earle

ProblemType: Crash
Architecture: i386
Date: Wed Sep 26 10:26:24 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: nvidia
Package: compiz-core 1:0.5.2+git20070918-0ubuntu5
PackageArchitecture: i386
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --loose-binding --sm-client-id default0 ccp
ProcCwd: /home/earle
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: compiz
StacktraceTop:
 polygonsUpdateBB (output=0x81e5ec0, w=0x850fc98)
 animPreparePaintScreen (s=0x815e188, msSinceLastPaint=13)
 infoPreparePaintScreen (s=0x815e188, ms=0)
 fadePreparePaintScreen (s=0x815e188, msSinceLastPaint=13)
 scalePreparePaintScreen (s=0x815e188, msSinceLastPaint=13)
Title: compiz.real crashed with SIGSEGV in polygonsUpdateBB()
Uname: Linux earle-desktop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video
SegvAnalysis:
 Segfault happened at: 0xb5f325e4 <getPerspectiveCorrectionMat+84>: mov 0x1c(%ecx),%edx
 PC (0xb5f325e4) ok
 source "0x1c(%ecx)" (0x0000001c) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA

macgee7 (e-lcollins) wrote :

StacktraceTop:polygonsUpdateBB (output=0x81e5ec0, w=0x850fc98) at polygon.c:1544
animPreparePaintScreen (s=0x815e188, msSinceLastPaint=13) at animation.c:2144
infoPreparePaintScreen (s=0x815e188, ms=0) at resizeinfo.c:287
fadePreparePaintScreen (s=0x815e188, msSinceLastPaint=13) at ../../plugins/fade.c:181
scalePreparePaintScreen (s=0x815e188, msSinceLastPaint=13) at ../../plugins/scale.c:922

Changed in compiz:
importance: Undecided → Medium
Kees Cook (kees) on 2009-09-16
description: updated
Travis Watkins (amaranth) wrote :

This bug was fixed some time ago and should not occur in a current release of Ubuntu (9.04).

Changed in compiz-fusion-plugins-main (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers