compiz.real crashed with SIGSEGV in fxDodgeAnimStep()

Bug #144644 reported by Rocko on 2007-09-25
6
Affects Status Importance Assigned to Milestone
compiz-fusion-plugins-main (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

This happened immediately after rebooting Gutsy following an update that required rebooting (I didn't touch anything after logging in), so I don't know exactly what caused it.

After setting desktop effects to 'no effects' and then back to normal, compiz seems to be running fine again.

ProblemType: Crash
Architecture: i386
Date: Mon Sep 24 11:21:21 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: vmnet vmmon
Package: compiz-core 1:0.5.2+git20070918-0ubuntu5
PackageArchitecture: i386
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --indirect-rendering --sm-client-id default0 ccp
ProcCwd: /home/sean
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: compiz
StacktraceTop:
 fxDodgeAnimStep () from /usr/lib/compiz/libanimation.so
 ?? () from /usr/lib/compiz/libanimation.so
 ?? ()
 ?? ()
 ?? ()
Title: compiz.real crashed with SIGSEGV in fxDodgeAnimStep()
Uname: Linux pegasus 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy lpadmin netdev plugdev powerdev scanner video
SegvAnalysis:
 Segfault happened at: 0xb75d70bf <fxDodgeAnimStep+703>: mov (%eax,%edx,4),%eax
 PC (0xb75d70bf) ok
 source "(%eax,%edx,4)" (0x000002c0) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

Seems to happen each time I reboot.

StacktraceTop:fxDodgeAnimStep (s=0x815d338, w=0x8491838, time=15) at dodge.c:113
animPreparePaintScreen (s=0x815d338, msSinceLastPaint=15) at animation.c:2137
expoPreparePaintScreen (s=0x815d338, ms=15) at expo.c:560
fadePreparePaintScreen (s=0x815d338, msSinceLastPaint=15) at ../../plugins/fade.c:181
zoomPreparePaintScreen (s=0x815d338, msSinceLastPaint=15) at ezoom.c:456

Changed in compiz:
importance: Undecided → Medium
Kees Cook (kees) on 2009-09-16
description: updated
Travis Watkins (amaranth) wrote :

This bug was fixed some time ago and should not occur in a current release of Ubuntu (9.04).

Changed in compiz-fusion-plugins-main (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers